Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Unable to connect to the network for update
Unable to connect to the network for update [message #467835] Mon, 03 August 2009 05:38 Go to next message
Eclipse UserFriend
Originally posted by: bojana.simova.gmail.com

Hi,

Installed Eclipse Platform 3.5.0.v20090611a
on Linux Red Hat.
My company is using firewall.
When I tried to check for updates or install new plug-ins, I realized
that Eclipse is not connecting to the network.
Went to Windows-> Preferences -> Network connections and configured
the proxies, using the same proxy server as in my browser, which works
perfectly. Even after this configuration, I'm still unable to connect.
Test Connection hangs for a while and then I get error message :
Unable to read repository at
http://download.eclipse.org/releases/galileo/site.xml.
Unable to read repository at
http://download.eclipse.org/releases/galileo/site.xml.
No route to host

Checked .log file in workspace directory :

!MESSAGE Connection to
http://download.eclipse.org/releases/galileo/site.xml failed on No route
to host. Retry attempt 0 started
!STACK 0
java.net.NoRouteToHostException: No route to host
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.ja va:195)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:519)

And also a bunch of these :

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:29.286
!MESSAGE System property http.proxyHost is not set but should be
my-proxy.com.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:29.286
!MESSAGE System property http.proxyPort is not set but should be 80.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:29.286
!MESSAGE System property https.proxyHost is not set but should be
my-proxy.com.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:29.286
!MESSAGE System property https.proxyPort is not set but should be 80.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:29.287
!MESSAGE System property socksProxyHost is not set but should be
my-proxy.com.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:29.287
!MESSAGE System property socksProxyPort is not set but should be 80.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:40.056
!MESSAGE System property http.proxyHost is not set but should be
my-proxy.com.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:40.056
!MESSAGE System property http.proxyPort is not set but should be 80.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:40.056
!MESSAGE System property https.proxyHost is not set but should be
my-proxy.com.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:40.057
!MESSAGE System property https.proxyPort is not set but should be 80.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:40.057
!MESSAGE System property socksProxyHost is not set but should be
my-proxy.com.

!ENTRY org.eclipse.core.net 1 0 2009-08-02 22:27:40.057
!MESSAGE System property socksProxyPort is not set but should be 80.

I don't know how am I supposed to set these system properties.

Installed the same version on Windows machine using the same proxy server
and
it works fine. Some proxies even have been added automatically at
installation time and I did not need to configure anything afterwords to
get it working.

Thanks and Regards
Re: Unable to connect to the network for update [message #482053 is a reply to message #467835] Tue, 25 August 2009 09:42 Go to previous messageGo to next message
Pascal is currently offline PascalFriend
Messages: 9
Registered: July 2009
Junior Member
Eclipse use SOCKS proxy before HTTP. So, if your companie does set a SOCKS
proxy, you should clear it in proxy preference (then eclipse use HTTP
proxy first).
Re: Unable to connect to the network for update [message #482056 is a reply to message #482053] Tue, 25 August 2009 09:44 Go to previous messageGo to next message
Pascal is currently offline PascalFriend
Messages: 9
Registered: July 2009
Junior Member
Eclipse use SOCKS proxy before HTTP. So, if your company doesn't provide a
SOCKS proxy, you should clear it in proxy preference (then eclipse use
HTTP proxy first).
Re: Unable to connect to the network for update [message #525455 is a reply to message #482056] Tue, 06 April 2010 15:52 Go to previous messageGo to next message
jackalista  is currently offline jackalista Friend
Messages: 2
Registered: April 2010
Junior Member
Hi,

I'm getting this same error (System property http.proxyPort is not set but should be 8080, the analogous error for the host too) trying to deploy a new GWT app to the app engine.

Where do I need to set these system properties so that the deploy will work? I have the settings successfully set in both firefox and eclipse, I guess it needs to be set elsewhere as well? Could someone point out where?

Thanks!

-=j=-
Re: Unable to connect to the network for update [message #649965 is a reply to message #525455] Fri, 21 January 2011 09:03 Go to previous messageGo to next message
Moritz Riedl is currently offline Moritz RiedlFriend
Messages: 1
Registered: January 2011
Junior Member
Just in case someone still has this problem (Coporate Proxy doesn't provide SOCKS):

Try unchecking SOCKS in Control Panel - Internet Options under Windows. If you then select native proxy settings under eclipse, a GOPHER entry should be added instead of the SOCKS entry and the update manager (install new software) should work fine..

That solved the issue for me..
Re: Unable to connect to the network for update [message #693786 is a reply to message #467835] Thu, 07 July 2011 08:15 Go to previous messageGo to next message
BlackBishop64  is currently offline BlackBishop64 Friend
Messages: 1
Registered: July 2011
Junior Member
I've had the same problem and this worked out well for me:

At \eclipse\configuration\.settings\org.eclipse.core.net.prefs set the property systemProxiesEnabled to true manually and restart.

So long Very Happy

[Updated on: Thu, 07 July 2011 08:15]

Report message to a moderator

Re: Unable to connect to the network for update [message #1697406 is a reply to message #693786] Wed, 03 June 2015 16:53 Go to previous messageGo to next message
sumi ss is currently offline sumi ssFriend
Messages: 1
Registered: June 2015
Junior Member
This worked for me! Thank you!
icon14.gif  Re: Unable to connect to the network for update [message #1743893 is a reply to message #693786] Tue, 20 September 2016 12:46 Go to previous messageGo to next message
Alex Mising name is currently offline Alex Mising nameFriend
Messages: 1
Registered: September 2016
Junior Member
BIG THANX!!! I have this trouble for 4 YEARS!!! Laughing
Re: Unable to connect to the network for update [message #1766428 is a reply to message #693786] Wed, 21 June 2017 10:51 Go to previous messageGo to next message
mahesh j is currently offline mahesh jFriend
Messages: 1
Registered: June 2017
Junior Member
Where should I add this systemProxiesEnabled=true?
Re: Unable to connect to the network for update [message #1784555 is a reply to message #1766428] Thu, 29 March 2018 10:09 Go to previous messageGo to next message
khouloud AYARI is currently offline khouloud AYARIFriend
Messages: 49
Registered: March 2018
Member
hey,
How can I go to the confugation tab!! I can't find it :(
Thank u
Re: Unable to connect to the network for update [message #1799067 is a reply to message #693786] Thu, 29 November 2018 13:37 Go to previous messageGo to next message
Padmapriya Manoharan is currently offline Padmapriya ManoharanFriend
Messages: 1
Registered: November 2018
Junior Member
Thank you.. It worked for me..
Re: Unable to connect to the network for update [message #1832988 is a reply to message #1799067] Wed, 30 September 2020 12:15 Go to previous messageGo to next message
Eric Wills is currently offline Eric WillsFriend
Messages: 4
Registered: September 2020
Junior Member
Everything worked great. This solved the problem for me and everything is fine now.
Also, I now do not receive error messages.
Thanks for this


Business before pleasure
Cheap Essay Writing Service


Re: Unable to connect to the network for update [message #1839946 is a reply to message #1832988] Thu, 01 April 2021 17:17 Go to previous message
Francisco Villalba is currently offline Francisco VillalbaFriend
Messages: 2
Registered: April 2021
Location: United Kingdom
Junior Member
Sometimes the router configuration has a firewall rule that blocks an IP address for 8080 or any other port/IP.

A DNS server is, in its simplest form, a database of names and addresses. This DNS tracks the names and addresses of your hosts and queries.
You can configure your local DNS via your access point on 10.0.0.0.1
Previous Topic:Support for p2 update sites from maven in target platforms editor
Next Topic:-Declipse.pluginCustomization not working for RCP application
Goto Forum:
  


Current Time: Sun Oct 24 03:19:10 GMT 2021

Powered by FUDForum. Page generated in 0.02116 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top