Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » GitHub Copilot support for Eclipse IDE(GitHub Copilot Integration in Eclipse)
GitHub Copilot support for Eclipse IDE [message #1861408] Wed, 11 October 2023 14:26 Go to next message
Dittmar Gross is currently offline Dittmar GrossFriend
Messages: 1
Registered: October 2023
Junior Member
Hello,
I would like to benefit from the GitHub Copilot AI support in the Eclipse IDE.
GitHub Copilot is supported for many different IDEs like IntelliJ, VSCode etc.
I found the unofficial plugin on GitHub (https://github.com/vgcpge/eclipse.copilot) but was wondering, that I did not find any official plug in.

Do you know about plans to support it officially or did I overlook any available integration?

Thank you for your reply!
Dgit
Re: GitHub Copilot support for Eclipse IDE [message #1861459 is a reply to message #1861408] Fri, 13 October 2023 15:42 Go to previous messageGo to next message
Vasili Gulevich is currently offline Vasili GulevichFriend
Messages: 28
Registered: July 2009
Junior Member
This is tracked in https://github.com/orgs/community/discussions/51197
Re: GitHub Copilot support for Eclipse IDE [message #1862347 is a reply to message #1861408] Mon, 27 November 2023 19:33 Go to previous message
Brian Fernandes is currently offline Brian FernandesFriend
Messages: 9
Registered: July 2009
Junior Member
Copilot4Eclipse is now generally available in the Eclipse Marketplace. This plugin is compatible with Eclipse 2023-06 and more recent versions.
For support/feedback, please reach out to us here: https://www.genuitec.com/forums/topics/copilot4eclipse/
Previous Topic:Error starting module. osgi.identity; osgi.identity="org.eclipse.emf.compare.ide.ui"; type
Next Topic:When In Dark Theme Mode, Editing Background Color Is Not Allowed
Goto Forum:
  


Current Time: Fri May 24 13:33:03 GMT 2024

Powered by FUDForum. Page generated in 0.09308 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top