Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » plugin dependency issues in eclipse 2023-06
plugin dependency issues in eclipse 2023-06 [message #1860256] Tue, 25 July 2023 10:56 Go to next message
pavan kumar is currently offline pavan kumarFriend
Messages: 5
Registered: July 2023
Junior Member
Upgraded software which is built on Eclipse APIs EMF and GMF using eclipse 2023-06
I am getting following plug-in dependency issue. Attached complete log file

Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.runtime; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.runtime; bundle-version="1.14.0.v20221201-1038"
org.eclipse.emf.parsley.runtime
No resolution report for the bundle. Bundle was not resolved because of a uses constraint violation.
org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.emf.parsley.dsl because it is exposed to package 'com.google.common.util.concurrent.internal' from resources com.google.guava and com.google.guava.failureaccess via two dependency chains.

Chain 1:
org.eclipse.emf.parsley.dsl
require: (osgi.wiring.bundle=org.eclipse.xtext)
|
provide: osgi.wiring.bundle: org.eclipse.xtext
com.google.guava

Chain 2:
org.eclipse.emf.parsley.dsl
require: (osgi.wiring.bundle=org.eclipse.emf.parsley)
|
provide: osgi.wiring.bundle; bundle-version:Version="1.14.0.v20221201-1038"; osgi.wiring.bundle="org.eclipse.emf.parsley"; singleton:="true"
com.google.guava
import: (&(osgi.wiring.package=com.google.common.util.concurrent.internal)(&(version>=1.0.0)(!(version>=2.0.0))))
|
export: osgi.wiring.package: com.google.common.util.concurrent.internal
com.google.guava.failureaccess
at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.emf.parsley.dsl.additional.builder 4 0 2023-07-25 16:14:19.612
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.parsley.dsl.additional.builder
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.dsl
-> Bundle-SymbolicName: org.eclipse.emf.parsley.dsl; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley.dsl
Unresolved requirement: Require-Bundle: org.eclipse.emf.mwe2.launch; resolution:="optional"
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.runtime; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.runtime; bundle-version="1.14.0.v20221201-1038"
org.eclipse.emf.parsley.runtime
No resolution report for the bundle. Bundle was not resolved because of a uses constraint violation.
org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.emf.parsley.dsl.additional.builder because it is exposed to package 'com.google.common.util.concurrent.internal' from resources com.google.guava and com.google.guava.failureaccess via two dependency chains.

Chain 1:
org.eclipse.emf.parsley.dsl.additional.builder
require: (osgi.wiring.bundle=org.eclipse.xtend.lib)
|
provide: osgi.wiring.bundle: org.eclipse.xtend.lib
com.google.guava

Chain 2:
org.eclipse.emf.parsley.dsl.additional.builder
require: (osgi.wiring.bundle=com.google.guava)
|
provide: osgi.wiring.bundle; bundle-version:Version="31.1.0.jre"; osgi.wiring.bundle="com.google.guava"
com.google.guava
import: (&(osgi.wiring.package=com.google.common.util.concurrent.internal)(&(version>=1.0.0)(!(version>=2.0.0))))
|
export: osgi.wiring.package: com.google.common.util.concurrent.internal
com.google.guava.failureaccess
at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.emf.parsley.dsl.ide 4 0 2023-07-25 16:14:19.647
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.parsley.dsl.ide
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.dsl
-> Bundle-SymbolicName: org.eclipse.emf.parsley.dsl; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley.dsl
Unresolved requirement: Require-Bundle: org.eclipse.emf.mwe2.launch; resolution:="optional"
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.runtime; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.runtime; bundle-version="1.14.0.v20221201-1038"
org.eclipse.emf.parsley.runtime
No resolution report for the bundle. Bundle was not resolved because of a uses constraint violation.
org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.emf.parsley.dsl.ide because it is exposed to package 'com.google.common.util.concurrent.internal' from resources com.google.guava and com.google.guava.failureaccess via two dependency chains.

Chain 1:
org.eclipse.emf.parsley.dsl.ide
require: (osgi.wiring.bundle=org.eclipse.emf.parsley.dsl)
|
provide: osgi.wiring.bundle: org.eclipse.emf.parsley.dsl
com.google.guava

Chain 2:
org.eclipse.emf.parsley.dsl.ide
require: (osgi.wiring.bundle=org.eclipse.emf.parsley.dsl)
|
provide: osgi.wiring.bundle; bundle-version:Version="1.14.0.v20221201-1038"; osgi.wiring.bundle="org.eclipse.emf.parsley.dsl"; singleton:="true"
com.google.guava
import: (&(osgi.wiring.package=com.google.common.util.concurrent.internal)(&(version>=1.0.0)(!(version>=2.0.0))))
|
export: osgi.wiring.package: com.google.common.util.concurrent.internal
com.google.guava.failureaccess
at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.emf.parsley.dsl.ui 4 0 2023-07-25 16:14:19.734
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.parsley.dsl.ui
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.dsl.additional.builder
-> Bundle-SymbolicName: org.eclipse.emf.parsley.dsl.additional.builder; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley.dsl.additional.builder
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.dsl
-> Bundle-SymbolicName: org.eclipse.emf.parsley.dsl; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley.dsl
Unresolved requirement: Require-Bundle: org.eclipse.emf.mwe2.launch; resolution:="optional"
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.runtime; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.runtime; bundle-version="1.14.0.v20221201-1038"
org.eclipse.emf.parsley.runtime
No resolution report for the bundle. Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.dsl.ide
-> Bundle-SymbolicName: org.eclipse.emf.parsley.dsl.ide; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley.dsl.ide
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.dsl
-> Bundle-SymbolicName: org.eclipse.emf.parsley.dsl; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.views
-> Bundle-SymbolicName: org.eclipse.emf.parsley.views; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley.views
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.views.common; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.views.common; bundle-version="1.14.0.v20221201-1038"
org.eclipse.emf.parsley.views.common
No resolution report for the bundle. Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.dsl; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.dsl; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.wizards
-> Bundle-SymbolicName: org.eclipse.emf.parsley.wizards; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley.wizards
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley
-> Bundle-SymbolicName: org.eclipse.emf.parsley; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
Bundle was not resolved because of a uses constraint violation.
org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.emf.parsley.dsl.ui because it is exposed to package 'com.google.common.util.concurrent.internal' from resources com.google.guava and com.google.guava.failureaccess via two dependency chains.

Chain 1:
org.eclipse.emf.parsley.dsl.ui
require: (osgi.wiring.bundle=org.eclipse.emf.parsley.dsl)
|
provide: osgi.wiring.bundle: org.eclipse.emf.parsley.dsl
com.google.guava

Chain 2:
org.eclipse.emf.parsley.dsl.ui
require: (osgi.wiring.bundle=org.eclipse.emf.parsley.dsl)
|
provide: osgi.wiring.bundle; bundle-version:Version="1.14.0.v20221201-1038"; osgi.wiring.bundle="org.eclipse.emf.parsley.dsl"; singleton:="true"
com.google.guava
import: (&(osgi.wiring.package=com.google.common.util.concurrent.internal)(&(version>=1.0.0)(!(version>=2.0.0))))
|
export: osgi.wiring.package: com.google.common.util.concurrent.internal
com.google.guava.failureaccess
at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.emf.parsley.editors 4 0 2023-07-25 16:14:19.753
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.parsley.editors
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.editors.common; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.editors.common; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley.editors.common
No resolution report for the bundle. Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.runtime; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.runtime; bundle-version="1.14.0.v20221201-1038"
org.eclipse.emf.parsley.runtime
No resolution report for the bundle. Bundle was not resolved because of a uses constraint violation.
org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.emf.parsley.editors because it is exposed to package 'com.google.common.base' from resources com.google.guava and com.google.guava via two dependency chains.

Chain 1:
org.eclipse.emf.parsley.editors
require: (osgi.wiring.bundle=org.eclipse.emf.parsley)
|
provide: osgi.wiring.bundle: org.eclipse.emf.parsley
com.google.guava

Chain 2:
org.eclipse.emf.parsley.editors
require: (osgi.wiring.bundle=org.eclipse.emf.parsley)
|
provide: osgi.wiring.bundle; bundle-version:Version="1.14.0.v20221201-1038"; osgi.wiring.bundle="org.eclipse.emf.parsley"; singleton:="true"
com.google.inject
import: (&(osgi.wiring.package=com.google.common.collect)(&(version>=30.1.0)(!(version>=31.0.0))))
|
export: osgi.wiring.package: com.google.common.collect; uses:=com.google.common.base
export: osgi.wiring.package=com.google.common.base
com.google.guava
at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.emf.parsley.views 4 0 2023-07-25 16:14:19.802
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.parsley.views
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.views.common; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.views.common; bundle-version="1.14.0.v20221201-1038"
org.eclipse.emf.parsley.views.common
No resolution report for the bundle. Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.runtime; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.runtime; bundle-version="1.14.0.v20221201-1038"
org.eclipse.emf.parsley.runtime
No resolution report for the bundle. Bundle was not resolved because of a uses constraint violation.
org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.emf.parsley.views because it is exposed to package 'com.google.common.base' from resources com.google.guava and com.google.guava via two dependency chains.

Chain 1:
org.eclipse.emf.parsley.views
require: (osgi.wiring.bundle=org.eclipse.emf.parsley)
|
provide: osgi.wiring.bundle: org.eclipse.emf.parsley
com.google.guava

Chain 2:
org.eclipse.emf.parsley.views
require: (osgi.wiring.bundle=org.eclipse.emf.parsley)
|
provide: osgi.wiring.bundle; bundle-version:Version="1.14.0.v20221201-1038"; osgi.wiring.bundle="org.eclipse.emf.parsley"; singleton:="true"
com.google.inject
import: (&(osgi.wiring.package=com.google.common.collect)(&(version>=30.1.0)(!(version>=31.0.0))))
|
export: osgi.wiring.package: com.google.common.collect; uses:=com.google.common.base
export: osgi.wiring.package=com.google.common.base
com.google.guava
at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.emf.parsley.wizards 4 0 2023-07-25 16:14:19.835
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.parsley.wizards
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley
-> Bundle-SymbolicName: org.eclipse.emf.parsley; bundle-version="1.14.0.v20221201-1038"; singleton:="true"
org.eclipse.emf.parsley
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.runtime; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.runtime; bundle-version="1.14.0.v20221201-1038"
org.eclipse.emf.parsley.runtime
No resolution report for the bundle. Bundle was not resolved because of a uses constraint violation.
org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.emf.parsley.wizards because it is exposed to package 'com.google.common.base' from resources com.google.guava and com.google.guava via two dependency chains.

Chain 1:
org.eclipse.emf.parsley.wizards
require: (osgi.wiring.bundle=org.eclipse.emf.parsley)
|
provide: osgi.wiring.bundle: org.eclipse.emf.parsley
com.google.guava

Chain 2:
org.eclipse.emf.parsley.wizards
require: (osgi.wiring.bundle=org.eclipse.emf.parsley)
|
provide: osgi.wiring.bundle; bundle-version:Version="1.14.0.v20221201-1038"; osgi.wiring.bundle="org.eclipse.emf.parsley"; singleton:="true"
com.google.inject
import: (&(osgi.wiring.package=com.google.common.collect)(&(version>=30.1.0)(!(version>=31.0.0))))
|
export: osgi.wiring.package: com.google.common.collect; uses:=com.google.common.base
export: osgi.wiring.package=com.google.common.base
com.google.guava
at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.gmf.ecore.editor 4 0 2023-07-25 16:14:20.564
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gmf.ecore.editor
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.printing.render
-> Bundle-SymbolicName: org.eclipse.gmf.runtime.diagram.ui.printing.render; bundle-version="1.9.0.202305230839"
org.eclipse.gmf.runtime.diagram.ui.printing.render
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="1.16.0"
Unresolved requirement: Require-Bundle: org.apache.batik.transcoder; bundle-version="1.16.0"; visibility:="reexport"
-> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.16.0.v20221027-0840"
org.apache.batik.transcoder
Unresolved requirement: Import-Package: org.apache.batik.bridge; version="
Unresolved requirement: Import-Package: org.apache.batik.dom.svg; version="
Unresolved requirement: Import-Package: org.apache.batik.parser; version="
No resolution report for the bundle. Unresolved requirement: Import-Package: org.apache.batik.dom.svg12; version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.render
-> Bundle-SymbolicName: org.eclipse.gmf.runtime.diagram.ui.render; bundle-version="1.8.0.202305230839"; singleton:="true"
org.eclipse.gmf.runtime.diagram.ui.render
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.printing.render; bundle-version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="1.16.0"
Unresolved requirement: Require-Bundle: org.apache.batik.transcoder; bundle-version="1.16.0"; visibility:="reexport"
-> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.16.0.v20221027-0840"
org.apache.batik.transcoder
Unresolved requirement: Import-Package: org.apache.batik.bridge; version="
Unresolved requirement: Import-Package: org.apache.batik.dom.svg; version="
Unresolved requirement: Import-Package: org.apache.batik.parser; version="
No resolution report for the bundle. Unresolved requirement: Import-Package: org.apache.batik.dom.svg12; version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.render
-> Bundle-SymbolicName: org.eclipse.gmf.runtime.diagram.ui.render; bundle-version="1.8.0.202305230839"; singleton:="true"
org.eclipse.gmf.runtime.diagram.ui.render
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.printing.render; bundle-version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="1.16.0"
Unresolved requirement: Require-Bundle: org.apache.batik.transcoder; bundle-version="1.16.0"; visibility:="reexport"
-> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.16.0.v20221027-0840"
org.apache.batik.transcoder
Unresolved requirement: Import-Package: org.apache.batik.bridge; version="
Unresolved requirement: Import-Package: org.apache.batik.dom.svg; version="
Unresolved requirement: Import-Package: org.apache.batik.parser; version="
No resolution report for the bundle. Unresolved requirement: Import-Package: org.apache.batik.dom.svg12; version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="1.16.0"
Unresolved requirement: Require-Bundle: org.apache.batik.transcoder; bundle-version="1.16.0"; visibility:="reexport"
-> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.16.0.v20221027-0840"
org.apache.batik.transcoder
Unresolved requirement: Import-Package: org.apache.batik.bridge; version="
Unresolved requirement: Import-Package: org.apache.batik.dom.svg; version="
Unresolved requirement: Import-Package: org.apache.batik.parser; version="
No resolution report for the bundle. Unresolved requirement: Import-Package: org.apache.batik.dom.svg12; version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.printing.render; bundle-version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="1.16.0"
Unresolved requirement: Require-Bundle: org.apache.batik.transcoder; bundle-version="1.16.0"; visibility:="reexport"
-> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.16.0.v20221027-0840"
org.apache.batik.transcoder
Unresolved requirement: Import-Package: org.apache.batik.bridge; version="
Unresolved requirement: Import-Package: org.apache.batik.dom.svg; version="
Unresolved requirement: Import-Package: org.apache.batik.parser; version="
No resolution report for the bundle. Unresolved requirement: Import-Package: org.apache.batik.dom.svg12; version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="1.16.0"
Unresolved requirement: Require-Bundle: org.apache.batik.transcoder; bundle-version="1.16.0"; visibility:="reexport"
-> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.16.0.v20221027-0840"
org.apache.batik.transcoder
Unresolved requirement: Import-Package: org.apache.batik.bridge; version="
Unresolved requirement: Import-Package: org.apache.batik.dom.svg; version="
Unresolved requirement: Import-Package: org.apache.batik.parser; version="
No resolution report for the bundle. Unresolved requirement: Import-Package: org.apache.batik.dom.svg12; version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="[1.6.0,1.7.0)"

at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.gmf.tooling.simplemap.diagram 4 0 2023-07-25 16:14:20.595
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gmf.tooling.simplemap.diagram
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.render
-> Bundle-SymbolicName: org.eclipse.gmf.runtime.diagram.ui.render; bundle-version="1.8.0.202305230839"; singleton:="true"
org.eclipse.gmf.runtime.diagram.ui.render
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.printing.render; bundle-version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="1.16.0"
Unresolved requirement: Require-Bundle: org.apache.batik.transcoder; bundle-version="1.16.0"; visibility:="reexport"
-> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.16.0.v20221027-0840"
org.apache.batik.transcoder
Unresolved requirement: Import-Package: org.apache.batik.bridge; version="
Unresolved requirement: Import-Package: org.apache.batik.dom.svg; version="
Unresolved requirement: Import-Package: org.apache.batik.parser; version="
No resolution report for the bundle. Unresolved requirement: Import-Package: org.apache.batik.dom.svg12; version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.tooling.simplemap.diagram; bundle-version="0.1.0"
-> Bundle-SymbolicName: org.eclipse.gmf.tooling.simplemap.diagram; bundle-version="1.0.0.201409171321"; singleton:="true"
org.eclipse.gmf.tooling.simplemap.diagram
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.render
-> Bundle-SymbolicName: org.eclipse.gmf.runtime.diagram.ui.render; bundle-version="1.8.0.202305230839"; singleton:="true"
org.eclipse.gmf.runtime.diagram.ui.render
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.printing.render; bundle-version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="1.16.0"
Unresolved requirement: Require-Bundle: org.apache.batik.transcoder; bundle-version="1.16.0"; visibility:="reexport"
-> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.16.0.v20221027-0840"
org.apache.batik.transcoder
Unresolved requirement: Import-Package: org.apache.batik.bridge; version="
Unresolved requirement: Import-Package: org.apache.batik.dom.svg; version="
Unresolved requirement: Import-Package: org.apache.batik.parser; version="
No resolution report for the bundle. Unresolved requirement: Import-Package: org.apache.batik.dom.svg12; version="
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.printing.render; bundle-version="1.8.0"
-> Bundle-SymbolicName: org.eclipse.gmf.runtime.diagram.ui.printing.render; bundle-version="1.9.0.202305230839"
org.eclipse.gmf.runtime.diagram.ui.printing.render
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="
Unresolved requirement: Require-Bundle: org.apache.batik.bridge; bundle-version="1.16.0"
Unresolved requirement: Require-Bundle: org.apache.batik.transcoder; bundle-version="1.16.0"; visibility:="reexport"
-> Bundle-SymbolicName: org.apache.batik.transcoder; bundle-version="1.16.0.v20221027-0840"
org.apache.batik.transcoder
Unresolved requirement: Import-Package: org.apache.batik.bridge; version="
Unresolved requirement: Import-Package: org.apache.batik.dom.svg; version="
Unresolved requirement: Import-Package: org.apache.batik.parser; version="
No resolution report for the bundle. Unresolved requirement: Import-Package: org.apache.batik.dom.svg12; version="[1.16.0,2.0.0)"
-> Export-Package: org.apache.batik.dom.svg12; bundle-symbolic-name="org.apache.batik.dom.svg"; bundle-version="1.16.0.v20221027-0840"; version="1.16.0"
Unresolved requirement: Import-Package: org.apache.batik.parser; version="[1.16.0,2.0.0)"
-> Export-Package: org.apache.batik.parser; bundle-symbolic-name="org.apache.batik.parser"; bundle-version="1.16.0.v20221027-0840"; version="1.16.0"; uses:="org.apache.batik.ext.awt.geom,org.apache.batik.i18n,org.apache.batik.util.io,org.w3c.dom"
Unresolved requirement: Require-Bundle: org.apache.batik.anim; bundle-version="1.16.0"
-> Bundle-SymbolicName: org.apache.batik.anim; bundle-version="1.16.0.v20221027-0840"
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.render; bundle-version="1.7.1"
-> Bundle-SymbolicName: org.eclipse.gmf.runtime.diagram.ui.render; bundle-version="1.8.0.202305230839"; singleton:="true"
org.eclipse.gmf.runtime.diagram.ui.render [832]
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="[1.2.0,2.0.0)"
-> Bundle-SymbolicName: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="1.11.0.202305230839"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="1.10.0"
-> Bundle-SymbolicName: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="1.11.0.202305230839"; singleton:="true"

at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.jface 2 0 2023-07-25 16:15:05.571
!MESSAGE Keybinding conflicts occurred. They may interfere with normal accelerator operation.
!SUBENTRY 1 org.eclipse.jface 2 0 2023-07-25 16:15:05.571
!MESSAGE A conflict occurred for CTRL+SHIFT+T:
Binding(CTRL+SHIFT+T,
ParameterizedCommand(Command(org.eclipse.jdt.ui.navigate.open.type,Open Type,
Open a type in a Java editor,
Category(org.eclipse.ui.category.navigate,Navigate,null,true),
WorkbenchHandlerServiceHandler("org.eclipse.jdt.ui.navigate.open.type"),
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)
Binding(CTRL+SHIFT+T,
ParameterizedCommand(Command(org.eclipse.lsp4e.symbolinworkspace,Go to Symbol in Workspace,
,
Category(org.eclipse.lsp4e.category,Language Servers,null,true),
WorkbenchHandlerServiceHandler("org.eclipse.lsp4e.symbolinworkspace"),
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)

!ENTRY org.eclipse.egit.ui 2 0 2023-07-25 16:16:22.573
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: 'Z:\'. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.
  • Attachment: .log
    (Size: 94.50KB, Downloaded 67 times)
Re: plugin dependency issues in eclipse 2023-06 [message #1860260 is a reply to message #1860256] Tue, 25 July 2023 16:15 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33163
Registered: July 2009
Senior Member
If you're not using Parsley, just ignore the error. I have told those folks that when their stuff is installed in combination with other things, this conflict arises.

If you wish to communicate with those folks directly, you can look here:

https://eclipse.dev/emf-parsley/support.html


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: plugin dependency issues in eclipse 2023-06 [message #1860267 is a reply to message #1860260] Wed, 26 July 2023 09:18 Go to previous messageGo to next message
pavan kumar is currently offline pavan kumarFriend
Messages: 5
Registered: July 2023
Junior Member
Parsley plugin is no more needed in our application. After clearing the plugin, i got below error. It is expecting org.w3c.dom.events dependency.
I am using java17 and Eclipse 2023-06 build. And also using gmf-tooling plugin which is pretty old one. Please let us know gmf-tooling supports with latest EMF plugin bundled with latest eclipse? i
Bundle was not resolved because of a uses constraint violation.
org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.sirius.diagram.ui [osgi.identity; type="osgi.bundle"; version:Version="7.2.0.202306070701"; osgi.identity="org.eclipse.sirius.diagram.ui"; singleton:="true"] because it is exposed to package 'org.w3c.dom.events' from resources org.eclipse.osgi [osgi.identity; type="osgi.bundle"; version:Version="3.18.400.v20230509-2241"; osgi.identity="org.eclipse.osgi"; singleton:="true"] and org.w3c.dom.events [osgi.identity; type="osgi.bundle"; version:Version="3.0.0.draft20060413_v201105210656"; osgi.identity="org.w3c.dom.events"] via two dependency chains.

Chain 1:
org.eclipse.sirius.diagram.ui [osgi.identity; type="osgi.bundle"; version:Version="7.2.0.202306070701"; osgi.identity="org.eclipse.sirius.diagram.ui"; singleton:="true"]
require: (&(osgi.wiring.bundle=org.eclipse.gmf.runtime.diagram.ui.properties)(bundle-version>=1.8.0))
|
provide: osgi.wiring.bundle: org.eclipse.gmf.runtime.diagram.ui.properties
org.eclipse.osgi [osgi.identity; type="osgi.bundle"; version:Version="3.18.400.v20230509-2241"; osgi.identity="org.eclipse.osgi"; singleton:="true"]

Chain 2:
org.eclipse.sirius.diagram.ui [osgi.identity; type="osgi.bundle"; version:Version="7.2.0.202306070701"; osgi.identity="org.eclipse.sirius.diagram.ui"; singleton:="true"]
require: (&(osgi.wiring.bundle=org.eclipse.gmf.runtime.draw2d.ui.render.awt)(bundle-version>=1.10.0))
|
provide: osgi.wiring.bundle; bundle-version:Version="1.11.0.202305230839"; osgi.wiring.bundle="org.eclipse.gmf.runtime.draw2d.ui.render.awt"; singleton:="true"
org.apache.batik.transcoder [osgi.identity; type="osgi.bundle"; version:Version="1.16.0.v20221027-0840"; osgi.identity="org.apache.batik.transcoder"]
import: (&(osgi.wiring.package=org.apache.batik.bridge)(&(version>=1.16.0)(!(version>=2.0.0))))
|
export: osgi.wiring.package=org.apache.batik.bridge; uses:=org.w3c.dom.events
org.apache.batik.bridge [osgi.identity; type="osgi.bundle"; version:Version="1.16.0.v20230210-1249"; osgi.identity="org.apache.batik.bridge"]
import: (osgi.wiring.package=org.w3c.dom.events)
|
export: osgi.wiring.package: org.w3c.dom.events
org.w3c.dom.events [osgi.identity; type="osgi.bundle"; version:Version="3.0.0.draft20060413_v201105210656"; osgi.identity="org.w3c.dom.events"]
at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)
Re: plugin dependency issues in eclipse 2023-06 [message #1860274 is a reply to message #1860267] Wed, 26 July 2023 11:08 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33163
Registered: July 2009
Senior Member
Likely you'd be better to start with something small and install only the things you actually need. Failing that you will need to contact the specific projects involved because those folks don't look here...

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:"Target is not a JDK root" error
Next Topic:error message ' could not create the view'
Goto Forum:
  


Current Time: Wed Jun 19 04:10:40 GMT 2024

Powered by FUDForum. Page generated in 0.08621 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top