Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to open Eclipse.app(Problem starting Eclipse for macOS M1)
Unable to open Eclipse.app [message #1854676] Fri, 02 September 2022 08:13 Go to next message
Vittorio Maria Stano is currently offline Vittorio Maria StanoFriend
Messages: 5
Registered: September 2022
Junior Member
Hi all, I am writing to ask you for some solution to a problem with Eclipse version for MacOS Apple Silicon. Every time I restart my Mac it happens that when I open Eclipse the message appears:
"Unable to open Eclipse.app". This is very strange. I solve the problem each time by reinstalling the application but this is really very inconvenient. Do you happen to have any idea how to solve this problem?
Re: Unable to open Eclipse.app [message #1854694 is a reply to message #1854676] Fri, 02 September 2022 13:44 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33132
Registered: July 2009
Senior Member
How and where are you installing it?

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Unable to open Eclipse.app [message #1854699 is a reply to message #1854676] Fri, 02 September 2022 15:52 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 742
Registered: August 2014
Senior Member
My guess is that you are trying to run a version of Eclipse for the older Intel chip architecture. The Apple M1 chip does not understand anything of the Intel machine code.

Get the Eclipse installer from <https://www.eclipse.org/downloads/packages/installer>.

Please select the AArch64 option, the x86_64 version does not work.

Use the installer to install Eclipse.


--

Tauno Voipio
Re: Unable to open Eclipse.app [message #1854703 is a reply to message #1854699] Fri, 02 September 2022 19:30 Go to previous messageGo to next message
Vittorio Maria Stano is currently offline Vittorio Maria StanoFriend
Messages: 5
Registered: September 2022
Junior Member
Thank you for your response. The version I downloaded is already for the new Apple Silicon processors.
I downloaded the "Eclipse IDE for Java Developers" package from this page: https://www.eclipse.org/downloads/packages/
Re: Unable to open Eclipse.app [message #1854704 is a reply to message #1854694] Fri, 02 September 2022 19:31 Go to previous messageGo to next message
Vittorio Maria Stano is currently offline Vittorio Maria StanoFriend
Messages: 5
Registered: September 2022
Junior Member
I downloaded the "Eclipse IDE for Java Developers" package from this page: https://www.eclipse.org/downloads/packages/
Re: Unable to open Eclipse.app [message #1854711 is a reply to message #1854704] Sat, 03 September 2022 05:17 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33132
Registered: July 2009
Senior Member
And where is it physically located on your machine after you "installed" it?

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Unable to open Eclipse.app [message #1854712 is a reply to message #1854711] Sat, 03 September 2022 06:18 Go to previous messageGo to next message
Vittorio Maria Stano is currently offline Vittorio Maria StanoFriend
Messages: 5
Registered: September 2022
Junior Member
Yes through the installer I moved the app to the Mac's application folder.
Re: Unable to open Eclipse.app [message #1854713 is a reply to message #1854712] Sat, 03 September 2022 06:29 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33132
Registered: July 2009
Senior Member
Well, that's one everyone does who downloads packages. So your saying, you can only run it once the first time?

Have you tried copying it to somewhere in your home folder, i.e., somewhere that's always writable for you personally?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Unable to open Eclipse.app [message #1854715 is a reply to message #1854713] Sat, 03 September 2022 12:39 Go to previous messageGo to next message
Vittorio Maria Stano is currently offline Vittorio Maria StanoFriend
Messages: 5
Registered: September 2022
Junior Member
Actually this problem happens often but not always. For example, I reinstalled Eclipse yesterday but today when I turned on my Mac it did not give me this problem. It happens sometimes and I don't understand why honestly.
Re: Unable to open Eclipse.app [message #1859746 is a reply to message #1854715] Sat, 24 June 2023 15:40 Go to previous messageGo to next message
Kabiru Usman is currently offline Kabiru UsmanFriend
Messages: 42
Registered: April 2023
Member
I know I'm late to the show, but I think the problem can also be in the operating system. The next time you have similar issues, check general problems for the operating system version you have, due to which the application is not launching.
Sometimes problems with apps not launching on MAC can be solved by resetting NVRAM, PRAM or SMC. But there are many other causes, which have been covered in this article https://setapp.com/how-to/apps-not-launching-on-ventura, which also details possible fixes.

[Updated on: Mon, 26 June 2023 14:33]

Report message to a moderator

Re: Unable to open Eclipse.app [message #1860483 is a reply to message #1859746] Wed, 09 August 2023 11:01 Go to previous message
Zachary Price is currently offline Zachary PriceFriend
Messages: 5
Registered: August 2023
Junior Member
Hey! Facing the same issue can be frustrating. Try this: Go to the Applications folder, find Eclipse, and right-click to choose "Get Info." In the info window, check if there's an option called "Open using Rosetta." If it's there, enable it. This might help Eclipse run better on Apple Silicon. Give it a shot and see if it solves your problem!
Previous Topic:Glassfish JMS
Next Topic:Importing Linked Ressources with Windows Batch script
Goto Forum:
  


Current Time: Sat Apr 13 10:43:14 GMT 2024

Powered by FUDForum. Page generated in 0.31717 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top