Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » e(fx)clipse css editor fails in newer version of Eclipse(There appears to be a missing dependency in the fx specific css editor as it works in Version 2020-12 but fails in Version 2022-06)
e(fx)clipse css editor fails in newer version of Eclipse [message #1853700] Thu, 14 July 2022 02:22 Go to next message
David MacGibbon is currently offline David MacGibbonFriend
Messages: 2
Registered: July 2022
Junior Member
This may be related to the following stack trace from the error log.

org.osgi.framework.BundleException: Could not resolve module: org.eclipse.fx.core.guice [642]
Unresolved requirement: Import-Package: com.google.inject; version="[1.3.0,2.0.0)"

at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1847)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1840)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1781)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1745)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1667)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)
Re: e(fx)clipse css editor fails in newer version of Eclipse [message #1853722 is a reply to message #1853700] Thu, 14 July 2022 20:17 Go to previous messageGo to next message
Stephane  fournier is currently offline Stephane fournierFriend
Messages: 337
Registered: July 2009
Senior Member
Hi,
I did not the issue with Eclipse IDE Modeling 2022-06 + EFX 3.8.0 release.

St├ęphane.
Re: e(fx)clipse css editor fails in newer version of Eclipse [message #1854102 is a reply to message #1853722] Mon, 01 August 2022 10:52 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6649
Registered: July 2009
Senior Member
me neither can you provide us with the Eclipse Version
Re: e(fx)clipse css editor fails in newer version of Eclipse [message #1854412 is a reply to message #1854102] Wed, 17 August 2022 18:55 Go to previous message
David MacGibbon is currently offline David MacGibbonFriend
Messages: 2
Registered: July 2022
Junior Member
I no longer see the error I reported earlier on Eclipse 2022-06 with the EFX 3.8 release. I don't know what else changed since I reported the error.

Please close this issue as resolved.
Previous Topic:Install error
Next Topic:Update site for 3.9.0?
Goto Forum:
  


Current Time: Mon Jun 05 01:16:26 GMT 2023

Powered by FUDForum. Page generated in 0.01678 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top