Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » SVN Version Error(Can't connect Eclipse to SVN even after updating the version it uses)
SVN Version Error [message #1850117] Wed, 16 February 2022 18:03 Go to next message
Becky Villwock is currently offline Becky VillwockFriend
Messages: 1
Registered: February 2022
Junior Member
We followed these steps:

1. Install Eclipse from ninite.com.

2. Set the shortcut to run as Administrator.

3. Launch eclipse.

4. Set default workspace to C:\repos (!!!)

5. Help > Install Software

6. Add...

Name: Subversion
Location: http://download.eclipse.org/technology/subversive/4.0/update-site/

7. Add...

Name: SVNKit 1.10.x
Location: "eclipse.svnkit.com/1.10.x"

8. Help > Install Software (Install PHP)

Work with... --All Available Sites--
Filter: php

Programming Languages
x PHP Development Tools (PDT)
x PHP Development Tools (PDT) Composer Support
x PHP Development Tools (PDT) PHPUnit Support
x PHP Development Tools (PDT) Remote Project Syncronization
x PHP Development Tools (PDT) Zend and Xdebug Profiler

Next
Next
Accept
Finish
Restart Now

9. Help > Install Software (Install Subversion)

Work with... --All Available Sites--
Filter: svn

(wait for it to populate)

Subversive SVN Team Provider Plugin
x Subversive SVN Team Provider
x Subversive SVN Team Provider Localization (optional)

Next
Finish
Restart Now

10. Help > Install Software (Install SVNKit 1.10.x)

x SVNKit Library
x JNA Library

Next
Next
Accept the agreement
Finish
Restart Now

11. Set default perspective to PHP.
Window > Preferences > Version Control > Team

12. Set default SVN Connector
Window > Preferences > Version Control (Team) > SVN > SVNConnector (TAB) > SVNKit 1.10.x

NOPE - SVNKit 1.10.x isn't showing up. WTH?!?!

Restart Eclipse again.

13. Close the welcome tab. Ready to go!

But it isn't connected to the SVNConnector and version SVNKit 1.10.x still isn't showing up. We aren't sure what is causing this. So we tried installing SVNKit 1.8.14 instead because that was showing up and got the error:


SVN: '0x0040010b: Obtain Project Name' operation finished with error: Unable to make field private java.lang.Throwable java.lang.Throwable.cause accessible: module java.base does not "opens java.lang" to unnamed module @2c95cb24
Unable to make field private java.lang.Throwable java.lang.Throwable.cause accessible: module java.base does not "opens java.lang" to unnamed module @2c95cb24
Re: SVN Version Error [message #1850122 is a reply to message #1850117] Thu, 17 February 2022 03:26 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4283
Registered: July 2009
Senior Member

This looks like a subject for https://svnkit.com/support.html .

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Auto closing parenthesis in php file
Next Topic:Best lightweight IDE for PHP programming?
Goto Forum:
  


Current Time: Mon Nov 28 05:16:29 GMT 2022

Powered by FUDForum. Page generated in 0.01544 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top