Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » MultiThreading java program not working in eclipse(I am setting priority for threads execution and it won't work.)
MultiThreading java program not working in eclipse [message #1848117] Sun, 21 November 2021 16:53 Go to next message
Apurv Anand is currently offline Apurv AnandFriend
Messages: 1
Registered: November 2021
Junior Member
I am a new eclipse user and, I was trying a program where I need to set the priorities for threads to get a proper execution order as desired but even after setting the priority for threads, upon execution the program behaves the same as of without any threads priority and the output varies every time (which is normal if we haven't set any priority but it is not normal when I have given the priority).
I have tried integer value (1 to 10) and also tried MAX_PRIORITY, MIN_PRIORITY but still the output order is random.
any help in this regard will be much appreciated.
Re: MultiThreading java program not working in eclipse [message #1848147 is a reply to message #1848117] Mon, 22 November 2021 14:45 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32161
Registered: July 2009
Senior Member
This is not a question specific to Eclipse but rather a general Java question. It would be better to ask on a general forum such as https://stackoverflow.com/

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Unable to Install ADT software in Eclipse
Next Topic:Failed to create Virtual Machine
Goto Forum:
  


Current Time: Sun Jan 23 18:52:51 GMT 2022

Powered by FUDForum. Page generated in 0.03336 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top