Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Internal errors when running WildFly in Eclipse 2021-06
Internal errors when running WildFly in Eclipse 2021-06 [message #1844115] Wed, 01 September 2021 15:57 Go to next message
Philippe Merrilees is currently offline Philippe MerrileesFriend
Messages: 2
Registered: September 2021
Junior Member
Hello,

This is my first time posting on the Eclipse forums so I am unsure if this is the right section for this topic (please forgive me if it isn't!).

I am writing because I just reinstalled Eclipse on both my laptop and desktop computers (using Linux on both machines) and I am running into problems I never encountered in the past (about two years ago), when I was using the WildFly application server in Eclipse.

Indeed, I am now getting the following errors when I try to start my WildFly server instance:


  • An internal error occurred during: "Checking Deployment Scanners for server". java.lang.ExceptionInInitializerError
  • An internal error occurred during: "Updating Deployment Scanners for Server: WildFly 17". Could not initialize class org.wildfly.security.auth.client.DefaultAuthenticationContextProvider


I also tried using WildFly 24 (the latest version) instead of WildFly 17 (the version I had no problems with in the past) but the problem remains the same.

I do not get any errors when running WildFly from the command line so I assume these internal errors are specific to Eclipse.

Also, I downloaded JBoss Tools from the Eclipse Marketplace (on top of the tools Eclipse downloads when adding a WildFly server instance) but nothing seems to work.

Thank you for your kind assistance!
Re: Internal errors when running WildFly in Eclipse 2021-06 [message #1844128 is a reply to message #1844115] Thu, 02 September 2021 07:21 Go to previous messageGo to next message
Jay Arthanareeswaran is currently offline Jay ArthanareeswaranFriend
Messages: 68
Registered: July 2009
Member
This doesn't looks like related to Eclipse. I think checking with WildFly folks might give some answers. I doubt the JDT folks here will have any idea about this.
Re: Internal errors when running WildFly in Eclipse 2021-06 [message #1844131 is a reply to message #1844128] Thu, 02 September 2021 08:57 Go to previous message
Philippe Merrilees is currently offline Philippe MerrileesFriend
Messages: 2
Registered: September 2021
Junior Member
Thank you for your reply!

I posted this issue to the WildFly Google Group which seems to be the official replacement for the WildFly forums which are now read-only.

I am not whether the problem is Eclipse-related or if it has something to do with the JBoss Tools Eclipse downloads when adding an instance of the WildFly application server but I will post back here if I ever get a response from the WildFly folks.

What is strange, however, is that the server can start from Eclipse and my applications deploy successfully but I always get these error messages in Eclipse, no matter what I do.

Thanks again for taking the time!
Previous Topic:Bug when exporting jar on newer version of Eclipse
Next Topic:Running an Eclipse Application from within Ant
Goto Forum:
  


Current Time: Sat Oct 16 13:11:44 GMT 2021

Powered by FUDForum. Page generated in 0.01804 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top