Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Eclipse installation fails on repository error(A clean installation of Eclipse fails on missing repository)
Eclipse installation fails on repository error [message #1843493] Mon, 02 August 2021 12:19 Go to next message
Gilbert Blom is currently offline Gilbert BlomFriend
Messages: 2
Registered: November 2019
Junior Member
Today I tried adding some plugins on an older version of Eclipse (4.6) after a re-installation. To my surprise did several repositories URLs give an error when reloading the repository.

After that I tried a complete new installation of the current 2021‑06 Eclipse installer from https://www.eclipse.org/downloads/packages/installer. The installation failed due to a missing repository . This is the error message I got:
ERROR: org.eclipse.equinox.p2.metadata.repository code=1000 No repository found at http://download.eclipse.org/technology/epp/packages/2021-06/202106121200.

Not sure if there is an issue with the installer or the repositories.

Some of the older repository URLs that stopped working:

  • http://download.eclipse.org/releases/neon/ error:
    Unable to read repository at http://download.eclipse.org/releases/neon/.
    Artifact not found: http://download.eclipse.org/technology/epp/packages/neon/content.xml.xz.
    http://download.eclipse.org/technology/epp/packages/neon/content.xml.xz
    

  • http://download.eclipse.org/technology/m2e/releases/1.3 error:
    Artifact not found: http://download.eclipse.org/technology/m2e/releases/1.13/compositeContent.xml.
    http://download.eclipse.org/technology/m2e/releases/1.13/compositeContent.xml
    


What is happening with the installation and repositories?

This is the full installation log I got on Windows 10, installation on Linux gave a similar log:
[2021-08-02 13:33:59] Executing bootstrap tasks
[2021-08-02 13:33:59] OpenJDK Runtime Environment 16.0.1+9-24
[2021-08-02 13:33:59] Product org.eclipse.products.epp.package.jee.2021-06
[2021-08-02 13:33:59] Bundle org.eclipse.oomph.setup 1.20.0.v20210601-0619, build=5141, branch=67b7b5642ad3a3c48e6c206588e5b85492209546
[2021-08-02 13:33:59] Bundle org.eclipse.oomph.setup.core 1.20.0.v20210601-0619, build=5141, branch=67b7b5642ad3a3c48e6c206588e5b85492209546
[2021-08-02 13:33:59] Bundle org.eclipse.oomph.setup.p2 1.17.0.v20210601-0619, build=5141, branch=67b7b5642ad3a3c48e6c206588e5b85492209546
[2021-08-02 13:33:59] Performing P2 Director (Eclipse IDE for Enterprise Java and Web Developers (2021-06))
[2021-08-02 13:33:59] Offline = false
[2021-08-02 13:33:59] Mirrors = true
[2021-08-02 13:33:59] Resolving 87 requirements from 3 repositoriesto C:\Users\giblom\eclipse\jee-2021-06\eclipse
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:epp.package.jee [4.20.0,5.0.0)
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.platform.feature.group [4.20.0,5.0.0)
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.rcp.feature.group [4.20.0,5.0.0)
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.buildship.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.common.doc.user.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.connectivity.doc.user.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.connectivity.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.connectivity.oda.designer.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.connectivity.oda.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.doc.user.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.apache.derby.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.hsqldb.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.ibm.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.ingres.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.jdbc.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.jdt.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.msft.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.mysql.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.oda.designer.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.oda.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.oracle.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.postgresql.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.sap.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.sdk.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.sqlite.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.enablement.sybase.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.intro.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.modelbase.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sdk.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sqldevtools.data.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sqldevtools.ddl.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sqldevtools.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sqldevtools.parsers.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sqldevtools.results.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.datatools.sqltools.doc.user.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.eclemma.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.egit.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.egit.mylyn.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.epp.mpc.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jdt.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jpt.common.eclipselink.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jpt.common.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jpt.jaxb.eclipselink.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jpt.jaxb.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jpt.jpa.eclipselink.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jpt.jpa.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jsf.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.common.fproj.enablement.jdt.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.enterprise_ui.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.server_adapters.ext.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.server_adapters.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.server_ui.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.web_ui.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.webpageeditor.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.ws.axis2tools.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.ws.cxf.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.ws.jaxws.dom.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.jst.ws.jaxws.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.m2e.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.m2e.lemminx.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.m2e.logback.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.m2e.pde.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.m2e.wtp.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.m2e.wtp.jaxrs.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.m2e.wtp.jpa.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.m2e.wtp.jsf.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.mylyn.bugzilla_feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.mylyn.context_feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.mylyn.ide_feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.mylyn.java_feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.mylyn.wikitext_feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.mylyn_feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.pde.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.tips.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.tm.terminal.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.wildwebdeveloper.embedder.node.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.wildwebdeveloper.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.wst.common.fproj.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.wst.server_adapters.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.wst.xsl.feature.feature.group
[2021-08-02 13:33:59] Requirement org.eclipse.equinox.p2.iu:org.eclipse.oomph.setup.feature.group
[2021-08-02 13:33:59] Repository http://download.eclipse.org/technology/epp/packages/2021-06/202106121200
[2021-08-02 13:33:59] Repository http://download.eclipse.org/releases/2021-06/202106161001
[2021-08-02 13:33:59] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2021-08-02 13:34:15] ERROR: org.eclipse.equinox.p2.metadata.repository code=1000 No repository found at http://download.eclipse.org/technology/epp/packages/2021-06/202106121200.
  at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.fail(AbstractRepositoryManager.java:397)
  at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
  at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
  at java.base/java.lang.reflect.Method.invoke(Unknown Source)
  at org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:119)
  at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.fail(CachingRepositoryManager.java:367)
  at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:258)
  at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager$Metadata.loadRepository(CachingRepositoryManager.java:495)
  at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:110)
  at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:105)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$RepositoryLoader$Worker.perform(ProfileTransactionImpl.java:1578)
  at org.eclipse.oomph.util.WorkerPool$Worker.run(WorkerPool.java:434)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

[2021-08-02 13:34:15] 
Re: Eclipse installation fails on repository error [message #1843499 is a reply to message #1843493] Mon, 02 August 2021 14:51 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4143
Registered: July 2009
Senior Member

A number of eclipse.org servers were offline over the weekend. The contents of download.eclipse.org are slowly coming back, see https://www.eclipsestatus.io/ .

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse installation fails on repository error [message #1843503 is a reply to message #1843499] Tue, 03 August 2021 06:36 Go to previous message
Gilbert Blom is currently offline Gilbert BlomFriend
Messages: 2
Registered: November 2019
Junior Member
Retried again today. New installation now worked without problems. And also the older repositories are back online.
Previous Topic:P2 error using archived Babel - handshake_failure
Next Topic:Eclipse maven archetype catalog
Goto Forum:
  


Current Time: Fri Dec 03 08:20:39 GMT 2021

Powered by FUDForum. Page generated in 0.02347 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top