Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » WebView crashing the VM in RCP app
WebView crashing the VM in RCP app [message #1842735] Wed, 30 June 2021 07:59 Go to next message
Stéphane  ournier is currently offline Stéphane ournierFriend
Messages: 317
Registered: July 2009
Senior Member
Hi,
I'm facing a major bug when trying to use a WebView component in an e4 Part.
I'm running my RCP with AdoptOpenJDK 11.0.9.1 + OpenJFX 11.0.2 + EFX 3.7.0 + Elipse Platform 2019-12 under RedHat 8.

Indeed, the VM is crashing due to a class not found issue : com.sun.webkit.MainThread

I found this ticket https://bugs.eclipse.org/bugs/show_bug.cgi?id=545203 and I would like to know if we have a workaround please ?

Regards,
Stéphane

Re: WebView crashing the VM in RCP app [message #1842799 is a reply to message #1842735] Thu, 01 July 2021 16:00 Go to previous message
Stéphane  ournier is currently offline Stéphane ournierFriend
Messages: 317
Registered: July 2009
Senior Member
Solution 1 proposed in comment 7 of the bugzilla ticket fixed the problem.

[Updated on: Thu, 01 July 2021 16:01]

Report message to a moderator

Previous Topic:openjdk 11, openjfx, eclipse rcp 2018-12
Next Topic:Eclipse won't start after installing e(fx)clipse
Goto Forum:
  


Current Time: Sat Sep 25 10:33:27 GMT 2021

Powered by FUDForum. Page generated in 0.01291 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top