Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Error while setup
Error while setup [message #1842154] Thu, 10 June 2021 14:03 Go to next message
Prashanth Dsouza is currently offline Prashanth DsouzaFriend
Messages: 1
Registered: June 2021
Junior Member
Hi
I'm getting this error can someone help me resolve

ERROR: org.eclipse.pde.core code=0 Problems occurred while resolving the target contents
at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:291)
at org.eclipse.oomph.util.pde.TargetPlatformUtil.activateTargetDefinition(TargetPlatformUtil.java:151)
at org.eclipse.oomph.setup.pde.impl.TargetPlatformTaskImpl.perform(TargetPlatformTaskImpl.java:293)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3851)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3794)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:5178)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2313)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2338)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:5172)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:5170)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3785)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3760)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3638)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:595)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:722)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
ERROR: org.eclipse.m2e.core code=-1 Could not resolve artifact org.eclipse.m2e:org.eclipse.m2e.archetype.common:jar:1.18.0-SNAPSHOT
ERROR: org.eclipse.m2e.core code=-1 Missing org.eclipse.m2e:org.eclipse.m2e.archetype.common:jar:1.18.0-SNAPSHOT
ERROR: org.eclipse.m2e.core code=-1 Could not resolve artifact org.eclipse.m2e:org.eclipse.m2e.maven.indexer:jar:1.18.0-SNAPSHOT
ERROR: org.eclipse.m2e.core code=-1 Missing org.eclipse.m2e:org.eclipse.m2e.maven.indexer:jar:1.18.0-SNAPSHOT
ERROR: org.eclipse.m2e.core code=-1 Could not resolve artifact org.eclipse.m2e:org.eclipse.m2e.maven.runtime:jar:1.18.0-SNAPSHOT
ERROR: org.eclipse.m2e.core code=-1 Missing org.eclipse.m2e:org.eclipse.m2e.maven.runtime:jar:1.18.0-SNAPSHOT
ERROR: org.eclipse.m2e.core code=-1 Could not resolve artifact org.eclipse.m2e:org.eclipse.m2e.maven.runtime.slf4j.simple:jar:1.18.0-SNAPSHOT
ERROR: org.eclipse.m2e.core code=-1 Missing org.eclipse.m2e:org.eclipse.m2e.maven.runtime.slf4j.simple:jar:1.18.0-SNAPSHOT

Took 1 seconds.
There are failed tasks.
Press Back to choose different settings or Cancel to abort.
Re: Error while setup [message #1842181 is a reply to message #1842154] Fri, 11 June 2021 05:16 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32111
Registered: July 2009
Senior Member
If resolution gets the point of trying to download artifacts but then those artifacts aren't found, it's generally an inconsistency between what's in the contant.jar versus the artifacts.jar. Using Window -> Preference s-> Oomph -> Bundle Ppols -> Clear cache... to clear all of the cached repository metadata (both p2's own cache and Oomph's improved cache) will likely fix the problem by forcing new consistent metadata to be downloaded.

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Evaluation of dynamic filters
Next Topic:P2 Director creating an inconsistent configuration that crashes after restart
Goto Forum:
  


Current Time: Tue Dec 07 22:21:53 GMT 2021

Powered by FUDForum. Page generated in 0.02168 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top