Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Bug: Auto-complete doesn't work for Java in eclipse 2021-03(Bug: Auto-complete doesn't work for Java in eclipse 2021-03)
Bug: Auto-complete doesn't work for Java in eclipse 2021-03 [message #1840857] Tue, 27 April 2021 02:15 Go to next message
Randy Strauss is currently offline Randy StraussFriend
Messages: 10
Registered: April 2021
Junior Member
SOLUTION- CREATED A NEW WORKSPACE and REIMPORTED PROJECTS

After upgrading killed eclipse, I installed a new version of eclipse 2021-03 (4.19.0).

Since I use a Mac provided by NASA, I only have Java 1.8. So I fixed the ini file.

But autocomplete doesn't work. The first time I try it I get a popup that has just 1 line, "No Default Proposals."

In my preferences, Auto Activation is enabled with a delay of 0ms, a trigger of '.' (period). I tried changing the 0 to 1ms - it didn't help, even after a restart...

I really don't want to use IntelliJ....

[Updated on: Fri, 07 May 2021 23:37]

Report message to a moderator

Re: Bug: Auto-complete doesn't work for Java in eclipse 2021-03 [message #1840858 is a reply to message #1840857] Tue, 27 April 2021 05:22 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31957
Registered: July 2009
Senior Member
Of course proposals are context sensitive so it really depends on where you did this whether it's a bug or not, and if it's a bug, someone else will need to reproduce it and in that case too, more details are needed.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Bug: Auto-complete doesn't work for Java in eclipse 2021-03 [message #1840875 is a reply to message #1840858] Tue, 27 April 2021 20:39 Go to previous messageGo to next message
Randy Strauss is currently offline Randy StraussFriend
Messages: 10
Registered: April 2021
Junior Member
I got a jdk11 (or 14?) using brew, fixed the ini file, fixed my project properties, quit and restarted.
I still have the same problem...

Attached is a zip of a new, small project with the following java file:
=======

package com.ment;

public class Fubar {
static final double TWO = 2.0;
final double THREE = 3.0;

double getOne() {
return 1.0;
}

void doSomething() {
double value = this.; // type "this." and no suggestions are given
}
}

========
  • Attachment: fubar.zip
    (Size: 4.46KB, Downloaded 41 times)
Re: Bug: Auto-complete doesn't work for Java in eclipse 2021-03 [message #1840876 is a reply to message #1840858] Tue, 27 April 2021 20:41 Go to previous messageGo to next message
Randy Strauss is currently offline Randy StraussFriend
Messages: 10
Registered: April 2021
Junior Member
I submitted an example.
Here's an image of the error log (see below for the text log)

http://randy.strausses.net/misc/eclipse-no-complete-log.jpg

[Updated on: Tue, 27 April 2021 22:41]

Report message to a moderator

Re: Bug: Auto-complete doesn't work for Java in eclipse 2021-03 [message #1840877 is a reply to message #1840876] Tue, 27 April 2021 21:49 Go to previous messageGo to next message
Randy Strauss is currently offline Randy StraussFriend
Messages: 10
Registered: April 2021
Junior Member
index.php/fa/40411/0/I found the "Error log view"
I attached a log and a screenshot.



The UI doesn't make it easy to search for conflicting bindings...
Open Type was conflicting with Go To Symbol in Workspace

Deleting the "Open Type" resolved the conflict, but I still have the other errors in the log,
and Auto-Complete is still broken.

If I close eclipse and restart it,
on the first .
it says "No default proposals"
if I hit ^space, "No template proposals"
if I hit ^space, "No template SWT proposals"
if I hit ^space, it DOES find a bunch of "chain template proposals", through getClass() and toString()...

I can also repeat this by just typing ^space after a period...
Attached is a screen capture of the non-empty chain template proposals...

[Updated on: Tue, 27 April 2021 22:47]

Report message to a moderator

Re: Bug: Auto-complete doesn't work for Java in eclipse 2021-03 [message #1840878 is a reply to message #1840877] Tue, 27 April 2021 21:50 Go to previous messageGo to next message
Randy Strauss is currently offline Randy StraussFriend
Messages: 10
Registered: April 2021
Junior Member
(blank)

[Updated on: Wed, 28 April 2021 02:43]

Report message to a moderator

Re: Bug: Auto-complete doesn't work for Java in eclipse 2021-03 [message #1840879 is a reply to message #1840878] Tue, 27 April 2021 21:59 Go to previous messageGo to next message
Randy Strauss is currently offline Randy StraussFriend
Messages: 10
Registered: April 2021
Junior Member
I reinstalled eclipse- same result...
I put the log
(after nuking the error log, closing eclipse, re-opening it, and typing a period after "this", then exporting the log) in a reply above.
Too bad there's no way to delete one's reply...

[Updated on: Tue, 27 April 2021 22:43]

Report message to a moderator

Re: Bug: Auto-complete doesn't work for Java in eclipse 2021-03 [message #1840885 is a reply to message #1840879] Wed, 28 April 2021 07:32 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31957
Registered: July 2009
Senior Member
It works for me:

index.php/fa/40414/0/

It looks like you used the same workspace with different Eclipse installations that have perspective not in the Java IDE you are currently using. This leads to some of the things in the error log.

The key binding conflict is something I've complained about but no one fixes. I'm not sure you can make it go away manually, but it doesn't generally cause problems. The Mylyn thing is also annoying and an old problem.

I don't see anything in the log that explains your Java problem...


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Bug: Auto-complete doesn't work for Java in eclipse 2021-03 [message #1841253 is a reply to message #1840885] Fri, 07 May 2021 23:38 Go to previous message
Randy Strauss is currently offline Randy StraussFriend
Messages: 10
Registered: April 2021
Junior Member
The problem was old stuff in the workspace.
When I created a new workspace and re-imported the projects, it now works...
Previous Topic:How to use a variable in Python (2.x) to define decimal part?
Next Topic:error when I lunch the eclipse rcp
Goto Forum:
  


Current Time: Sun Jul 25 01:05:04 GMT 2021

Powered by FUDForum. Page generated in 0.02903 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top