Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Support for PHP 8
Support for PHP 8 [message #1835697] Thu, 10 December 2020 16:07 Go to next message
Thomas Zuschneid is currently offline Thomas ZuschneidFriend
Messages: 3
Registered: June 2015
Junior Member
Hello,

will there be support for PHP 8 syntax in release 2020-12 of Eclipse PDT?
Or is there any other way to add this?

Thanks,
Thomas
Re: Support for PHP 8 [message #1835703 is a reply to message #1835697] Thu, 10 December 2020 17:45 Go to previous messageGo to next message
Nader Jafari is currently offline Nader JafariFriend
Messages: 13
Registered: December 2020
Junior Member
I don't think so. 2020-12 php package has pdt 7.2. I think we should wait for pdt 8.0 release
Re: Support for PHP 8 [message #1837536 is a reply to message #1835703] Tue, 02 February 2021 03:22 Go to previous messageGo to next message
Mostafa Barmshory is currently offline Mostafa BarmshoryFriend
Messages: 5
Registered: October 2009
Junior Member
Any new release to support PHP 8?
Re: Support for PHP 8 [message #1837830 is a reply to message #1837536] Mon, 08 February 2021 12:01 Go to previous messageGo to next message
Richard Harding is currently offline Richard HardingFriend
Messages: 2
Registered: May 2013
Junior Member
https://www.eclipse.org/pdt/

See the following:
If you're looking for developer builds, try out **: https://download.eclipse.org/tools/pdt/updates/8.0
Re: Support for PHP 8 [message #1838534 is a reply to message #1835697] Sun, 28 February 2021 16:38 Go to previous messageGo to next message
Nader Jafari is currently offline Nader JafariFriend
Messages: 13
Registered: December 2020
Junior Member
Any updates?
I really don't want to switch from eclipse
Yes I know it's foss and devs don't have to contribute to it but while(true) echo "please"; do something about php 8 support
Re: Support for PHP 8 Named arguments [message #1841303 is a reply to message #1835697] Tue, 11 May 2021 15:11 Go to previous messageGo to next message
jeremy mitchell is currently offline jeremy mitchellFriend
Messages: 3
Registered: May 2021
Junior Member
Hi,

Is there a way to setup Eclipse so that "php 8.0 named arguments" are validated without generating a warning in the IDE?

I tried downloading software:-
https://download.eclipse.org/tools/pdt/updates/8.0/.

And installing the latest Eclipse IDE development install
https://www.eclipse.org/downloads/packages/release/2021-06/m2
(latest stable release was 2021-3)

In the currently project's properties->php>validation shows the latest "php version is 7.4".

Any advice?


php8 code example with named arguments:-
$this->create_questions( no_questions: $question_count );

php7.4 example without:
$this->create_questions( $question_count );

Re: Support for PHP 8 Named arguments [message #1848799 is a reply to message #1841303] Fri, 17 December 2021 11:33 Go to previous messageGo to next message
Ilyas Bakirov is currently offline Ilyas BakirovFriend
Messages: 2
Registered: December 2021
Junior Member
Checkout Eclipse 2012-12 version
Re: Support for PHP 8 Named arguments [message #1848801 is a reply to message #1848799] Fri, 17 December 2021 14:06 Go to previous messageGo to next message
jeremy mitchell is currently offline jeremy mitchellFriend
Messages: 3
Registered: May 2021
Junior Member
Thanks - Will do.
Re: Support for PHP 8 Named arguments [message #1848890 is a reply to message #1848801] Wed, 22 December 2021 11:59 Go to previous messageGo to next message
Dominika Gie is currently offline Dominika GieFriend
Messages: 1
Registered: December 2021
Junior Member
Still with Eclipse 2021-12 version doesn't work, any ideas?
Re: Support for PHP 8 Named arguments [message #1850770 is a reply to message #1848890] Wed, 16 March 2022 14:35 Go to previous messageGo to next message
Alex McKee is currently offline Alex McKeeFriend
Messages: 5
Registered: September 2021
Junior Member
The issue of PHP 8.0 and 8.1 support is being tracked on GitHub - https://github.com/eclipse/pdt/issues/95

The sole developer working on PDT did commit to PHP 8.0 support for the 2022-03 release but unfortunately that does not seem to have materialised.
Re: Support for PHP 8 [message #1852971 is a reply to message #1835697] Mon, 13 June 2022 14:28 Go to previous messageGo to next message
maxxwell sana is currently offline maxxwell sanaFriend
Messages: 2
Registered: June 2022
Junior Member
I think we should wait for pdt 8.0 release








hız testi

[Updated on: Tue, 14 June 2022 20:33]

Report message to a moderator

Re: Support for PHP 8 [message #1854666 is a reply to message #1852971] Thu, 01 September 2022 16:55 Go to previous messageGo to next message
Dieter SchmidtFriend
Messages: 6
Registered: January 2021
Junior Member
> I think we should wait for pdt 8.0 release
Do you have infos about pdt8? There has been no developer activity here since December 21.

Feedback (from project members) on how the PDT project will or could proceed would certainly be helpful.

The current PDT 7.2 supports only PHP up to version 7.4 (3 years old).

But in two month (Nov 2022) the PHP 7.4 support ends (https://www.php.net/supported-versions.php) and PHP 8.0 will be two years old (and PHP 8.1 one year)!








--------------------------------------------
Eclipse IDE for PHP Developers
Version: 2022-06 (4.24.0)
Build id: 20220609-1112
Re: Support for PHP 8 [message #1854838 is a reply to message #1854666] Wed, 14 September 2022 05:21 Go to previous message
Dieter SchmidtFriend
Messages: 6
Registered: January 2021
Junior Member
There are news: https://github.com/eclipse/pdt/issues/141#issuecomment-1245190558



--------------------------------------------
Eclipse IDE for PHP Developers
Version: 2022-06 (4.24.0)
Build id: 20220609-1112
Previous Topic:Error to Choose the type of server to create
Next Topic:How does one become a good PHP developer?
Goto Forum:
  


Current Time: Sun Dec 04 22:47:01 GMT 2022

Powered by FUDForum. Page generated in 0.02879 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top