Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse at startup "An Error has occured. See the log file /home.../.metadata/.log".(Can't start Eclipse due to an error)
Eclipse at startup "An Error has occured. See the log file /home.../.metadata/.log". [message #1835428] Thu, 03 December 2020 08:33 Go to next message
Nico van de Kamp is currently offline Nico van de KampFriend
Messages: 12
Registered: April 2013
Junior Member
Hello,

I want to start working in Eclipse and I can choose the workspace environment and than short after this I get the error which I have paste here below.
I doesn't make any difference if I choose an another workspace.
I get the same error, if I choose an another existing workspace, but than another .metadata/.log file.
If I create a new workspace than also this error.

I've been working yesterday with Eclipse without any issue and/or problem

I'm working in Eclipse 2020-09 from the foundation. The OS is Fedora version 33.

Can somenone help me out what todo and how can I solve this?

.metadata/.log file content from this morning:

Quote:
!SESSION 2020-12-03 08:39:01.327 -----------------------------------------------
eclipse.buildId=4.17.0.v20200914-0420
java.version=11.0.9.1
java.vendor=Red Hat, Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=nl_NL
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.ecf.provider.filetransfer.ssl 2 0 2020-12-03 08:39:12.255
!MESSAGE Could not resolve module: org.eclipse.ecf.provider.filetransfer.ssl [913]
Unresolved requirement: Fragment-Host: org.eclipse.ecf.provider.filetransfer; bundle-version="2.0.0"


!ENTRY org.eclipse.ecf.ssl 2 0 2020-12-03 08:39:12.256
!MESSAGE Could not resolve module: org.eclipse.ecf.ssl [914]
Unresolved requirement: Fragment-Host: org.eclipse.ecf


!ENTRY org.eclipse.osgi.compatibility.state 2 0 2020-12-03 08:39:12.256
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state [930]
Unresolved requirement: Fragment-Host: org.eclipse.osgi; bundle-version="3.12.0"


!ENTRY org.eclipse.osgi 4 0 2020-12-03 08:39:12.256
!MESSAGE Application error
!STACK 1
org.eclipse.e4.ui.css.core.sac.ParserNotFoundException: java.lang.ClassCastException: class org.apache.batik.css.parser.Parser cannot be cast to class org.w3c.css.sac.Parser (org.apache.batik.css.parser.Parser is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @28554ac8; org.w3c.css.sac.Parser is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @4bcdd11)
at org.eclipse.e4.ui.css.core.impl.dom.parsers.AbstractCSSParser.getParser(AbstractCSSParser.java:152)
at org.eclipse.e4.ui.css.core.impl.dom.parsers.AbstractCSSParser.parseStyleSheet(AbstractCSSParser.java:61)
at org.eclipse.e4.ui.css.core.impl.engine.AbstractCSSEngine.parseStyleSheet(AbstractCSSEngine.java:192)
at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.setTheme(ThemeEngine.java:445)
at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.setTheme(ThemeEngine.java:406)
at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.setTheme(ThemeEngine.java:398)
at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.restore(ThemeEngine.java:594)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.setCSSTheme(PartRenderingEngine.java:1419)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.initializeStyling(PartRenderingEngine.java:1326)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1050)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1046)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:644)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:551)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:153)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:150)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:566)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:606)
at org.eclipse.equinox.launcher.Main.run(Main.java:1477)
at org.eclipse.equinox.launcher.Main.main(Main.java:1450)
Caused by: java.lang.ClassCastException: class org.apache.batik.css.parser.Parser cannot be cast to class org.w3c.css.sac.Parser (org.apache.batik.css.parser.Parser is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @28554ac8; org.w3c.css.sac.Parser is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @4bcdd11)
at org.eclipse.e4.ui.css.core.impl.sac.SACParserFactoryImpl.makeParser(SACParserFactoryImpl.java:52)
at org.eclipse.e4.ui.css.core.sac.SACParserFactory.makeParser(SACParserFactory.java:39)
at org.eclipse.e4.ui.css.core.impl.dom.parsers.AbstractCSSParser.getParser(AbstractCSSParser.java:142)
... 30 more
!SESSION 2020-12-03 08:39:25.494 -----------------------------------------------
eclipse.buildId=4.17.0.v20200914-0420
java.version=11.0.9.1
java.vendor=Red Hat, Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=nl_NL
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.ecf.ssl 2 0 2020-12-03 08:39:39.749
!MESSAGE Could not resolve module: org.eclipse.ecf.ssl [914]
Unresolved requirement: Fragment-Host: org.eclipse.ecf


!ENTRY org.eclipse.ecf.provider.filetransfer.ssl 2 0 2020-12-03 08:39:39.751
!MESSAGE Could not resolve module: org.eclipse.ecf.provider.filetransfer.ssl [913]
Unresolved requirement: Fragment-Host: org.eclipse.ecf.provider.filetransfer; bundle-version="2.0.0"


!ENTRY org.eclipse.osgi.compatibility.state 2 0 2020-12-03 08:39:39.751
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state [930]
Unresolved requirement: Fragment-Host: org.eclipse.osgi; bundle-version="3.12.0"


!ENTRY org.eclipse.osgi 4 0 2020-12-03 08:39:39.752
!MESSAGE Application error
!STACK 1
org.eclipse.e4.ui.css.core.sac.ParserNotFoundException: java.lang.ClassCastException: class org.apache.batik.css.parser.Parser cannot be cast to class org.w3c.css.sac.Parser (org.apache.batik.css.parser.Parser is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @1f949ab9; org.w3c.css.sac.Parser is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @1c62c3fd)
at org.eclipse.e4.ui.css.core.impl.dom.parsers.AbstractCSSParser.getParser(AbstractCSSParser.java:152)
at org.eclipse.e4.ui.css.core.impl.dom.parsers.AbstractCSSParser.parseStyleSheet(AbstractCSSParser.java:61)
at org.eclipse.e4.ui.css.core.impl.engine.AbstractCSSEngine.parseStyleSheet(AbstractCSSEngine.java:192)
at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.setTheme(ThemeEngine.java:445)
at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.setTheme(ThemeEngine.java:406)
at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.setTheme(ThemeEngine.java:398)
at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngine.restore(ThemeEngine.java:594)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.setCSSTheme(PartRenderingEngine.java:1419)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.initializeStyling(PartRenderingEngine.java:1326)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1050)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1046)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:644)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:551)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:153)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:150)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:566)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:606)
at org.eclipse.equinox.launcher.Main.run(Main.java:1477)
at org.eclipse.equinox.launcher.Main.main(Main.java:1450)
Caused by: java.lang.ClassCastException: class org.apache.batik.css.parser.Parser cannot be cast to class org.w3c.css.sac.Parser (org.apache.batik.css.parser.Parser is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @1f949ab9; org.w3c.css.sac.Parser is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @1c62c3fd)
at org.eclipse.e4.ui.css.core.impl.sac.SACParserFactoryImpl.makeParser(SACParserFactoryImpl.java:52)
at org.eclipse.e4.ui.css.core.sac.SACParserFactory.makeParser(SACParserFactory.java:39)
at org.eclipse.e4.ui.css.core.impl.dom.parsers.AbstractCSSParser.getParser(AbstractCSSParser.java:142)
... 30 more
[nkamp_admin@localhost .metadata]$

Re: Eclipse at startup "An Error has occured. See the log file /home.../.metadata/.log". [message #1835432 is a reply to message #1835428] Thu, 03 December 2020 09:05 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31863
Registered: July 2009
Senior Member
The bundles look like they are "wired" incorrectly. I'd first try to run on the command line with a -clean argument to force the module's to be rewired from scratch.

Did you recently update or install additional features? Which package did you install? Did you download it from Eclipse (or install it with the Eclipse Installer)?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse at startup "An Error has occured. See the log file /home.../.metadata/.log". [message #1835435 is a reply to message #1835432] Thu, 03 December 2020 11:00 Go to previous messageGo to next message
Nico van de Kamp is currently offline Nico van de KampFriend
Messages: 12
Registered: April 2013
Junior Member
Ok, thanks.

I have made a script eclipse_clean.sh with the content:
 ./eclipse -clean


This is for more than 1 hour running with flickering the startup screen of Eclipse every second. I read on stackoverflow this can take a long time. But what is a long time?

This should be ok, I have still to wait?
Re: Eclipse at startup "An Error has occured. See the log file /home.../.metadata/.log". [message #1835436 is a reply to message #1835435] Thu, 03 December 2020 12:30 Go to previous messageGo to next message
Nico van de Kamp is currently offline Nico van de KampFriend
Messages: 12
Registered: April 2013
Junior Member
Ok maybe what I did was not correct with script.
I have started ./eclipse -clean from the commandline and it is working again. But a lot plugins (modules) are not installed anymore like marketplace, webtools, Angular etc etc...

(The flickering was I think, Eclipse was itself everytime restarting again)

Although a lot of plugins are removed and I have to install this again, it solved for me now, I have learned something and I can carry on!
Re: Eclipse at startup "An Error has occured. See the log file /home.../.metadata/.log". [message #1835438 is a reply to message #1835436] Thu, 03 December 2020 12:34 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31863
Registered: July 2009
Senior Member
No, that's not normal at all. It might take a "while" but a minute would already seem overly long to me.

It really sounds like the installation is in very bad shape. Which leaves me with the question: Where did it come from and how did it get into this state?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse at startup "An Error has occured. See the log file /home.../.metadata/.log". [message #1835485 is a reply to message #1835438] Fri, 04 December 2020 12:51 Go to previous message
Nico van de Kamp is currently offline Nico van de KampFriend
Messages: 12
Registered: April 2013
Junior Member
Ok, I think it was in bad shape yeh.

I thought that I have install it from the foundation a few weeks ago, but is was I think from the "software explorer", which is I think from Fedora. So now I think that I have install the eclipse version of Fedora and not from the foundation

And I have issue's with the plugin from genuitec, so I have removed it again. I install it because I thought it is necessary to use Angular. I'm not 100% sure but I don't think that I need it.

And I had permission issue with upgrading the Eclipse platform IDE form 2020-06 --> 2020-09, "not enough permissions".
All the other plugins I could upgrade but not the platform IDE!!???. In the end I succeeded it with some hasle

I believe I have taken out from the eclipse.ini the "-protect root" , so that I could start eclipse as root.
Oh yeh I have changed the permissions of .eclipseproduct and eclipse I thought, because an error message not enough permission to overwrite these files. After that and starting eclipse as sudo I could upgrade the platform.

Till yesterday, when I started eclipse I had issues..
Previous Topic:RED - Change color of general text in Robot Framework scripts
Next Topic:Linux terminal as Debug console
Goto Forum:
  


Current Time: Sun May 09 02:44:38 GMT 2021

Powered by FUDForum. Page generated in 0.03243 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top