Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Platform "Insufficient access privileges to apply this update.", how can I solve t
Eclipse Platform "Insufficient access privileges to apply this update.", how can I solve t [message #1834389] Mon, 09 November 2020 14:27 Go to next message
Nico van de Kamp is currently offline Nico van de KampFriend
Messages: 8
Registered: April 2013
Junior Member
Hello,

I'm logged in as administrator user and running eclipse as this user. I can till now do the things that I want do: working on the OPC book and working on tutorials on the internet to learn Java (with Angular).



But in Eclipse I do a "check for updates" and then a update is found for the Eclipse Platform (see screenshot: index.php/fa/39238/0/). But as administrator I have "Insufficient access privileges to apply this update."
What I remember that I have installed eclipse as sudo.

The id for the update is: org.eclipse.platform.ide, my expectations is, is that this is the update...url? or is that wrong?

What I have tried is to change the eclipse.ini
-protect --> to #-protect
root --> to #root
and than with the terminal "sudo ./eclipse"

If I press " check for updates" nothing is found? This is the first thing what I not understand, why are updates found under the user admininstrator and not under the sudo?

Than I tried another suggestion <user_adminstrator_name> (in steadoff root):
sudo chown -R <user_adminstrator_name>:<user_adminstrator_name> eclipse/
With the same result: no updates found.

And i tried to get a manual by update url https://org.eclipse.platform.ide. But maybe that is a mistake from my site and is not the correct url.

It is fedora Linux.

I had also another update for the marketplace client which is installed without any issue while I'm running eclipse with the "<user_adminstrator_name>" user

I hope that someone can point me in the right direction.

Nico

[Updated on: Mon, 09 November 2020 14:28]

Report message to a moderator

Re: Eclipse Platform "Insufficient access privileges to apply this update.", how can I sol [message #1834855 is a reply to message #1834389] Thu, 19 November 2020 08:44 Go to previous messageGo to next message
Nico van de Kamp is currently offline Nico van de KampFriend
Messages: 8
Registered: April 2013
Junior Member
I have solved my problem. After all I doubting if it was all necessary but it works now.
Temporarily I changed the permissions for:
eclipse 755 --> 777
.eclipseproduct 644 --> 777 (because I saw an error message that this could be overwritten en believe deleted)

I changed eclipse.ini
- protect --> # - protect
root --> # root

And then I was trying to update the platform ide, but I get the message there are no updates. Which was strang to me becaus I knew that there was a new version 2020-09 and I suppose that was for platform.ide
Then I saw the location http://download.exlipse.org/eclipse/updates/4.16. I changed that to 4.17!! After this it was updating my eclipse.

After changing the persmissions back to the original state and I start Eclipse I got the question "This is the first time... automtic update the plugins" . Yes

But now I have the error "No editor descriptor for id org.eclipse.m2e.editor.MavenPomEditor"!!?????
Re: Eclipse Platform "Insufficient access privileges to apply this update.", how can I sol [message #1834968 is a reply to message #1834855] Sun, 22 November 2020 15:09 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3905
Registered: July 2009
Senior Member

If you saw an Update Site for releases/2020-06, you'd similarly want to update it to point to releases/2020-09 (or just releases/latest).

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Problem with my Workspace
Next Topic:i got a error message when i ran a program
Goto Forum:
  


Current Time: Sun Nov 29 14:22:26 GMT 2020

Powered by FUDForum. Page generated in 0.03313 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top