Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » java.lang.ExceptionInInitializerError 32 bit RCP application(32 bit JDK 8u261 on RCP gives Caused by: java.lang.IllegalArgumentException: Invalid version number: Version number may be negative or greater than 255)
java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833251] Wed, 07 October 2020 16:56 Go to next message
Subhash BP is currently offline Subhash BPFriend
Messages: 6
Registered: October 2020
Junior Member
Hi,

We have a 32 bit RCP application which works fine with jdk1.8.0_211 or below.

But when we use jdk1.8.0_261 it gives java.lang.ExceptionInInitializerError while launching the application.
ie. (-vm C:\Program Files (x86)\Java\jdk1.8.0_261\jre)

The complete error is :
java.lang.ExceptionInInitializerError
at com.ibm.icu.text.Collator.<clinit>(Collator.java:946)
at org.eclipse.ui.internal.WorkingSetComparator.<init>(WorkingSetComparator.java:29)
at org.eclipse.ui.internal.WorkingSetComparator.<clinit>(WorkingSetComparator.java:27)
at org.eclipse.ui.internal.AbstractWorkingSetManager.<init>(AbstractWorkingSetManager.java:79)
at org.eclipse.ui.internal.WorkingSetManager.<init>(WorkingSetManager.java:46)
at org.eclipse.ui.internal.WorkbenchPlugin.getWorkingSetManager(WorkbenchPlugin.java:608)
at org.eclipse.ui.internal.Workbench.getWorkingSetManager(Workbench.java:1262)
at org.eclipse.ui.internal.WorkbenchPage.restoreState(WorkbenchPage.java:3122)
at org.eclipse.ui.internal.WorkbenchWindow.restoreState(WorkbenchWindow.java:2102)
at org.eclipse.ui.internal.Workbench.doRestoreState(Workbench.java:3357)
at org.eclipse.ui.internal.Workbench.restoreState(Workbench.java:2075)
at org.eclipse.ui.internal.Workbench.access$28(Workbench.java:2060)
at org.eclipse.ui.internal.Workbench$48.run(Workbench.java:1923)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.ui.internal.Workbench.restoreState(Workbench.java:1867)
at org.eclipse.ui.internal.WorkbenchConfigurer.restoreState(WorkbenchConfigurer.java:183)
at org.eclipse.ui.application.WorkbenchAdvisor$1.run(WorkbenchAdvisor.java:781)
Caused by: java.lang.IllegalArgumentException: Invalid version number: Version number may be negative or greater than 255
at com.ibm.icu.util.VersionInfo.getInstance(VersionInfo.java:191)
at com.ibm.icu.impl.ICUDebug.getInstanceLenient(ICUDebug.java:65)
at com.ibm.icu.impl.ICUDebug.<clinit>(ICUDebug.java:69)
... 17 more


What could be the issue ?

- Subhash
Re: java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833263 is a reply to message #1833251] Thu, 08 October 2020 06:24 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31702
Registered: July 2009
Senior Member
I really don't know what the developers are thinking with this code:
    /**
     * Returns an instance of VersionInfo with the argument version.
     * @param major major version, non-negative number &lt;= 255.
     * @param minor minor version, non-negative number &lt;= 255.
     * @param milli milli version, non-negative number &lt;= 255.
     * @param micro micro version, non-negative number &lt;= 255.
     * @exception IllegalArgumentException when either arguments are negative or &gt; 255
     * @stable ICU 2.6
     */
    public static VersionInfo getInstance(int major, int minor, int milli,
                                          int micro)
    {
        // checks if it is in the hashmap
        // else
        if (major < 0 || major > 255 || minor < 0 || minor > 255 ||
            milli < 0 || milli > 255 || micro < 0 || micro > 255) {
            throw new IllegalArgumentException(INVALID_VERSION_NUMBER_);
        }
I.e., I'm not sure why any of the version segments can't be greater then 255...

It's not as if you're the first person to encounter this:

https://stackoverflow.com/questions/61462535/jasypt-encryption-stops-working-after-upgrade-to-jdk-7u261

I don't see any open bug reports about it...



Ed Merks
Professional Support: https://www.macromodeling.com/
Re: java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833287 is a reply to message #1833263] Thu, 08 October 2020 12:45 Go to previous messageGo to next message
Subhash BP is currently offline Subhash BPFriend
Messages: 6
Registered: October 2020
Junior Member
I am sorry I coudn't follow. Our problem is , when the customer applies latest jre (JDK 8u261) then it gives the the I have mentioned. Our application is a 32 bit RCP application. So is there any version limt for any RCP application for supported jre ?

- Subhash
Re: java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833291 is a reply to message #1833263] Thu, 08 October 2020 13:13 Go to previous messageGo to next message
Subhash BP is currently offline Subhash BPFriend
Messages: 6
Registered: October 2020
Junior Member
So what you suggest ? Use another version or jre ?? Can you please advice ?
Re: java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833295 is a reply to message #1833291] Thu, 08 October 2020 14:04 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31702
Registered: July 2009
Senior Member
From what I can tell of the code for any JRE version 1.8.0.256 or higher would have a problem like this. :-( I just don't get the point of such a guard...

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833298 is a reply to message #1833295] Thu, 08 October 2020 14:23 Go to previous messageGo to next message
Subhash BP is currently offline Subhash BPFriend
Messages: 6
Registered: October 2020
Junior Member
Ok, thanks Ed Merks.
Re: java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833302 is a reply to message #1833295] Thu, 08 October 2020 14:51 Go to previous messageGo to next message
Subhash BP is currently offline Subhash BPFriend
Messages: 6
Registered: October 2020
Junior Member
Ed,
That means we can't use jre 8 with version more that 255 ? What I have found is from jre 9 onwards there is no support for 32 bit. If that is the case, then we hit the road block. Our Eclipse RCP is 32 bit application. ...
Any thought ?

- Subhash
Re: java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833303 is a reply to message #1833302] Thu, 08 October 2020 15:24 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31702
Registered: July 2009
Senior Member
Yes, it seems 32 bit has reach end of life. Is there some native things you're using that require 32 bit and don't have corresponding 64 bit version? I.e., why do you need 32 bit?

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833411 is a reply to message #1833303] Mon, 12 October 2020 13:46 Go to previous messageGo to next message
Subhash BP is currently offline Subhash BPFriend
Messages: 6
Registered: October 2020
Junior Member
Ed,
We have an old RCP product built on 32 bit and rolled out to customers. Is there any option to maintain this product without migrating to 64 since there is no developers working on maintenance ?
Now customers for security reason use new versions of jre and it fails due to the version number check with in.

- Subhash
Re: java.lang.ExceptionInInitializerError 32 bit RCP application [message #1833433 is a reply to message #1833411] Tue, 13 October 2020 05:49 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31702
Registered: July 2009
Senior Member
I really don't know what to suggest. It looks like it's parsing the value of the "java.version" system property (mostly to decide if it's Java 1.4 or higher) so maybe you could somehow set that system property, at least while initializing, i.e., during a call to com.ibm.icu.text.Collator.getInstance() very early in your application.

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:eclipse 2020-06 and PyDev crash
Next Topic:Eclipse 2020-09 fails to find plug-in sources on Linux
Goto Forum:
  


Current Time: Mon Jan 18 05:29:54 GMT 2021

Powered by FUDForum. Page generated in 0.03400 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top