Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Dark theme has white current line for XML editor
Dark theme has white current line for XML editor [message #1830704] Fri, 31 July 2020 22:55 Go to next message
Hugo Espejel is currently offline Hugo EspejelFriend
Messages: 5
Registered: July 2020
Junior Member
I like the dark theme for Eclipse, but I'm having an issue with the color of the current line when editing a *.xml file, which is white (as seen in the image below).

index.php/fa/38707/0/

I've gone through the usual suggestions online:

Windows - Preference - General - Editors - Text Editors
then "Appearance color options:" and "Current line highlight"
but that seems ok for any other editor

I've also done:

Windows - Preference - XML Files - Editor - Appearance or Syntax Coloring

I've played around with the settings, but nothing has changed the white current line for the XML editor. How do I resolve this?
Re: Dark theme has white current line for XML editor [message #1830709 is a reply to message #1830704] Sat, 01 August 2020 00:36 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3905
Registered: July 2009
Senior Member

Is this in the current 2020-06 release?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Dark theme has white current line for XML editor [message #1830711 is a reply to message #1830709] Sat, 01 August 2020 03:17 Go to previous messageGo to next message
Hugo Espejel is currently offline Hugo EspejelFriend
Messages: 5
Registered: July 2020
Junior Member
Correct
Re: Dark theme has white current line for XML editor [message #1830714 is a reply to message #1830711] Sat, 01 August 2020 06:20 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3905
Registered: July 2009
Senior Member

I haven't been able to reproduce this--it's following the current line highlight color correctly. There
is an annotation on that line, shown in the overview ruler on the right. When you hover over it, what
does the accompanying text say? Is it something that's configured on the Text Editor/Annotations
preference page to change the background color to white?


Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Sat, 01 August 2020 06:27]

Report message to a moderator

Re: Dark theme has white current line for XML editor [message #1831052 is a reply to message #1830714] Mon, 10 August 2020 22:55 Go to previous messageGo to next message
Hugo Espejel is currently offline Hugo EspejelFriend
Messages: 5
Registered: July 2020
Junior Member
The comment just stated "1 changed line". I checked the other annotations, and none were related to the color of the line.
Re: Dark theme has white current line for XML editor [message #1831059 is a reply to message #1831052] Tue, 11 August 2020 01:44 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3905
Registered: July 2009
Senior Member

It almost looks like the "current line" color for the Light theme stayed in effect, but every time I change to the Dark theme, it's correct for me, even without the prompted restart.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Dark theme has white current line for XML editor [message #1831097 is a reply to message #1831059] Tue, 11 August 2020 18:11 Go to previous messageGo to next message
Hugo Espejel is currently offline Hugo EspejelFriend
Messages: 5
Registered: July 2020
Junior Member
I changed the theme to "Light", closed the program, changed it back to "Dark", closed the program, and everything looks fine now. The current line color is now a dark grey. Thanks!
Re: Dark theme has white current line for XML editor [message #1831114 is a reply to message #1831097] Tue, 11 August 2020 20:59 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3905
Registered: July 2009
Senior Member

If you should find it happening again, and can narrow down the circumstances that caused it, I'll be happy to take a closer look.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Dark theme has white current line for XML editor [message #1831116 is a reply to message #1831114] Tue, 11 August 2020 21:10 Go to previous messageGo to next message
Hugo Espejel is currently offline Hugo EspejelFriend
Messages: 5
Registered: July 2020
Junior Member
I truly appreciate it!
Re: Dark theme has white current line for XML editor [message #1832830 is a reply to message #1831097] Fri, 25 September 2020 20:35 Go to previous message
Mike Konikoff is currently offline Mike KonikoffFriend
Messages: 2
Registered: August 2013
Junior Member
Same thing was happening for me using the DevStyle theme Dark Gray (Darkest Dark). Changing from DevStyle to Dark and restarting did not fix it. Changed to DevStyle and selecting "Use enhanced DevStyle Themes" on main DevStyle preferences page finally fixed it. Thanks for reporting your problem and solution -- it helped me with mine!
Previous Topic:eclipse would not launch
Next Topic:Error popup on launch: "'Load QML Analyzer' has encountered a problem."
Goto Forum:
  


Current Time: Sun Nov 29 08:33:45 GMT 2020

Powered by FUDForum. Page generated in 0.03326 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top