Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » PyDev on Eclipse 2020-06 installation failed(Could not install PyDev plugin due to dependency error)
PyDev on Eclipse 2020-06 installation failed [message #1829761] Fri, 10 July 2020 09:29 Go to next message
Alex Gor is currently offline Alex GorFriend
Messages: 151
Registered: November 2014
Location: Russia
Senior Member
Hello Gang


I've tried to install Pydev 7.6.0 on Eclipse 2020-06 C/C++ package.
The Eclipse runs over JDK 8.
I observe the following error message

Cannot complete the install because some dependencies are not satisfiable
Software being installed: a.jre.javase 10.0.0
Software currently installed: C/C++ Autotools support 9.11.1.202004012023 (org.eclipse.cdt.autotools.feature.group 9.11.1.202004012023)
Cannot satisfy dependency:
From: C/C++ Autotools support 9.11.1.202004012023 (org.eclipse.cdt.autotools.feature.group 9.11.1.202004012023)
To: org.eclipse.equinox.p2.iu; org.eclipse.tools.templates.freemarker.java11 [1.1.100.202001140305,1.1.100.202001140305]
Cannot satisfy dependency:
From: Template Engine Freemarker Support (Java 11) 1.1.100.202001140305 (org.eclipse.tools.templates.freemarker.java11 1.1.100.202001140305)
To: osgi.ee; (&(osgi.ee=JavaSE)(version=11))


Thanks in advance
Alexander
Re: PyDev on Eclipse 2020-06 installation failed [message #1829766 is a reply to message #1829761] Fri, 10 July 2020 10:12 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31342
Registered: July 2009
Senior Member
See this Bug about this issue:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=564698

Given the next version of Eclipse will require Java 11, it's probably easiest to just install that...



Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:What JVM config options does Eclipse insert into application?
Next Topic:Eclipse intallation failed for Eclipse IDE 2020-06
Goto Forum:
  


Current Time: Tue Aug 04 01:34:58 GMT 2020

Powered by FUDForum. Page generated in 0.03293 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top