Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Errors : Software being installed: artificial_root 1.0.0.v1594017162698
Errors : Software being installed: artificial_root 1.0.0.v1594017162698 [message #1829522] Mon, 06 July 2020 06:56 Go to next message
Valentin Dinca is currently offline Valentin DincaFriend
Messages: 3
Registered: July 2020
Junior Member
Hello.
I'm trying to use Eclipse installer and I get errors for multiple projects.
Below some errors:
ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:427)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:339)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:882)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3827)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3755)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3736)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3629)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:585)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:714)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1594017162698
ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: JBoss AS, WildFly & EAP Server Tools - Remote Systems Integration 3.2.4.v20170329-2126 (org.jboss.ide.eclipse.as.server.rse.integration.feature.feature.group 3.2.4.v20170329-2126) requires 'org.eclipse.equinox.p2.iu; org.eclipse.rse.subsystems.terminals.ssh 0.0.0' but it could not be found
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1594017162698
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.jboss.ide.eclipse.as.server.rse.integration.feature.feature.group 0.0.0

Also on this project who worked on the middle of june and I didn't make any changes till now, I get the partially the same error:

ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:427)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:339)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:882)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3827)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3755)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3736)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3629)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:585)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:714)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1594018452864
ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: artificial_root 1.0.0.v1594018452864 requires 'org.eclipse.equinox.p2.iu; com.sap.ndb.studio.admin.feature.devedition.feature.group 0.0.0' but it could not be found

I'm using Installer version: 1.17.0 Build 4683.

Can you help me with this ?
Re: Errors : Software being installed: artificial_root 1.0.0.v1594017162698 [message #1829545 is a reply to message #1829522] Mon, 06 July 2020 17:31 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32109
Registered: July 2009
Senior Member
None of the products in the catalog have dependencies on things like org.jboss.ide or com.sap.ndb.studio. Are you trying to install also things from Eclipse Marketplace at the same time? What steps would I need to take to reproduce this problem?

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Errors : Software being installed: artificial_root 1.0.0.v1594017162698 [message #1829636 is a reply to message #1829522] Wed, 08 July 2020 06:10 Go to previous messageGo to next message
Valentin Dinca is currently offline Valentin DincaFriend
Messages: 3
Registered: July 2020
Junior Member
Hello Ed.
After some testing and diagnostic I realize that the problem is the Nexus 3 P2 proxy repository. We use nexus (from sonatype) p2 proxy repositories for eclipse installer.
In the repo (nexus 3) we find only with a content.xml.xz file.
In nexus 2 with the same settings I have more files like artifacts.jar, artifact.xml, content.jar and content.xml.
I use this url : https://tools.hana.ondemand.com/2020-03
If I try to use the nexus 3 repo with eclipse installer I have the above errors.
With nexus 2 repo , everything works.
If i use direct url (https://tools.hana.ondemand.com/2020-03) in the eclipse installer I have no problems.
Do you have some experience with this ?
Thank you.
Have a nice day.
Re: Errors : Software being installed: artificial_root 1.0.0.v1594017162698 [message #1829677 is a reply to message #1829636] Wed, 08 July 2020 14:52 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32109
Registered: July 2009
Senior Member
I was able to load this repository in the Repository Explorer so that looks okay.

https://tools.hana.ondemand.com/2020-03

It appears to contain com.sap.ndb.studio.admin.feature.devedition.feature.group.

You typed the same URL twice, so I don't know about the one that's failing...


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Targlets and dynamic update site URIs
Next Topic:Upgrading the IDE
Goto Forum:
  


Current Time: Sun Nov 28 03:38:38 GMT 2021

Powered by FUDForum. Page generated in 0.01298 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top