Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Errors in Eclipse 2020-03 with latest ADT(Not sure if issue with eclipse or SAP ADT)
Errors in Eclipse 2020-03 with latest ADT [message #1828013] Fri, 29 May 2020 07:24 Go to next message
Mithun KumarFriend
Messages: 4
Registered: May 2020
Junior Member

Hi All,
My eclipse and SAP ADT (ABAP Development Tools) are both updated to the latest version. Not sure what's wrong but, everytime I right click on any object or within any code, while in the ABAP perspective, I get this error (Attached).
In other perspective, like in Java this error is not there.
Couldn't find anything like this online as I googled. So had to ask here.

Tried to uninstall and re-install everything. Even tried removing just the git integration from eclipse, but this error keeps coming back.
Really not sure if it's an error with eclipse or the SAP ADT.

Can anyone please help? This is very annoying.
Re: Errors in Eclipse 2020-03 with latest ADT [message #1828040 is a reply to message #1828013] Fri, 29 May 2020 18:38 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 363
Registered: August 2016
Senior Member
EGit UI cannot load because EGit core cannot load because JGit crashes because the path to your HOME directory is utterly wrong.

You're on Windows. What are the values of the following environment variables:

%HOME%
%HOMEDRIVE%
%HOMEPATH%
%HOMESHARE%

What is the setting in Eclipse of system property user.home (should be shown in the Eclipse About Dialog, click "Installation Details", in the "Configuration" tab)?
Re: Errors in Eclipse 2020-03 with latest ADT [message #1828041 is a reply to message #1828013] Fri, 29 May 2020 18:39 Go to previous messageGo to next message
Andrey Loskutov is currently offline Andrey LoskutovFriend
Messages: 82
Registered: July 2009
Member
Please report bug for egit
Re: Errors in Eclipse 2020-03 with latest ADT [message #1828042 is a reply to message #1828041] Fri, 29 May 2020 18:50 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 363
Registered: August 2016
Senior Member
Andrey Loskutov wrote on Fri, 29 May 2020 18:39
Please report bug for egit

No, please don't. It's a problem in JGit, and I've just created bug 563739.
Re: Errors in Eclipse 2020-03 with latest ADT [message #1828078 is a reply to message #1828040] Mon, 01 June 2020 03:14 Go to previous messageGo to next message
Mithun KumarFriend
Messages: 4
Registered: May 2020
Junior Member

Thomas Wolf wrote on Sat, 30 May 2020 02:38
EGit UI cannot load because EGit core cannot load because JGit crashes because the path to your HOME directory is utterly wrong.

You're on Windows. What are the values of the following environment variables:

%HOME%
%HOMEDRIVE%
%HOMEPATH%
%HOMESHARE%

What is the setting in Eclipse of system property user.home (should be shown in the Eclipse About Dialog, click "Installation Details", in the "Configuration" tab)?

Thanks for the reply. Here're the values in my system...

HOME=C:\Program Files\Git;C:\<myfolder>\eclipse;C:\Program Files\Java\jdk-11.0.6\bin;
HOMEDRIVE = C:
HOMEPATH=\Users\<myuser>
I don't have HOMESHARE setup.

In eclipse config, the user.home is set to my user folder C:/Users/<myuser>

PS: I just noticed that my eclipse is stored in "Eclipse" folder, whereas the HOME shows the folder as "eclipse". Do you think this is supposed to be case sensitive? Usually in windows it shouldn't matter, right?

[Updated on: Mon, 01 June 2020 03:16]

Report message to a moderator

Re: Errors in Eclipse 2020-03 with latest ADT [message #1828079 is a reply to message #1828042] Mon, 01 June 2020 03:19 Go to previous messageGo to next message
Mithun KumarFriend
Messages: 4
Registered: May 2020
Junior Member

Thomas Wolf wrote on Sat, 30 May 2020 02:50
Andrey Loskutov wrote on Fri, 29 May 2020 18:39
Please report bug for egit

No, please don't. It's a problem in JGit, and I've just created bug 563739.


Thanks.
So a fix for this bug should fix the issue for me?
Re: Errors in Eclipse 2020-03 with latest ADT [message #1828082 is a reply to message #1828079] Mon, 01 June 2020 05:39 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 363
Registered: August 2016
Senior Member
Yes.

Having a list of paths in %HOME% is highly unusual, if not wrong. Did you intend to set %PATH% to that list?

You could also fix it by setting %HOME% to C:\Users\<myuser>.
Re: Errors in Eclipse 2020-03 with latest ADT [message #1828217 is a reply to message #1828082] Thu, 04 June 2020 08:59 Go to previous message
Mithun KumarFriend
Messages: 4
Registered: May 2020
Junior Member

Thomas Wolf wrote on Mon, 01 June 2020 13:39
You could also fix it by setting %HOME% to C:\Users\<myuser>.

Wow.. awesome this simple step fixed the issue for me... In fact this also made git recognized in my VS Code, where it always showed as git not found.
Didn't know both the issues, were due to this one HOME path.
Previous Topic:EGit not recognising git repositories downloaded using repo tool
Next Topic:Slow performance of add command
Goto Forum:
  


Current Time: Mon Jun 14 16:26:06 GMT 2021

Powered by FUDForum. Page generated in 0.02367 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top