Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Transport Error :: Egit :: clone repository fail( clone repository in Egit throws Transport Error)
Transport Error :: Egit :: clone repository fail [message #1826351] Thu, 23 April 2020 20:36 Go to next message
Charles Herrick is currently offline Charles HerrickFriend
Messages: 17
Registered: July 2016
Location: Jeddo, TX
Junior Member
Egit :: clone repository takes my credentials and immediately throws the Transport Error (3 possible probs, url, sslVerify, etc). Git BASH clone works flawlessly. Any ideas on why Egit is being difficult?
Note: I do NOT have ssh keys set up.
Windows 10, Eclipse 4.4.2
Egit 4.9.2
Please see the attached .jpg files
index.php/fa/37929/0/
index.php/fa/37930/0/


--
Charles Herrick
[e:] charles.n.herrick@gmail.com
[m:] (512) 289-0926
Re: Transport Error :: Egit :: clone repository fail [message #1826372 is a reply to message #1826351] Fri, 24 April 2020 07:17 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1212
Registered: July 2009
Senior Member
- there is no need to setup ssh keys when cloning via https
- you should not disable ssl verification except for a short trouble shooting, if your JVM doesn't trust the server's certificate you should import its ca certificate to teach the JVM trusting this server's certificate authority
- are you behind a proxy and didn't configure Eclipse to use it or vice versa ?
Re: Transport Error :: Egit :: clone repository fail [message #1826374 is a reply to message #1826351] Fri, 24 April 2020 07:23 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 494
Registered: August 2016
Senior Member
This is a private repository at Github, so I can only guess at what might be wrong.

Do you have 2FA enabled for https access? If so, the password would have to be the access token. See the Github documentation.

Also, EGit 4.9.2 is rather old; there have been some improvements since then. Try cloning from an Eclipse 2020-03 with EGit nightly installed (update site: https://download.eclipse.org/egit/updates-nightly ). Does it work then?

Are there any errors in the Eclipse log? If so, it might also help to see what they are.
Re: Transport Error :: Egit :: clone repository fail [message #1826376 is a reply to message #1826374] Fri, 24 April 2020 07:26 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 494
Registered: August 2016
Senior Member
Also see https://developer.github.com/changes/2020-02-14-deprecating-password-auth/ . Which seems to mean that you have to use a personal access token and give that as the password in any case.

Or set up an SSH key on your Giithub account and use ssh. (In which case the clone URL would be ssh://git@github.com/... )
Re: Transport Error :: Egit :: clone repository fail [message #1826411 is a reply to message #1826376] Fri, 24 April 2020 13:46 Go to previous messageGo to next message
Charles Herrick is currently offline Charles HerrickFriend
Messages: 17
Registered: July 2016
Location: Jeddo, TX
Junior Member
OK, while still stuck with ODM Rule Designer (Eclipse) at 4.4.2 I did manage to up my Eclipse to 5.0.3.
I'm still getting the Transport Error, so still trying ... again, thanks.

I do see in the .metadata\.log file the error "cannot open git-upload-pack"

the proxy settings check box in IE is off, so there is that.


--
Charles Herrick
[e:] charles.n.herrick@gmail.com
[m:] (512) 289-0926

[Updated on: Fri, 24 April 2020 13:58]

Report message to a moderator

Re: Transport Error :: Egit :: clone repository fail [message #1826418 is a reply to message #1826411] Fri, 24 April 2020 15:48 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 494
Registered: August 2016
Senior Member
Please show the stack trace of that "cannot open git-upload-pack" error, as well as any other error in the log that looks like it might have something to do with this. (Say, occurred a few seconds before.)

If this is an old Eclipse, it may also be using an old JVM. I know that IBM ships its own JVM with RSA (Rational Software Architect), and it is outdated; if that JVM has outdated certificates then perhaps the SSL connection already fails.

Proxy settings in IE (which I guess is Internet Explorer) should have no effect in Eclipse? No proxies in Eclipse are set? Opening a Github page in the Eclipse-internal web browser works?

Did you try using a modern JVM (AdoptOpenJDK 11.0.7 or newer), a modern Eclipse like 2020-03 and a modern EGit like EGit.nightly? It is worth a try, because if that works we know that either it's a fixed bug in EGit/JGit, or it's indeed an outdated JVM. And if that still doesn't work we know we have to look elsewhere.
Re: Transport Error :: Egit :: clone repository fail [message #1826422 is a reply to message #1826418] Fri, 24 April 2020 16:22 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 494
Registered: August 2016
Senior Member
Just remembered: if your Eclipse is using an IBM JVM, it might also be bug 558709.

If you are using an IBM JVM, try setting "-Dcom.ibm.jsse2.overrideDefaultTLS=true" in eclipse.ini.
Re: Transport Error :: Egit :: clone repository fail [message #1826429 is a reply to message #1826422] Fri, 24 April 2020 17:32 Go to previous messageGo to next message
Charles Herrick is currently offline Charles HerrickFriend
Messages: 17
Registered: July 2016
Location: Jeddo, TX
Junior Member
thanks,
Use of the Eclipse internal browser appears to work on https://github.com/CardinalHealth.

stack from "cannot open git-upload-pack":
Eclipse warns about the HOME variable and then
!ENTRY org.eclipse.egit.ui 4 0 2020-04-24 08:41:49.291
!MESSAGE https://github.com/CardinalHealth/odm-dynamicallocationxom.git: cannot open git-upload-pack
!STACK 0
org.eclipse.jgit.api.errors.TransportException: https://github.com/CardinalHealth/odm-dynamicallocationxom.git: cannot open git-upload-pack
at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:222)
at org.eclipse.jgit.api.LsRemoteCommand.call(LsRemoteCommand.java:161)
at org.eclipse.egit.core.op.ListRemoteOperation.run(ListRemoteOperation.java:116)
at org.eclipse.egit.ui.internal.clone.SourceBranchPage$8.run(SourceBranchPage.java:337)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
Caused by: org.eclipse.jgit.errors.TransportException: https://github.com/CardinalHealth/odm-dynamicallocationxom.git: cannot open git-upload-pack
at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:587)
at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:361)
at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:200)
... 4 more
Caused by: javax.net.ssl.SSLException: Received fatal alert: protocol_version
at com.ibm.jsse2.k.a(k.java:25)
at com.ibm.jsse2.k.a(k.java:3)
at com.ibm.jsse2.at.b(at.java:49)
at com.ibm.jsse2.at.a(at.java:573)
at com.ibm.jsse2.at.i(at.java:73)
at com.ibm.jsse2.at.a(at.java:357)
at com.ibm.jsse2.at.startHandshake(at.java:723)
at com.ibm.net.ssl.www2.protocol.https.c.afterConnect(c.java:215)
at com.ibm.net.ssl.www2.protocol.https.d.connect(d.java:34)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1561)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1489)
at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:491)
at com.ibm.net.ssl.www2.protocol.https.b.getResponseCode(b.java:80)
at org.eclipse.jgit.transport.http.JDKHttpConnection.getResponseCode(JDKHttpConnection.java:108)
at org.eclipse.jgit.util.HttpSupport.response(HttpSupport.java:207)
at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:501)
... 6 more

!ENTRY org.eclipse.egit.ui 4 0 2020-04-24 08:45:10.196
!MESSAGE https://github.com/CardinalHealth/odm-dynamicallocationxom.git: cannot open git-upload-pack
!STACK 0
org.eclipse.jgit.api.errors.TransportException: https://github.com/CardinalHealth/odm-dynamicallocationxom.git: cannot open git-upload-pack
at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:222)
at org.eclipse.jgit.api.LsRemoteCommand.call(LsRemoteCommand.java:161)
at org.eclipse.egit.core.op.ListRemoteOperation.run(ListRemoteOperation.java:116)
at org.eclipse.egit.ui.internal.clone.SourceBranchPage$8.run(SourceBranchPage.java:337)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
Caused by: org.eclipse.jgit.errors.TransportException: https://github.com/CardinalHealth/odm-dynamicallocationxom.git: cannot open git-upload-pack
at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:587)
at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:361)
at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:200)
... 4 more
Caused by: javax.net.ssl.SSLException: Received fatal alert: protocol_version
at com.ibm.jsse2.k.a(k.java:25)
at com.ibm.jsse2.k.a(k.java:3)
at com.ibm.jsse2.at.b(at.java:49)
at com.ibm.jsse2.at.a(at.java:573)
at com.ibm.jsse2.at.i(at.java:73)
at com.ibm.jsse2.at.a(at.java:357)
at com.ibm.jsse2.at.startHandshake(at.java:723)
at com.ibm.net.ssl.www2.protocol.https.c.afterConnect(c.java:215)
at com.ibm.net.ssl.www2.protocol.https.d.connect(d.java:34)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1561)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1489)
at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:491)
at com.ibm.net.ssl.www2.protocol.https.b.getResponseCode(b.java:80)
at org.eclipse.jgit.transport.http.JDKHttpConnection.getResponseCode(JDKHttpConnection.java:108)
at org.eclipse.jgit.util.HttpSupport.response(HttpSupport.java:207)
at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:501)
... 6 more

working on the others ...


--
Charles Herrick
[e:] charles.n.herrick@gmail.com
[m:] (512) 289-0926
Re: Transport Error :: Egit :: clone repository fail [message #1826430 is a reply to message #1826429] Fri, 24 April 2020 17:39 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 494
Registered: August 2016
Senior Member
OK. You are using an IBM JVM, and this looks like bug 558709.

So try setting "-Dcom.ibm.jsse2.overrideDefaultTLS=true" in eclipse.ini first.

And/or remove that http.sslVerify=false git config.

[Updated on: Fri, 24 April 2020 18:07]

Report message to a moderator

Re: Transport Error :: Egit :: clone repository fail [message #1826435 is a reply to message #1826430] Fri, 24 April 2020 18:32 Go to previous messageGo to next message
Charles Herrick is currently offline Charles HerrickFriend
Messages: 17
Registered: July 2016
Location: Jeddo, TX
Junior Member
http:sslVerify=false removed.
Still getting the pop up.
Now I'm seeing "git-upload-pack not permitted on .xxx.git"

added the -Dcom.ibm.jsse2. thing to the .ini file.
Still getting the pop up and seeing git-unload-pack not permitted error on the clone window


--
Charles Herrick
[e:] charles.n.herrick@gmail.com
[m:] (512) 289-0926

[Updated on: Fri, 24 April 2020 18:47]

Report message to a moderator

Re: Transport Error :: Egit :: clone repository fail [message #1826438 is a reply to message #1826435] Fri, 24 April 2020 20:31 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 494
Registered: August 2016
Senior Member
Well, "git-upload-pack not permitted" is something else. "cannot open git-upload-pack" really was http.sslVerify = false on an IBM JDK.

So try again http.sslVerify=false, but leave the -Dcom.ibm.jsse2.overrideDefaultTLS=true line in eclipse.ini. I'd need stack traces again to be sure, but if that combination works, then it's outdated certificates in the IBM JDK you're using.

If it then still doesn't work, I'm a bit out of ideas. Except trying it with a modern Eclipse/EGit combo.
Re: Transport Error :: Egit :: clone repository fail [message #1826607 is a reply to message #1826435] Mon, 27 April 2020 16:31 Go to previous messageGo to next message
Charles Herrick is currently offline Charles HerrickFriend
Messages: 17
Registered: July 2016
Location: Jeddo, TX
Junior Member
Can not finish. I am abandoning Egit and going to use Github Desktop (d/l from Internet).
The EGit fixers need to make this tool work with a lot less pain and agony. Unfortunately, it will not work for me and I will have to dump Egit.


--
Charles Herrick
[e:] charles.n.herrick@gmail.com
[m:] (512) 289-0926
Re: Transport Error :: Egit :: clone repository fail [message #1827510 is a reply to message #1826607] Sat, 16 May 2020 09:07 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1212
Registered: July 2009
Senior Member
again:
you are using a wildly outdated Eclipse release which went out of maintenance years ago and you seem to
be unable to try with a current release. Then you should not blame us.
Re: Transport Error :: Egit :: clone repository fail [message #1843749 is a reply to message #1826351] Mon, 16 August 2021 16:13 Go to previous message
CHANDAN BHAGAT is currently offline CHANDAN BHAGATFriend
Messages: 1
Registered: August 2021
Junior Member
Please follow the given steps-
1) Go to the git hub >> Settings >> Developer Setting >> Personal Access Token >> Click on "Generate New Token" >> Enter the some text on "Note" text field and select the 'repo'(all check box), 'admin:repo_hook'(select all check box), and 'delete repo' checkboxes >> Click on "Generate Token" button => After generate the token number then use this token number as password.
2) Now go to the eclipse and enter the username of git hub and enter the 'Token' number as a password field.
Previous Topic:Wrong file hash
Next Topic:Read the tags from repo without cloning
Goto Forum:
  


Current Time: Wed Sep 28 17:10:12 GMT 2022

Powered by FUDForum. Page generated in 0.02197 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top