Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » [SOLVED] PDT and Xdebug 2.9.4
[SOLVED] PDT and Xdebug 2.9.4 [message #1824464] Wed, 15 April 2020 17:47 Go to next message
Mathieu Dubois is currently offline Mathieu DuboisFriend
Messages: 16
Registered: September 2018
Junior Member
Hello,

I have noticed recently that breakpoints are ignored. It was working quite well since about 2 month ago. I have seen many message from end-2019 about problems with breakpoints but I think non of them apply.

I have noticed that Eclipse seems unable to detect Xdebug: when I try to setup a new PHP interpreter, Eclipse says that Xdebug is not installed. The system itself didn't change (Fedora 31 installation) however Xdebug has been updated to 2.9.4 (I think it works and is well configured).

I have tried Eclipse 2019-12 and Eclipse 2020-03 but the result is the same.

Any idea ?

Thanks in advance,
Mathieu

[Updated on: Tue, 01 September 2020 09:40]

Report message to a moderator

Re: PDT and Xdebug 2.9.4 [message #1826287 is a reply to message #1824464] Wed, 22 April 2020 19:54 Go to previous messageGo to next message
Mathieu Dubois is currently offline Mathieu DuboisFriend
Messages: 16
Registered: September 2018
Junior Member
Bump.
Re: PDT and Xdebug 2.9.4 [message #1831860 is a reply to message #1824464] Tue, 01 September 2020 09:37 Go to previous message
Mathieu Dubois is currently offline Mathieu DuboisFriend
Messages: 16
Registered: September 2018
Junior Member
After suppressing the .metadata folder in the workspace and restarting Eclipse, it works (I updated to Fedora 32 in between but it didn't change anything). I had to reimport my previous projects and reconfigure servers and debuggers though but that was a matter of minutes (as I store debug configuration in the project, as explained in https://www.eclipse.org/forums/index.php/t/1095345/, I didn't need to recreate those).

I guess it was a purely local problem.

[Updated on: Tue, 01 September 2020 09:48]

Report message to a moderator

Previous Topic:Custom name for anoymous methods in outline view
Next Topic:Xdebug - breakpoints don't work
Goto Forum:
  


Current Time: Tue Apr 20 04:57:40 GMT 2021

Powered by FUDForum. Page generated in 0.01782 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top