Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » can't install eclipse :(
can't install eclipse :( [message #1820787] Tue, 28 January 2020 21:21 Go to next message
loic b is currently offline loic bFriend
Messages: 1
Registered: January 2020
Junior Member
[2020-01-28 22:16:54] Executing bootstrap tasks
[2020-01-28 22:16:54] Java(TM) SE Runtime Environment 1.8.0_241-b07
[2020-01-28 22:16:54] Product org.eclipse.products.epp.package.java.2019-12
[2020-01-28 22:16:54] Bundle org.eclipse.oomph.setup 1.15.0.v20191116-1146, build=4434, branch=3a9f8ff482882029c027d32dc59d8b0436598aa8
[2020-01-28 22:16:54] Bundle org.eclipse.oomph.setup.core 1.15.0.v20191103-0619, build=4434, branch=3a9f8ff482882029c027d32dc59d8b0436598aa8
[2020-01-28 22:16:54] Bundle org.eclipse.oomph.setup.p2 1.13.0.v20191019-1424, build=4434, branch=3a9f8ff482882029c027d32dc59d8b0436598aa8
[2020-01-28 22:16:54] Performing P2 Director (Eclipse IDE for Java Developers (2019-12))
[2020-01-28 22:16:54] Offline = false
[2020-01-28 22:16:54] Mirrors = true
[2020-01-28 22:16:54] Resolving 23 requirements from 3 repositories to C:\Users\Loïc\eclipse\java-2019-123\eclipse
[2020-01-28 22:16:54] Requirement epp.package.java [4.14.0,5.0.0)
[2020-01-28 22:16:54] Requirement org.eclipse.platform.feature.group [4.14.0,5.0.0)
[2020-01-28 22:16:54] Requirement org.eclipse.rcp.feature.group [4.14.0,5.0.0)
[2020-01-28 22:16:54] Requirement org.eclipse.buildship.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.eclemma.feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.egit.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.egit.mylyn.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.epp.mpc.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.jdt.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.jgit.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.m2e.feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.m2e.logback.feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.mylyn.context_feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.mylyn.git.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.mylyn.hudson.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.mylyn.ide_feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.mylyn.java_feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.mylyn.wikitext_feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.mylyn_feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.tips.feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.wst.xml_ui.feature.feature.group
[2020-01-28 22:16:54] Requirement org.eclipse.oomph.setup.feature.group
[2020-01-28 22:16:54] Repository http://download.eclipse.org/technology/epp/packages/2019-12
[2020-01-28 22:16:54] Repository http://download.eclipse.org/releases/2019-12/201912181000
[2020-01-28 22:16:54] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2020-01-28 22:16:55] Calculating requirements and dependencies.
[2020-01-28 22:16:56] Computing prerequisite plan
[2020-01-28 22:16:57] Collecting 1 artifacts from http://download.eclipse.org/technology/epp/packages/2019-12
[2020-01-28 22:16:57] Downloading epp.package.java.executable.win32.win32.x86_64
[2020-01-28 22:16:57] Collected 1 artifacts for http://download.eclipse.org/technology/epp/packages/2019-12 in 0.37s
[2020-01-28 22:16:57] Collecting 3 artifacts from http://download.eclipse.org/releases/2019-12/201912181000
[2020-01-28 22:16:58] Downloading org.eclipse.platform_root
[2020-01-28 22:16:58] Downloading org.eclipse.platform.ide.executable.win32.win32.x86_64
[2020-01-28 22:16:58] Downloading org.eclipse.rcp_root
[2020-01-28 22:16:58] Collected 3 artifacts for http://download.eclipse.org/releases/2019-12/201912181000 in 0.459s
[2020-01-28 22:16:58] An error was detected while performing the engine operation and the changes are being rolled back. See the log for details.
[2020-01-28 22:16:58] ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:549)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:341)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:815)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3827)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3755)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3736)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3629)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.installPerform(SimpleVariablePage.java:1325)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.access$32(SimpleVariablePage.java:1187)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage$20.run(SimpleVariablePage.java:1132)
ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=C__Users_Loïc_eclipse_java-2019-123_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
ERROR: org.eclipse.equinox.p2.engine code=0 Error reading signed content.
java.io.IOException: Exception in opening zip file: C:\Users\Loïc\.p2\pool\plugins\org.eclipse.ant.core_3.5.600.v20191122-2102.jar
at org.eclipse.osgi.framework.util.SecureAction.getZipFile(SecureAction.java:340)
at org.eclipse.osgi.internal.signedcontent.SignedBundleHook.getSignedContent(SignedBundleHook.java:217)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.checkCertificates(CertificateChecker.java:77)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.start(CertificateChecker.java:58)
at org.eclipse.equinox.internal.p2.engine.phases.CheckTrust.completePhase(CheckTrust.java:55)
at org.eclipse.equinox.internal.p2.engine.Phase.postPerform(Phase.java:255)
at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase.java:105)
at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet.java:50)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:80)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:48)
at org.eclipse.equinox.internal.provisional.p2.director.PlanExecutionHelper.executePlan(PlanExecutionHelper.java:46)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:545)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:341)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:815)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3827)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3755)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3736)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3629)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.installPerform(SimpleVariablePage.java:1325)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.access$32(SimpleVariablePage.java:1187)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage$20.run(SimpleVariablePage.java:1132)
Caused by: java.io.FileNotFoundException: C:\Users\Loïc\.p2\pool\plugins\org.eclipse.ant.core_3.5.600.v20191122-2102.jar (Le fichier spécifié est introuvable)
at java.util.zip.ZipFile.open(Native Method)
at java.util.zip.ZipFile.<init>(Unknown Source)
at java.util.zip.ZipFile.<init>(Unknown Source)
at java.util.zip.ZipFile.<init>(Unknown Source)
at org.eclipse.osgi.framework.util.SecureAction.getZipFile(SecureAction.java:322)
at org.eclipse.osgi.internal.signedcontent.SignedBundleHook.getSignedContent(SignedBundleHook.java:217)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.checkCertificates(CertificateChecker.java:77)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.start(CertificateChecker.java:58)
at org.eclipse.equinox.internal.p2.engine.phases.CheckTrust.completePhase(CheckTrust.java:55)
at org.eclipse.equinox.internal.p2.engine.Phase.postPerform(Phase.java:255)
at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase.java:105)
at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet.java:50)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:80)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:48)
at org.eclipse.equinox.internal.provisional.p2.director.PlanExecutionHelper.executePlan(PlanExecutionHelper.java:46)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:545)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:341)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:815)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3827)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3755)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3736)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3629)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.installPerform(SimpleVariablePage.java:1325)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.access$32(SimpleVariablePage.java:1187)
... 1 more

[2020-01-28 22:16:58]


need help <3
Re: can't install eclipse :( [message #1823151 is a reply to message #1820787] Fri, 20 March 2020 11:29 Go to previous message
Bla Blabla is currently offline Bla BlablaFriend
Messages: 1
Registered: March 2020
Junior Member
Hey,
the problem is, that the Installer programm needs other programms to complete the installation. Only afterwards the installer will work.

On this website you can find help: "https://wiki.eclipse.org/Eclipse/Installation"

Or you download this zip file from eclipse and it will also work:
"eclipse-java-2020-03-R-win32-x86_64.zip"
link: "https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/2020-03/R/eclipse-java-2020-03-R-win32-x86_64.zip"

I had the same problem as you and I hope it will help you as well.
Cheers.
Previous Topic:I can't choose workspace
Next Topic:maven can not find 2.5.2-SNAPSHOT
Goto Forum:
  


Current Time: Mon Feb 26 02:26:38 GMT 2024

Powered by FUDForum. Page generated in 0.02879 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top