Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » Unable to install LDT to Eclipse 2019-12 (4.14.0)
Unable to install LDT to Eclipse 2019-12 (4.14.0) [message #1819030] Sun, 05 January 2020 15:35 Go to next message
Dan Delgado is currently offline Dan DelgadoFriend
Messages: 2
Registered: January 2020
Junior Member
I was setting up a new laptop and downloaded Eclipse: Version: 2019-12 (4.14.0) but when I tried to add the LDT plugins, it fails because it cannot satisfy dependency (see below.)

The prior version of eclipse I had on my last laptop was 2018-12 (4.10.)

Do you guys have a list of what the last/latest version of Eclipse which works with your (1.4.2?) plugin is?


(pointed repo to "stable" (although tried even nightly after that)
Error message:
Cannot complete the install because one or more required items could not be found.
Software being installed: Lua Development Tools SDK 1.4.2.201804031433 (org.eclipse.ldt.source.feature.group 1.4.2.201804031433)
Missing requirement: Lua Development Tools Core 1.3.0.201804031433 (org.eclipse.ldt 1.3.0.201804031433) requires 'osgi.bundle; org.eclipse.dltk.core [5.5.0,6.0.0)' but it could not be found
Cannot satisfy dependency:
From: Lua Development Tools - Core Feature 1.4.2.201804031433 (org.eclipse.ldt.core.feature.group 1.4.2.201804031433)
To: org.eclipse.equinox.p2.iu; org.eclipse.ldt [1.3.0.201804031433,1.3.0.201804031433]
Cannot satisfy dependency:
From: Lua Development Tools 1.4.2.201804031433 (org.eclipse.ldt.feature.group 1.4.2.201804031433)
To: org.eclipse.equinox.p2.iu; org.eclipse.ldt.core.feature.group [1.4.2.201804031433,1.4.2.201804031433]
Cannot satisfy dependency:
From: Lua Development Tools SDK 1.4.2.201804031433 (org.eclipse.ldt.source.feature.group 1.4.2.201804031433)
To: org.eclipse.equinox.p2.iu; org.eclipse.ldt.feature.group [1.4.2.201804031433,1.4.2.201804031433]
Re: Unable to install LDT to Eclipse 2019-12 (4.14.0) [message #1819105 is a reply to message #1819030] Wed, 08 January 2020 03:14 Go to previous messageGo to next message
Dan Delgado is currently offline Dan DelgadoFriend
Messages: 2
Registered: January 2020
Junior Member
I tried earlier versions and it seems the very prior entry, Eclipse (Java) 2019-09 still allows install of the LDT plug-in.

I also eliminated the MacBook part of the issue. I did testing on Win10 with Eclipse installer and tried several versions - validating 2019-12 did not work there either.


Btw, since they do not go into the "uninstaller" do I need to do anything to cleanup after old Eclipse installs (via Installer) other than deleting directories and program folder shortcuts?
Re: Unable to install LDT to Eclipse 2019-12 (4.14.0) [message #1819120 is a reply to message #1819105] Wed, 08 January 2020 09:35 Go to previous messageGo to next message
Arjan van Vught is currently offline Arjan van VughtFriend
Messages: 1
Registered: January 2020
Junior Member
I report the same issue.

Cannot complete the install because one or more required items could not be found.
Software being installed: Lua Development Tools SDK 1.4.2.201804031433 (org.eclipse.ldt.source.feature.group 1.4.2.201804031433)
Missing requirement: Lua Development Tools UI 1.3.0.201804031433 (org.eclipse.ldt.ui 1.3.0.201804031433) requires 'osgi.bundle; org.eclipse.dltk.formatter [5.5.0,6.0.0)' but it could not be found
Cannot satisfy dependency:
From: Lua Development Tools - Core Feature 1.4.2.201804031433 (org.eclipse.ldt.core.feature.group 1.4.2.201804031433)
To: org.eclipse.equinox.p2.iu; org.eclipse.ldt.ui [1.3.0.201804031433,1.3.0.201804031433]
Cannot satisfy dependency:
From: Lua Development Tools - Core Feature SDK 1.4.2.201804031433 (org.eclipse.ldt.core.source.feature.group 1.4.2.201804031433)
To: org.eclipse.equinox.p2.iu; org.eclipse.ldt.core.feature.group [1.4.2.201804031433,1.4.2.201804031433]
Cannot satisfy dependency:
From: Lua Development Tools SDK 1.4.2.201804031433 (org.eclipse.ldt.source.feature.group 1.4.2.201804031433)
To: org.eclipse.equinox.p2.iu; org.eclipse.ldt.core.source.feature.group [1.4.2.201804031433,1.4.2.201804031433]
Re: Unable to install LDT to Eclipse 2019-12 (4.14.0) [message #1819264 is a reply to message #1819120] Fri, 10 January 2020 17:13 Go to previous messageGo to next message
Simon Bernard is currently offline Simon BernardFriend
Messages: 341
Registered: July 2009
Senior Member
LDT is not compatible with recent version of DLTK.
There is no plan to fix this as the project is not maintained anymore.

The last version of eclipse that I'm sure it is compatible with LDT is Eclipse photon (4.8). Recent one could work but I never test it with it
Re: Unable to install LDT to Eclipse 2019-12 (4.14.0) [message #1819304 is a reply to message #1819264] Sun, 12 January 2020 22:13 Go to previous messageGo to next message
Dave Alkire is currently offline Dave AlkireFriend
Messages: 1
Registered: January 2020
Junior Member
My own issue was similar enough that maybe my solution can work for you.

My scene:
I tried to install from Install New Software from site "http://download.eclipse.org/ldt/releases/stable" though I also had the other LDT sites enabled, same URL but ending in "/milestones" and "/updates-nightly"; I'm not sure if having those made a difference but anyway my errors were like:

"No repository found containing: osgi.bundle,org.eclipse.dltk.core,5.7.1.201703020501"
...plus 5 others, same except instead of "core" they were "debug", "debug.ui", "formatter", "launching" and "ui".

My solution was basically to provide the missing resource from a download since it doesn't seem to be available from repositories any more:

Download the runtime for DLTK 5.7.1 as a zip: Here's a direct link and its MD5. Save it to some logical place; I chose my root eclipse install directory but whatever.

In Eclipse, navigate to menu > Help > Install new software...

Click Manage... to go to Available Software Sites dialog

Click Add... use a good name like "LDTK zip", click the "Archive" button and browse to that zip, downloaded from before.

Then when I tried again the install happened correctly and my initial tests indicate that LDT is working as expected.
Re: Unable to install LDT to Eclipse 2019-12 (4.14.0) [message #1834509 is a reply to message #1819304] Wed, 11 November 2020 15:34 Go to previous message
Lee Cooper is currently offline Lee CooperFriend
Messages: 1
Registered: November 2020
Junior Member
You Sir,
are an absolute genius.
Thank you.
Previous Topic:Moose debugging thru dcs connects but fails on lua code
Next Topic:LDT need new contributors/committers !
Goto Forum:
  


Current Time: Tue Nov 24 10:15:32 GMT 2020

Powered by FUDForum. Page generated in 0.01765 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top