Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Compatibility problem of dependencies on com.google.common.* between EMF Compare and Xtext
Compatibility problem of dependencies on com.google.common.* between EMF Compare and Xtext [message #1818671] Sun, 22 December 2019 19:07 Go to next message
Dominique Blouin is currently offline Dominique BlouinFriend
Messages: 1
Registered: December 2019
Junior Member
I have an OSGI application that uses EMF compare 3.3.8 and XText 2.19 on Eclipse Modeling Tools 2019-09. When I execute the application I get the error below.

The source of the problem seems to be an inconsistency between the required dependencies on com.google.common.* of EMF Compare and Xtext. EMF Compare requires a version between 15 and 22 while Xtext requires at least 27. Therefore two versions of the classes are loaded leading to the error below. When I modify EMF compare to remove the upper version requirement it solves the problem. Is there a reason why EMF Compare requires no more than version 22 of com.google.common.*?

Thanks for your help.


java.lang.LinkageError: loader constraint violation: when resolving method "fr.tpt.aadl.ramses.generation.utils.GeneratorUtils$NoBAComparisonScope.setResourceContentFilter(Lcom/google/common/base/Predicate;)V" the class loader (instance of org/eclipse/osgi/internal/loader/EquinoxClassLoader) of the current class, fr/tpt/aadl/ramses/generation/utils/GeneratorUtils$NoBAComparisonScope, and the class loader (instance of org/eclipse/osgi/internal/loader/EquinoxClassLoader) for the method's defining class, org/eclipse/emf/compare/scope/FilterComparisonScope, have different Class objects for the type com/google/common/base/Predicate used in the signature
Re: Compatibility problem of dependencies on com.google.common.* between EMF Compare and Xtext [message #1818680 is a reply to message #1818671] Sun, 22 December 2019 22:07 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31159
Registered: July 2009
Senior Member
The latest version of EMF Compare has a broader dependency range:

https://download.eclipse.org/oomph/archive/reports/download.eclipse.org/releases/2019-12/http___download.eclipse.org_releases_2019-12_201912181000/org.eclipse.emf.cdo.compare_4.3.400.v20191204-0637.html#java.package;_com.google.common.collect_[15.0.0,28.0.0)

So best you switch to the latest releases of each of these.
Previous Topic:Versão e alterar o idioma
Next Topic:ERROR IN SETUP MAC OS X 10.15.2
Goto Forum:
  


Current Time: Sun May 31 07:11:52 GMT 2020

Powered by FUDForum. Page generated in 0.02972 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top