Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problem in connecting with Java(When I try to start Eclipse I get a message saying that jdk-12.0.2\bin must be available)
Problem in connecting with Java [message #1816470] Tue, 29 October 2019 18:44 Go to next message
Gerry Wolff is currently offline Gerry WolffFriend
Messages: 4
Registered: October 2019
Junior Member
When I try to start up Eclipse (which appears to be the latest version "Cpp 2019-09"), I get the following message:

"A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations: C:\Program Files\Java\jdk-12.0.2\bin"

I believe that I have the latest version of the JDK installed (jdk1.8.0-231).

I can't get beyond this message. How can this problem be fixed?

With thanks.

Re: Problem in connecting with Java [message #1816483 is a reply to message #1816470] Wed, 30 October 2019 03:18 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30635
Registered: July 2009
Senior Member
Did you install it with the installer? Does that 12.0.1 version of Java exist in your file system? Where on the file system does the 1.8.0-231 version exist? Does your eclipse.ini contain lines like this:
-vm
C:\Program Files\Java\jdk1.8.0_72\jre\bin
You can use this to "choose" which version of Java to use, or remove it so it finds whatever is on the PATH (or specified in JAVA_HOME).
Re: Problem in connecting with Java [message #1816507 is a reply to message #1816483] Wed, 30 October 2019 10:01 Go to previous message
Gerry Wolff is currently offline Gerry WolffFriend
Messages: 4
Registered: October 2019
Junior Member
JGW: Thanks for your questions and suggestion. Here are my answers and the result -- success! Many thanks.

Did you install it with the installer? JGW: yes

Does that 12.0.1 version of Java exist in your file system? JGW: It is not under "C:\Program Files\Java" and I don't see anywhere else that it could be.

Where on the file system does the 1.8.0-231 version exist? JGW: There are many files under "C:\Program Files\Java\jdk1.8.0_231\bin" which I assume are the files for version 1.8.0-231.

Does your eclipse.ini contain lines like this:

-vm
C:\Program Files\Java\jdk1.8.0_72\jre\bin JGW: No, it has:

"-vm
C:\Program Files\Java\jdk-12.0.2\bin"

You can use this to "choose" which version of Java to use, or remove it so it finds whatever is on the PATH (or specified in JAVA_HOME).

JGW: It looks as if things have been set up for a Unix OS. I guess the eclipse.ini file is provided for command-line options under Windows 10.

I've removed

"-vm
C:\Program Files\Java\jdk-12.0.2\bin"

and this seems to have solve the problem. Many thanks!
Previous Topic:Open files in detached editors
Next Topic:Eclipse RCP 4.11 and Open JDK 11
Goto Forum:
  


Current Time: Fri Nov 15 15:03:13 GMT 2019

Powered by FUDForum. Page generated in 0.03251 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top