Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Is PDT Built in Eclipse IDE for Web and JavaScript Developers? (PDT and Eclipse IDE for Web and JavaScript Developers )
Is PDT Built in Eclipse IDE for Web and JavaScript Developers? [message #1816390] Mon, 28 October 2019 22:37 Go to next message
Ken Stringer is currently offline Ken StringerFriend
Messages: 1
Registered: October 2019
Junior Member
Since Eclipse 2019-06 is the base of the Eclipse IDE for Web and JavaScript Developers (I assume), and PDT says version 6.2 is included in Eclipse 2019-06, then can I assume Eclipse IDE for Web and JavaScript Developers 2019-06 will contain PDT 6.2? I ask because with my organization must approve all software and I have PDT 6.3 and Eclipse IDE for Web and JavaScript Developers 2019-06 approved, but 2019-06 is not compatible with PDT 6.3 (at least that is what I read from the website). I hope this makes sense. Thanks.
Re: Is PDT Built in Eclipse IDE for Web and JavaScript Developers? [message #1816432 is a reply to message #1816390] Tue, 29 October 2019 13:13 Go to previous message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 289
Registered: March 2013
Senior Member
Current eclipse is now 2019-09, on download page you can find 2 different packages: https://www.eclipse.org/downloads/packages/

Eclipse IDE for PHP Developers - Contains PDT 6.3 and some JavaScript stuff: see detailed features list: https://www.eclipse.org/downloads/packages/release/2019-09/r/eclipse-ide-php-developers
Eclipse IDE for Web and JavaScript Developers (includes Incubating components) - Contains only JavaScript related items. Besides WTP and JSDT also contain Wild Web Developer that often isn't stable: https://marketplace.eclipse.org/content/eclipse-wild-web-developer-html-css-javascript-typescript-nodejs-angular-json-yaml

You can always mix them. And ADD to PDT to second : https://marketplace.eclipse.org/content/php-development-tools
Or add WildWebDeveloper to PHP Package


Previous Topic:PHPUnit not working (thus far) on Oxygen.1
Next Topic:Debug Conceptual Question for Eclipse 2019-03
Goto Forum:
  


Current Time: Fri Apr 23 15:35:18 GMT 2021

Powered by FUDForum. Page generated in 0.01540 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top