Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Save buttons not enabling consistently in EGit Merge Tool in PDT
Save buttons not enabling consistently in EGit Merge Tool in PDT [message #1816033] Thu, 17 October 2019 18:00 Go to next message
Everton Sant\\\'Ana de Araujo is currently offline Everton Sant\\\'Ana de AraujoFriend
Messages: 1
Registered: October 2019
Junior Member
EGit merge tool is causing real problems for our team. It is tricky to identify cause due to the underpinning complexity of EGit but here is what we are typically seeing...

1. Do a merge;
2. open a merged file showing conflicts in merge tool; and
3. make changes on the left hand side.

The save buttons are not enabled, preventing the changes from being saved!

This happens and as you can imagine, after going through a large file resolving conflicts, not being able to save it is seriously time wasting and frustrating for our developers.

This problem have been occurring since EGit 5.3.0. For instance, it is NOT occurring in "eclipse-php-2018-12-R-linux-gtk-x86_64" (EGit version 5.2.0.201812061821-r 2018-12-19).

I hope this gives you sufficient information but if not please let me know and I will certainly try to provide what is required.
Re: Save buttons not enabling consistently in EGit Merge Tool in PDT [message #1816184 is a reply to message #1816033] Wed, 23 October 2019 09:59 Go to previous message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 175
Registered: August 2016
Senior Member
This is a known bug in PDT. Where in fact you had commented already. It makes no sense to cross-post that here. See bug 547246.

It's not EGit that's causing the problem; it's that EGit has changed in version 5.3.0 and now triggers an old bug in PDT. This has to be fixed in PDT.

A known work-around is not to use the "Php compare" but a plain "Text compare".
Previous Topic:Clone error - non ASCII chars on file name
Next Topic:JGit: HTTPS links over a proxy that requires authentication
Goto Forum:
  


Current Time: Sun Dec 15 12:34:10 GMT 2019

Powered by FUDForum. Page generated in 0.01679 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top