Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Problem setting up target platform for multi-platform builds
Problem setting up target platform for multi-platform builds [message #1814065] Mon, 02 September 2019 17:06 Go to next message
Harald Stangl is currently offline Harald StanglFriend
Messages: 2
Registered: September 2019
Junior Member
I'm trying to migrate a project that uses the old Delta Pack approach for multi platform builds to using the latest Eclipse version 4.12 and the newer approach described in https://wiki.eclipse.org/A_Brief_Overview_of_Building_at_Eclipse#Preferred_way_of_doing_multi-platform_builds.

However, Eclipse is failing to setup the target platform with a quite strange error message:
index.php/fa/36209/0/

Directly installing Equinox Target Components into my Eclipse installation works and enables the "Export for multiple platforms" dialogue in the product export window, but does not install the required launchers for Linux and Windows (I'm on Mac).

Any help is appreciated, as all information I can find is about using the delta pack, but near to no information at all about the new approach.
Re: Problem setting up target platform for multi-platform builds [message #1814388 is a reply to message #1814065] Tue, 10 September 2019 18:26 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32494
Registered: July 2009
Senior Member
Sorry, it seems no one will answer this. There really aren't enough details about how exactly how your target platform is specified (i.e., how would someone else reproduce this?) and in the end, this is more of a PDE question than an Equinox question.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Problem setting up target platform for multi-platform builds [message #1814567 is a reply to message #1814065] Fri, 13 September 2019 10:31 Go to previous messageGo to next message
Harald Stangl is currently offline Harald StanglFriend
Messages: 2
Registered: September 2019
Junior Member
Thanks for the feedback. I just took a fresh Eclipse 4.12 (2019-06) DSL edition and followed the steps described here: https://wiki.eclipse.org/A_Brief_Overview_of_Building_at_Eclipse#Preferred_way_of_doing_multi-platform_builds

If this is not the right place to ask, is there a moderator who can move this topic to PDE, or should I rather re-post there?
Re: Problem setting up target platform for multi-platform builds [message #1814578 is a reply to message #1814567] Fri, 13 September 2019 14:06 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32494
Registered: July 2009
Senior Member
This web forum is not so flexible to move post so better just ask there.

https://www.eclipse.org/forums/index.php/f/14/

Just keep in mind that no one is going to invest a 1/2 hour reading documentation and following various manual steps hoping to reproduce your problem to then help you fix it. Better you make reproducing the problem trivial by sharing the *.target file with the problem, not just a screen image of something because those are more like tea leaves a the bottom of a teacup....


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Error when launching marketplace
Next Topic:Debugging eclipse binaries
Goto Forum:
  


Current Time: Wed Sep 28 10:47:49 GMT 2022

Powered by FUDForum. Page generated in 0.02149 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top