Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Connecting with Tomcat or installingTomcat Plugin(Can't get Tomcat Server to work in any way)
Connecting with Tomcat or installingTomcat Plugin [message #1804708] Sat, 30 March 2019 01:43
Johnny Kalesony is currently offline Johnny KalesonyFriend
Messages: 1
Registered: March 2019
Junior Member
Hello,
I'm sorry for new topic right after forum registration, but I don't know where to look for help.
I try to get Tomcat working with eclipse in any way, so I will describe two ways haw I tried to handle with this.
To save our time please see the solutions, that I've tried.

My configuration:
Mint 19.1 Tessa with XFCE4. It is based on Ubuntu 18.04 Bionic Beaver. (64bit)
Eclipse IDE for Enterprise Java Developers.
Version: 2018-12 (4.10.0)
Build id: 20181214-0600
OS: Linux, v.4.15.0-20-generic, x86_64 / gtk 3.22.30, WebKit 2.22.6
Java version: 11.0.1 (OpenJDK)(and its JDK, not JRE ;) )
Tomcat version 8.5.39 /9.14.0(tried both versions)


1st way - I have installed Tomcat independently.
I followed this instruction and it works fine.
https:[REMOVE THIS}]//hostovita.pl/blog/jak-zainstalowac-apache-tomcat-8-na-ubuntu-16-04/
It's in polish, but If you want to see what I exactly did- the commands are written on red font.
I don't think it's very important because it works fine.
I have control over it- when I launch it, it starts and the status is "running" and it stops when I command to.

The problem is when I try to add this server in eclipse in "Servers". I see the message:
"Unknown version of Tomcat was specified."
Please help me with that.


When I do (on purpose) mistake in installation directory, message changes to:
The specified Tomcat installation directory does not exist.
That means, that eclipse detects Tomcat, but something is wrong with the version.
Thats why I have tried version 8.5.39 instead of 9.0.17, but it doesnt help.
I also tried adding it when server was on and off.

//================================================
The second way I tried
And that was too much, I decided to install Tomcat Plugin from Marketplace.
When I have installed it (the little bar in screen bottom was complete)
I was asked to restart eclipse- I restarted even whole computer.
Menu buttons of Tomcat are visible, clickable but they dont have make any reaction, nothing happens when I try to launch.

Please tell me is f it is something wrong what I do? is it some bug?
I would appreciate any answer.

[Updated on: Sat, 30 March 2019 08:23]

Report message to a moderator

Previous Topic:Debugging in Eclipse Umple Plugin
Next Topic:Eclipse updater deletes eclipse.exe?
Goto Forum:
  


Current Time: Sun Jul 21 21:13:55 GMT 2019

Powered by FUDForum. Page generated in 0.02963 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top