Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » [Equinox] [java 10] Missing service: org.eclipse.osgi.service.resolver.PlatformAdmin
[Equinox] [java 10] Missing service: org.eclipse.osgi.service.resolver.PlatformAdmin [message #1795702] Thu, 27 September 2018 06:15
Tharindu Wijewardane is currently offline Tharindu WijewardaneFriend
Messages: 7
Registered: September 2018
Junior Member
Hi all,

I am trying to upgrade an OSGi based software platform (Wso2 Carbon version 4) to be able to run on java 10. I have upgraded OSGi dependencies to Luna and I was able to build it with java 8. When the framework is launched on java 10 some bundles are not activated due to the missing service org.eclipse.osgi.service.resolver.PlatformAdmin.

osgi> b 98
org.wso2.carbon.core_4.4.3511 [98]
  Id=98, Status=RESOLVED    Data Root=/Users/tharindu/IdeaProjects/luna-carbon-kernel/distribution/product/modules/distribution/target/wso2carbon-4.4.3511/repository/components/default/configuration/org.eclipse.osgi/98/data
  "No registered services."
  No services in use.
gogo: IllegalStateException: Missing service: org.eclipse.osgi.service.resolver.PlatformAdmin
osgi> 


Any clue to solve the above issue is highly appreciated.
Previous Topic:Prototype service instances in the console
Next Topic:[Equinox] [java 10] Missing service: org.eclipse.osgi.service.resolver.PlatformAdmin
Goto Forum:
  


Current Time: Tue Sep 21 08:37:47 GMT 2021

Powered by FUDForum. Page generated in 0.02188 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top