Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse won't run on Windows 10
Eclipse won't run on Windows 10 [message #1793615] Sat, 11 August 2018 19:29 Go to next message
Marcus Bakker is currently offline Marcus BakkerFriend
Messages: 3
Registered: August 2018
Junior Member
Hello,

I'm a java beginner. I downloaded Eclipse (eclipse-java-helios-SR1-win32-x86_64.zip was the zip file).
I have Java version 10.0.2 on my PC, Windows 10 64bit and I have Java in my path (can run java or javac from the command prompt anywhere). I've spent 2 hours googling for an answer and haven't found it so I hope you can help.
Every time I run sclipse.exe I get the message: An error has occured, see log file xxxxx. Below the contents of the log file. No idea how to fix this. Thanks for any advice.

!SESSION 2018-08-11 21:21:24.330 -----------------------------------------------
eclipse.buildId=M20100909-0800
java.version=10.0.2
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Framework arguments: -product org.eclipse.epp.package.java.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.java.product

!ENTRY org.eclipse.equinox.simpleconfigurator 4 0 2018-08-11 21:21:24.621
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.simpleconfigurator_1.0.200.v20100503 [1]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)

!ENTRY org.eclipse.osgi 4 0 2018-08-11 21:21:24.627
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.simpleconfigurator_1.0.200.v20100503.jar/ was not resolved.

!ENTRY org.eclipse.osgi 2 0 2018-08-11 21:21:24.630
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2018-08-11 21:21:24.630
!MESSAGE Bundle org.eclipse.equinox.simpleconfigurator_1.0.200.v20100503 [1] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.simpleconfigurator 2 0 2018-08-11 21:21:24.630
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4

!ENTRY org.eclipse.osgi 4 0 2018-08-11 21:21:24.635
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
Re: Eclipse won't run on Windows 10 [message #1793617 is a reply to message #1793615] Sat, 11 August 2018 20:16 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3250
Registered: July 2009
Senior Member

Helios is a nearly 8 year old release. Get Photon, specifically http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/photon/R/eclipse-java-photon-R-win32-x86_64.zip .

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse won't run on Windows 10 [message #1793624 is a reply to message #1793617] Sun, 12 August 2018 09:56 Go to previous messageGo to next message
Marcus Bakker is currently offline Marcus BakkerFriend
Messages: 3
Registered: August 2018
Junior Member
Thanks for your reply!
I did download Photon and deleted as it was only for javascript or web-based Java. Am I wrong?
Re: Eclipse won't run on Windows 10 [message #1793625 is a reply to message #1793617] Sun, 12 August 2018 10:20 Go to previous message
Marcus Bakker is currently offline Marcus BakkerFriend
Messages: 3
Registered: August 2018
Junior Member
I installed Photon again and found the Eclipse IDE. Thank you!
Previous Topic:Eclipse launcher unable for find shared library error
Next Topic:Warning: You are installing software that contains unsigned content.
Goto Forum:
  


Current Time: Tue Sep 18 23:02:16 GMT 2018

Powered by FUDForum. Page generated in 0.02994 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top