Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Eclipse EGIT plugin install Missing Requirement required items could not be found(Eclipse plugin install issue - receiving error message - "Missing requirement:...requires '<product>' but it could not be found")
Eclipse EGIT plugin install Missing Requirement required items could not be found [message #1786708] Wed, 09 May 2018 16:54 Go to next message
Jeffery DuBois is currently offline Jeffery DuBoisFriend
Messages: 4
Registered: May 2018
Junior Member
For Eclipse version 3.6.2 when installing the EGIT plug-in an error is occurring. I have tried a couple different plug-in versions. The error message is "Missing requirement:...requires '<product>' but it could not be found",
***Why are these plugins missing required products? What is the fix?****
A couple of concrete examples of error messages:
>>>>>>>>>>>>>>>>>>>>>>>>>>>
Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse JGit Command Line Interface 2.0.0.201206130900-r (org.eclipse.jgit.pgm.feature.group 2.0.0.201206130900-r)
Missing requirement: Eclipse JGit Command Line Interface 2.0.0.201206130900-r (org.eclipse.jgit.pgm.feature.group 2.0.0.201206130900-r) requires 'org.kohsuke.args4j [2.0.0,3.0.0)' but it could not be found

>>>>>>>>>>>>>>>>>>>>>>>>>>
Cannot complete the install because one or more required items could not be found.
Software being installed: EGit Mylyn 2.3.1.201302201838-r (org.eclipse.egit.mylyn.feature.group 2.3.1.201302201838-r)
Missing requirement: EGit Mylyn 2.3.1.201302201838-r (org.eclipse.egit.mylyn.feature.group 2.3.1.201302201838-r) requires 'org.eclipse.mylyn.team_feature.feature.group 3.5.0' but it could not be found
>>>>>>>>>>>>>>>>>>>>>>>>>>
Please see attached file for screenshots -

Re: Eclipse EGIT plugin install Missing Requirement required items could not be found [message #1786749 is a reply to message #1786708] Thu, 10 May 2018 14:50 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1039
Registered: July 2009
Senior Member
Why do you want to install such an ancient version of JGit and EGit ?

If you want to install the task focused interface / Mylyn integration you need the respective Mylyn version installed.
https://www.eclipse.org/mylyn/downloads/
Re: Eclipse EGIT plugin install Missing Requirement required items could not be found [message #1786756 is a reply to message #1786749] Thu, 10 May 2018 16:50 Go to previous messageGo to next message
Jeffery DuBois is currently offline Jeffery DuBoisFriend
Messages: 4
Registered: May 2018
Junior Member
Hi Matthias Sohn - Thank you for your prompt response!
As far as I know I do not necessarily want to install " the task focused interface / Mylyn integration" - it seems to be requiring this - is there some way to suppress that requirement?

Fyi I attempted to install egit 2.0.0.201206130900-r again, this time unselecting the "source" option and now I am receiving a different missing requirement -
EGit Import Support 2.0.0.201206130900-r (org.eclipse.egit.import.feature.group 2.0.0.201206130900-r) requires 'org.eclipse.team.core 3.6.100' but it could not be found"

Where do I find "org.eclipse.team.core 3.6.100" and/or the other missing products (e.g. 'org.kohsuke.args4j [2.0.0,3.0.0 ) .

The answer to your question regarding why we are using such an old version of eclipse (v3.6.2) is that my team is using a version of IBM's integration designer application that used eclipse 3.6.2 as its base. We are transitioning from SVN to Git and consequently we need to use the EGit plug-in that is compatible with 3.6.2.
Couple of questions:
1. A primary question - How do I determine what EGIT plug-ins are compatible with eclipse 3.6.2?
When I went to this site https://wiki.eclipse.org/EGit/FAQ#What_versions_of_Eclipse_does_EGit_target.3F I did not find v3.6.2 explicitly listed but I did find this reference:
EGit 2.0.0.201206130900-r >> Eclipse 3.5.2+ (Galileo) (except EGit Import Support feature, which is optional)

Then above where "3.5.2+" is referenced version "3.7.2+" is referenced.
3.6.2 is between the 3.5.2 and 3.7.2 ,
therefore it appears that EGit 2.0.0.201206130900-r is the correct plugin choice for my situation. Please confirm.
What I used for my attempts at installing plug-ins was EGit 2.0.0.201206130900-r and 2.3.1.201302201838-r.
I found the plugins at https://wiki.eclipse.org/EGit/FAQ#What_versions_of_Eclipse_does_EGit_target.3F

2. Apparently there may be several dependences that are missing from these plugins. How can I determine what all the missing dependencies are? Is there some way to identify these dependencies without having to execute multiple install attempts, one for each dependency failure?

Thank you for all your help! It is very much appreciated.

[Updated on: Fri, 11 May 2018 12:17]

Report message to a moderator

Re: Eclipse EGIT plugin install Missing Requirement required items could not be found [message #1787085 is a reply to message #1786756] Fri, 18 May 2018 15:51 Go to previous messageGo to next message
Jeffery DuBois is currently offline Jeffery DuBoisFriend
Messages: 4
Registered: May 2018
Junior Member
I found a solution to this "Missing Requirements" issue EGIT plugin install issue - essentially the solution was to install the EGit plugin without installing the "EGit Mylyn" feature and without installing the "EGIT Plug-in Import Support" feature.
To do this I brought up the Java Perspective first, and then I selected the Help>>Install New Software option, then I entered in the "Work with:" text field the following url: ' http://download.eclipse.org/egit/updates-2.1/ '.
After the IDE reads in the available install-able products/features based on that url, the IDE by default selects all the products to be installed. To unselect items to be installed, I expanded the "Eclipse Git Team Provider" option, and then un-selected both the "EGit Mylyn" and "EGit Plug-in Import Support" features/options. I then Clicked on Next, agreed to the conditions mentioned, and then clicked on Finish. Once the installation finishes you are prompted to restart the IID.

Re: Eclipse EGIT plugin install Missing Requirement required items could not be found [message #1787089 is a reply to message #1786708] Fri, 18 May 2018 16:14 Go to previous messageGo to next message
Jeffery DuBois is currently offline Jeffery DuBoisFriend
Messages: 4
Registered: May 2018
Junior Member
Solution was to unselect both the "EGit Mylyn" feature and the "EGIT Plug-in Import Support" feature so that no attempt would be made to install those features.
Re: Eclipse EGIT plugin install Missing Requirement required items could not be found [message #1788651 is a reply to message #1787089] Wed, 30 May 2018 19:26 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1039
Registered: July 2009
Senior Member
If you want to find out which version of mylyn is needed look at the source code of that version [1]:

<requires>
<import feature="org.eclipse.egit" version="2.0.0" match="greaterOrEqual"/>
<import feature="org.eclipse.mylyn.team_feature" version="3.5.0" match="greaterOrEqual"/>
</requires>

[1] https://git.eclipse.org/r/plugins/gitiles/egit/egit/+/1f07f085d6bcae0caf372fffec19583ac5615d3b/org.eclipse.egit.mylyn-feature/feature.xml#26
Re: Eclipse EGIT plugin install Missing Requirement required items could not be found [message #1788654 is a reply to message #1788651] Wed, 30 May 2018 19:27 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1039
Registered: July 2009
Senior Member
Find old versions of Mylyn here
https://www.eclipse.org/mylyn/downloads/archive.php
Previous Topic:Status of proposal and timeline?
Next Topic:What is the action for CVE 2018-11234 and CVE 2018-11235?
Goto Forum:
  


Current Time: Thu Nov 15 20:35:19 GMT 2018

Powered by FUDForum. Page generated in 0.02335 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top