Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » Design Tab Not Showing Anything(Design Tab has all the little boxes but with nothing in them)
Design Tab Not Showing Anything [message #1786272] Sun, 29 April 2018 05:06 Go to next message
Woah Nelly is currently offline Woah NellyFriend
Messages: 2
Registered: April 2018
Junior Member
My windows builder design tab isn't showing my GUI, it's basically blank. I've tried opening new projects, updating & uninstalling windowsbuilder, the project is opened with windowsbuilder editor, but the thing just doesn't seem to be working. No online solutions that I've found have solved the issue.

I started on this project probably a couple months ago but closed it, I came back to finish it just now and it's doing this.

Additionally, when I go to layout assistant it says "Empty Selection"

Sorry about the file being a attachment can't link it or use BBcode because this is my first post.


  • Attachment: designtab.PNG
    (Size: 23.65KB, Downloaded 1318 times)
Re: Design Tab Not Showing Anything [message #1786398 is a reply to message #1786272] Wed, 02 May 2018 15:54 Go to previous messageGo to next message
Avi Abrami is currently offline Avi AbramiFriend
Messages: 31
Registered: December 2017
Member
Does the "Source" tab display your source code?
Did you check the workspace log file?
Have you changed java versions in the last couple of months?
Did you try doing a "Clean"?
Re: Design Tab Not Showing Anything [message #1786409 is a reply to message #1786398] Thu, 03 May 2018 00:04 Go to previous messageGo to next message
Woah Nelly is currently offline Woah NellyFriend
Messages: 2
Registered: April 2018
Junior Member
Yeah the source tab shows the code.
I've not tried a clean, what is that?
Do not believe I've changed java version in the past couple months.
Also have not checked workspace log, not quite sure what that is.

Sorry, I'm pretty new to this and not super smart.
Re: Design Tab Not Showing Anything [message #1786465 is a reply to message #1786409] Thu, 03 May 2018 17:14 Go to previous messageGo to next message
Avi Abrami is currently offline Avi AbramiFriend
Messages: 31
Registered: December 2017
Member
[menu] Project > Clean...
File ".log" in ".metadata" subdirectory of your workspace directory.
Re: Design Tab Not Showing Anything [message #1833797 is a reply to message #1786409] Fri, 23 October 2020 21:24 Go to previous messageGo to next message
Jamal Al-Khatib is currently offline Jamal Al-KhatibFriend
Messages: 1
Registered: October 2020
Junior Member
Hi Guys,

I'm struggling now with the same problem,
I installed swing and we I create a JFrame file the source code appear but thee design is blank.
Can you please help me ? How did you solve your problem?
It's urgent Please.
Re: Design Tab Not Showing Anything [message #1833887 is a reply to message #1833797] Tue, 27 October 2020 04:08 Go to previous messageGo to next message
Sebastian Arriaga is currently offline Sebastian ArriagaFriend
Messages: 2
Registered: October 2020
Junior Member
I have the same problem
Re: Design Tab Not Showing Anything [message #1833925 is a reply to message #1833887] Tue, 27 October 2020 23:08 Go to previous messageGo to next message
Popa Miruna is currently offline Popa MirunaFriend
Messages: 1
Registered: October 2020
Junior Member
I have the same issue. Have you solved it?
Re: Design Tab Not Showing Anything [message #1833926 is a reply to message #1833925] Wed, 28 October 2020 06:11 Go to previous messageGo to next message
Sebastian Arriaga is currently offline Sebastian ArriagaFriend
Messages: 2
Registered: October 2020
Junior Member
Nobody response. I believe that the problem is common
Re: Design Tab Not Showing Anything [message #1833987 is a reply to message #1833926] Thu, 29 October 2020 14:10 Go to previous messageGo to next message
Özgür Sözüsağlam is currently offline Özgür SözüsağlamFriend
Messages: 1
Registered: October 2020
Junior Member
Hi Guys,
I had the same problem and I think I solved. Here is the solution :
Help-->Eclipse Marketplace--> Type "WindowBuilder 1.9.4 (the last version up to now I think) and click update.
After updating WindowBuilder, the design tab is opening now.
Bests.

Re: Design Tab Not Showing Anything [message #1834842 is a reply to message #1786272] Wed, 18 November 2020 20:29 Go to previous messageGo to next message
Strix Code is currently offline Strix CodeFriend
Messages: 1
Registered: November 2020
Junior Member
I had the same issue after a fresh install of Eclipse 2020-09.
Re: Design Tab Not Showing Anything [message #1836533 is a reply to message #1833797] Thu, 07 January 2021 04:16 Go to previous messageGo to next message
SEONGJONG LEE is currently offline SEONGJONG LEEFriend
Messages: 1
Registered: January 2021
Junior Member
Did you solve the problem?
If you can't see the Design tab yet, try the following:

When opening a file, right-click and select 'Open with' > 'WindowBuilder Editor'. If Window Builder is installed, you will see the Design tab in the newly opened file.

Hope this solution helps you. For reference, I checked it in eclipse 2020-12.

from swcodingschool
Re: Design Tab Not Showing Anything [message #1838220 is a reply to message #1836533] Thu, 18 February 2021 17:55 Go to previous message
Andy P is currently offline Andy PFriend
Messages: 1
Registered: February 2021
Junior Member
Quote:
right-click and select 'Open with' > 'WindowBuilder Editor'


Worked for me.

One thing I noticed causes this is when I switch from Debug perspective back to Java perspective the 'Design' disappears and above solution brings it back.
Previous Topic:Locked Components moving Windowbuilder
Next Topic:jrt-fs.jar problem with new install
Goto Forum:
  


Current Time: Wed Sep 28 20:31:42 GMT 2022

Powered by FUDForum. Page generated in 0.02099 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top