Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Tomcat 9.0.7 from Oxygen 3A(Can't use TOMCAT 9.0.7 with Eclipse Oxygen 3A)
Tomcat 9.0.7 from Oxygen 3A [message #1786042] Tue, 24 April 2018 16:11 Go to next message
Charles Andrews is currently offline Charles AndrewsFriend
Messages: 1
Registered: April 2018
Junior Member
I am using Eclipse Oxygen 3A Release (4.7.3a) and Apache Tomcat version 9.0.7 on a Windows 10 system. I am using JAVA 10 and the JDK is installed. I have set the JAVA_HOME environment variable and the bin and lib directories of the JDK are in the path variable. In Eclipse preferences I have set the runtime environment on the server Apache Tomcat V9.0

Tomcat works when I invoke it from the command line.

When I attempt to debug a project in Eclipse I get:

Error: Could not create the Java Virtual Machine

from the Java Virtual Machine Launcher. I then get the following error message:

'Starting Tomcat V9.0 Server at localhost' has encountered a problem.
Server Tomcat V9.0 server failed to start

The Eclipse console has the following entry:

-Djava.endorsed.dirs=C:\Program Files\Apache Software Foundation\apache-tomcat-9.0.7\endorsed is not supported. Endorsed standards and standalone APIs
in modular form will be supported via the concept of upgradeable modules.


Can anyone help me with this?


Charles


Re: Tomcat 9.0.7 from Oxygen 3A [message #1786294 is a reply to message #1786042] Mon, 30 April 2018 05:52 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3254
Registered: July 2009
Senior Member

You need an update that isn't on the main Oxygen site. Add http://download.eclipse.org/webtools/repository/oxygen/
as a URL in your Available Software Sites preference page and then check for updates from the Help menu.

https://bugs.eclipse.org/533162


Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Mon, 30 April 2018 05:54]

Report message to a moderator

Re: Tomcat 9.0.7 from Oxygen 3A [message #1786308 is a reply to message #1786294] Mon, 30 April 2018 14:25 Go to previous messageGo to next message
Saurabh Bhoomkar is currently offline Saurabh BhoomkarFriend
Messages: 1
Registered: April 2018
Junior Member
Thanks Nitin , Issue is resolved after installing wtp 3.9.4
Re: Tomcat 9.0.7 from Oxygen 3A [message #1786334 is a reply to message #1786042] Tue, 01 May 2018 14:47 Go to previous messageGo to next message
Nena Basina is currently offline Nena BasinaFriend
Messages: 1
Registered: May 2018
Junior Member
I already did the steps you described but the error remains... What else could be missing?
Re: Tomcat 9.0.7 from Oxygen 3A [message #1786341 is a reply to message #1786334] Tue, 01 May 2018 17:22 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3254
Registered: July 2009
Senior Member

Were you already otherwise on a fully updated Oxygen installation? And note that the URL is not the general Oxygen Update Site.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Tomcat 9.0.7 from Oxygen 3A [message #1786516 is a reply to message #1786341] Fri, 04 May 2018 20:54 Go to previous messageGo to next message
Jeff Spelman is currently offline Jeff SpelmanFriend
Messages: 4
Registered: May 2018
Junior Member
I'm new to Eclipse, so I apologize if this is a stupid question.

I am having the same problems, Ubuntu 16.04, Tomcat 9, Eclipse 3A and Java 10. When I look in "Help->Install New Software...-> What is already installed" it indicates Eclipse Jave EE Developer Tools are version 3.9.3. So that would seem to explain why Tomcat won't start from Eclipse.

I put the update site, http://download.eclipse.org/webtools/repository/oxygen/, into Available Software Sites and did Check for updates and it did some updates (it updated Eclipse Web Developer Tools to 3.9.2) but subsequent Check for updates indicate there are no available updates. I don't understand how to get the fix. I've looked at the web site for the WTP 3.9.5 release and it gives the same update site. There seems to be an indication that I need to get 3.9.4 first but I don't understand how to do that either.

Any help is much appreciated!

Is there some other way to apply the fix? Or what am I doing wrong?
Re: Tomcat 9.0.7 from Oxygen 3A [message #1786636 is a reply to message #1786516] Tue, 08 May 2018 20:42 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3254
Registered: July 2009
Senior Member

When you put http://download.eclipse.org/webtools/repository/oxygen/ into the Available Software Sites list, was the general Oxygen site still there and enabled? It needs to be.

You also didn't mention whether Tomcat was not launching after applying the update you did receive. 3.9.5 replaces 3.9.4, and it's not anything that requires starting from 3.9.4 to apply properly.


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Tomcat 9.0.7 from Oxygen 3A [message #1786713 is a reply to message #1786636] Wed, 09 May 2018 17:57 Go to previous messageGo to next message
Jeff Spelman is currently offline Jeff SpelmanFriend
Messages: 4
Registered: May 2018
Junior Member
Nitin - Thank you for the reply. The general Oxygen site was still there. Tomcat did not start after applying the update I initially received.

Unfortunately I ran out of time to try and figure out this problem. I went to Java 8 and everything is working now.
Re: Tomcat 9.0.7 from Oxygen 3A [message #1786714 is a reply to message #1786636] Wed, 09 May 2018 17:57 Go to previous messageGo to next message
Jeff Spelman is currently offline Jeff SpelmanFriend
Messages: 4
Registered: May 2018
Junior Member
No Message Body

[Updated on: Fri, 11 May 2018 15:33]

Report message to a moderator

Re: Tomcat 9.0.7 from Oxygen 3A [message #1786715 is a reply to message #1786636] Wed, 09 May 2018 17:57 Go to previous message
Jeff Spelman is currently offline Jeff SpelmanFriend
Messages: 4
Registered: May 2018
Junior Member
No Message Body

[Updated on: Fri, 11 May 2018 15:33]

Report message to a moderator

Previous Topic:Change Package Explorer Navigation Shortcut
Next Topic:PKIX Path Building Exception When Updating Eclipse
Goto Forum:
  


Current Time: Wed Sep 26 02:26:14 GMT 2018

Powered by FUDForum. Page generated in 0.01565 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top