Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » Debugger process was unexpectedly terminated with custom Lua 5.1 on Windows 10(Not possible to debug in LDT on Windows 10 with a customer Lua 5.1 build)
Debugger process was unexpectedly terminated with custom Lua 5.1 on Windows 10 [message #1772764] Thu, 14 September 2017 21:46 Go to next message
Pascal Collberg is currently offline Pascal CollbergFriend
Messages: 2
Registered: September 2017
Junior Member
Hi!

I have compiled an official version of Lua (5.1.4) fetched from here:

sourceforge.net/projects/luabinaries/files/5.1.4/Docs%20and%20Sources/lua5_1_4_Sources.zip/download

on a Windows 10 machine using this script:

cl /MD /O2 /c /DLUA_BUILD_AS_DLL *.c

link /DLL /IMPLIB:lua5.1.lib /OUT:lua5.1.dll *.obj

mv lua.obj lua.o

link /OUT:lua.exe lua.o lua5.1.lib /DYNAMICBASE "c:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\lib\x86\legacy_stdio_definitions.lib"


When I add this customer lua exe as an interpreter to my LDT installation and try to debug a very simple script (just a print of hello world) I get the following error:

'Debugger process was unexpectedly terminated'

If I "Enable DBGP logging" I can see these printouts:

CREATE from org.eclipse.ldt.debug.core.internal.LuaDebugTarget
MODEL_SPECIFIC/1 from org.eclipse.dltk.launching.InterpreterConfig
CHANGE from org.eclipse.dltk.launching.process.ScriptRuntimeProcess
CREATE from org.eclipse.dltk.launching.process.ScriptRuntimeProcess
CHANGE from org.eclipse.dltk.launching.process.ScriptRuntimeProcess
CHANGE from org.eclipse.dltk.launching.process.ScriptRuntimeProcess
TERMINATE from org.eclipse.dltk.launching.process.ScriptRuntimeProcess
CHANGE from org.eclipse.dltk.launching.process.ScriptRuntimeProcess
TERMINATE from org.eclipse.ldt.debug.core.internal.LuaDebugTarget


I used to do exactly the same on Windows 7 before I upgraded to Windows 10 and then it all worked fine.

Does anybody know what might be wrong?

Thanks!
/Pascal
Re: Debugger process was unexpectedly terminated with custom Lua 5.1 on Windows 10 [message #1772845 is a reply to message #1772764] Sun, 17 September 2017 07:39 Go to previous message
Pascal Collberg is currently offline Pascal CollbergFriend
Messages: 2
Registered: September 2017
Junior Member
Hi again,

It turned out that I had not configured my LuaRocks properly.

LDT was missing lua_cpath and lua_path variables to find all required dependencies.
Previous Topic:remote development: csv and other file extensions filter
Next Topic:Running application error
Goto Forum:
  


Current Time: Tue Sep 25 00:51:32 GMT 2018

Powered by FUDForum. Page generated in 0.01812 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top