Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » AUT vm argument value with spaces in maven plugin
AUT vm argument value with spaces in maven plugin [message #1771311] Wed, 23 August 2017 21:27 Go to next message
Alfonso Rios is currently offline Alfonso RiosFriend
Messages: 10
Registered: February 2016
Junior Member
Using the rcptt maven plugin how can I include a vm argument value that contains spaces like the example below. The -Dmyproperty has the value C:\Program Files\ABC but when I run it in jenkins the value only is taken as C:\Program.

I have tried to put it in double quotes like this: "C:\Program Files\ABC" but it does not work.

<plugin>
<groupId>org.eclipse.rcptt</groupId>
<artifactId>rcptt-maven-plugin</artifactId>
<configuration>
<aut>
<explicit>${myAUT}</explicit>

<args>
<arg>-product</arg>
<arg>${targetProduct}</arg>
</args>

<vmArgs>
<vmArg>-Dmyproperty=C:\Program Files\ABC</vmArg>
</vmArgs>
Re: AUT vm argument value with spaces in maven plugin [message #1771664 is a reply to message #1771311] Tue, 29 August 2017 10:13 Go to previous messageGo to next message
Viktoria Dlugopolskaya is currently offline Viktoria DlugopolskayaFriend
Messages: 124
Registered: March 2017
Senior Member
Hi Alfonso,

I cannot reproduce your problem. Could you attach a console log?
RCPTT runner writes passed vm args to the log. They can be found on the line '...target/aut-ws-0: AUT VM arguments:...'.

Regards,
Viktoria
Re: AUT vm argument value with spaces in maven plugin [message #1771697 is a reply to message #1771664] Tue, 29 August 2017 15:51 Go to previous message
Alfonso Rios is currently offline Alfonso RiosFriend
Messages: 10
Registered: February 2016
Junior Member
Hi Viktoria,

I have rerun my scenario and now I can see that the property value for cobol.runtime was enclosed by double quotes automatically I think because the space in the propery value. I do not know why It did not work this way before. Now it is working as expected, thanks anyway for looking into this problem, I really appreciate it.

[INFO] c:\remotejenkinsslave\workspace\Aqua_v3.1_Integration_Testing_Windows_IM\com.ibm.zeus.test.master.im\target\aut-ws-0: AUT arguments: -product com.ibm.pdp.rpp.product.ide -os ${target.os} -arch ${target.arch} -consoleLog
[INFO] c:\remotejenkinsslave\workspace\Aqua_v3.1_Integration_Testing_Windows_IM\com.ibm.zeus.test.master.im\target\aut-ws-0: AUT VM arguments: -Djava.util.Arrays.useLegacyMergeSort=true -Dorg.eclipse.swt.accessibility.UseIA2=false -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Xquickstart -Xms40m -Xmx1024m -Xmnx64m -Xgcpolicy:gencon -Xscmx96m -Xshareclasses:name=IBMSDP_%u -Xnolinenumbers -Xcompressedrefs -Dcom.ibm.cics.explorer.zos.connections.enable=true -Djavax.xml.accessExternalSchema=platform,file -DpropertiesFile=c:\remotejenkinsslave\workspace\Aqua_v3.1_Integration_Testing_Windows_IM\com.ibm.zeus.test.master.im/target/projects/com.ibm.etools.idz.com.ibm.etools.idz.base.test.ui/Global/CTFMVS08-ITEST10_v14.properties -Dfmbasedir=c:\remotejenkinsslave\workspace\Aqua_v3.1_Integration_Testing_Windows_IM\com.ibm.zeus.test.master.im/target/projects/fm.fm.base.test.ui/ -DuseDummy=true "-Dcobol.runtime=C:\Program Files\IBM\zOS_Explorer\rpp"
Previous Topic:RCPTT Test Runner not finishing its job
Next Topic:RCPTT command has been recorded but this command not executed if script running
Goto Forum:
  


Current Time: Fri Oct 19 04:16:18 GMT 2018

Powered by FUDForum. Page generated in 0.07464 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top