Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse RedDeer » Is there an example of using Red Deer with a (non Eclipse) E4 Application?
Is there an example of using Red Deer with a (non Eclipse) E4 Application? [message #1769872] Fri, 04 August 2017 10:45 Go to next message
Christoph Läubrich is currently offline Christoph LäubrichFriend
Messages: 9
Registered: September 2011
Junior Member
I have already read https://github.com/eclipse/reddeer/wiki/Getting-Started
(and some other e.g. https://dzone.com/articles/red-deer-recorder) but all seem to target for an Eclipse-Install, is there an example of using RedDeer with a (prebuild) E4 application instead of using the current Eclipse Workspace as a basis?

Especially the Recorder would be usefull it starts if I choose Eclipse as the Apllication to record but if I choose my own product it simply do not show up. Do I need to first install SWTBot like described here (https://wiki.eclipse.org/SWTBot/Generator#I_want_to_record_on_an_existing_application.2C_without_IDE) and RedDeer (what features are required for this?) or do I need to choose a completly different aproach?
Re: Is there an example of using Red Deer with a (non Eclipse) E4 Application? [message #1771636 is a reply to message #1769872] Tue, 29 August 2017 05:10 Go to previous message
Christoph Läubrich is currently offline Christoph LäubrichFriend
Messages: 9
Registered: September 2011
Junior Member
I got it running now to record events, but sadly I encountered the following Exception now:
Caused by: java.lang.IllegalStateException: Workbench has not been created yet.
	at org.eclipse.ui.PlatformUI.getWorkbench(PlatformUI.java:93)
	at org.jboss.reddeer.core.handler.WorkbenchPartHandler$4.run(WorkbenchPartHandler.java:118)
	at org.jboss.reddeer.core.handler.WorkbenchPartHandler$4.run(WorkbenchPartHandler.java:1)
	at org.jboss.reddeer.core.util.Display$ErrorHandlingRunnable.run(Display.java:163)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:161)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
According to this https://www.eclipse.org/forums/index.php/t/490073/ it seems for some reason eclipse 3.x API is called, does Reddeer (Version 1.2.1) not support E4 or is something missing in my setup?
Goto Forum:
  


Current Time: Mon Jun 18 23:19:12 GMT 2018

Powered by FUDForum. Page generated in 0.01509 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top