Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » RCPTT Testing tool startup failure (Also related to NAT table and Graphical editor capability)
RCPTT Testing tool startup failure [message #1768507] Wed, 19 July 2017 14:56 Go to next message
keith davis is currently offline keith davisFriend
Messages: 1
Registered: July 2017
Junior Member
I've been having issues at the moment with RCPTT 2.0.1 with regards to graphical editors and NAT-Tables. Our team has supported NAT-tables for the last few years and we recently ported over to RCPTT 2.0.1 from RFT.

We've dealt with it since, but in the last couple of days it has come to my attention that the RCPT tool that we possess does not support graphical editors (or Triquetrum editor). The tool would have the capability of connecting two components together with a link in the drawing tool. However; once the test is replayed, it is not possible.

In an attempt to fix the two problems above; we tried to upgrade to version 2.2.0 of RCPTT. We have now run into the roadblock that, upon initialization, the tool stalls inside of the loading bar. It states that it is loading the plugin "org.eclipse.jgit".

Does anyone have any idea how to fix this issue in order to get the tool up and running?
Re: RCPTT Testing tool startup failure [message #1768935 is a reply to message #1768507] Tue, 25 July 2017 06:20 Go to previous messageGo to next message
Viktoria Dlugopolskaya is currently offline Viktoria DlugopolskayaFriend
Messages: 109
Registered: March 2017
Senior Member
Hi Keith,

Which application hangs? RCPTT IDE, your AUT or Eclipse with RCPTT installed as plugin into it?
Try to start up the tool with the new workspace, will it work?
Could you provide console log of the app when it hangs?

Regards,
Viktoria
Re: RCPTT Testing tool startup failure [message #1777117 is a reply to message #1768935] Fri, 24 November 2017 16:36 Go to previous message
keith davis is currently offline keith davisFriend
Messages: 5
Registered: October 2017
Junior Member
Hi Viktoria,

Thanks for your response, I've only gotten round to testing this now today. I've downloaded the nightly build, added the launcher.GTK_version line to both the RCPTT.ini and AUT.ini. I've validated the bug fix as per your instructions.

However after running a test case; the tool still seems to freeze once it attempts to operate on the graphical editing framework - the same as it did beforehand.

The interesting thing is that this issue does not arise on RH6, but has been found on RH5 and RH7 when using the testrunners and RH7 when using the RCPTT IDE (i did not have a RH5 machine, myself, to test on the RCPTT IDE).

Any further suggestions would be greatly appreciated.

Cheers,
Keith
Previous Topic:RCP Tester not working
Next Topic:Setting value of checkbox editor in wizard table doesn't work
Goto Forum:
  


Current Time: Thu Jun 21 20:33:57 GMT 2018

Powered by FUDForum. Page generated in 0.01448 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top