Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » Compile error from Tycho plugin
Compile error from Tycho plugin [message #1766343] Tue, 20 June 2017 12:11 Go to next message
Roberto Palermo is currently offline Roberto PalermoFriend
Messages: 9
Registered: March 2017
Junior Member
Dear all,
trying to compile Eclipse Kura (last stable version) using the build-all.sh script, I receive the following error on the project org.eclipse.kura.api:

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 20.156 s
[INFO] Finished at: 2017-06-19T17:24:29+02:00
[INFO] Final Memory: 41M/471M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.eclipse.tycho:tycho-packaging-plugin:0.26.0:package-plugin (default-package-plugin) on project org.eclipse.kura.api: Execution default-package-plugin of goal org.eclipse.tycho:tycho-packaging-plugin:0.26.0:package-plugin failed: One of setGitDir or setWorkTree must be called. -> [Help 1]


Same error appears using different machines.
How can I solve?

Thank you in advance for your help,
best regards
Re: Compile error from Tycho plugin [message #1766352 is a reply to message #1766343] Tue, 20 June 2017 12:37 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 279
Registered: July 2015
Location: Italy
Senior Member
Hi,
which version of maven are you using?

Thanks.
Best regards,
Matteo
Re: Compile error from Tycho plugin [message #1766358 is a reply to message #1766352] Tue, 20 June 2017 14:03 Go to previous messageGo to next message
Roberto Palermo is currently offline Roberto PalermoFriend
Messages: 9
Registered: March 2017
Junior Member
Hi Matteo,
thank you for your quick reply.
I'm using Maven 3.5.0, I also tried with Maven 3.3.9.

Thank you very much,
Best regards
Roberto
Re: Compile error from Tycho plugin [message #1766462 is a reply to message #1766358] Wed, 21 June 2017 16:08 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 279
Registered: July 2015
Location: Italy
Senior Member
Hi,
I've tested the build of the KURA_3.0.0_RELEASE branch and I've also tested to build the current develop.
Everything seems to be working.
Also, the CI builds with Travis and Hudson seem to be able to build properly.
Could you please post a larger snippet of your log?
Maybe there is something more meaningful there that can allow to understand what goes wrong.

Best regards,
Matteo
Re: Compile error from Tycho plugin [message #1771236 is a reply to message #1766462] Wed, 23 August 2017 08:20 Go to previous messageGo to next message
Marko Erker is currently offline Marko ErkerFriend
Messages: 1
Registered: August 2017
Junior Member
This error appears when one tries to compile Kura from code that was downloaded from Github as a zip instead of being checked out through git.
So, use
git clone https://github.com/eclipse/kura.git
instead.

Why this happens?
Because Kura uses tycho-packaging-plugin to generate source references. And when the code is not checked out from git, the plugin fails. So an option is also to update kura/pom.xml and update
                    <sourceReferences>
                        <generate>true</generate>
                    </sourceReferences>

to
                    <sourceReferences>
                        <generate>false</generate>
                    </sourceReferences>

This way you will lose the reference in the MANIFEST.MF in the jar, but Kura will build.
Re: Compile error from Tycho plugin [message #1771602 is a reply to message #1771236] Mon, 28 August 2017 13:57 Go to previous message
Roberto Palermo is currently offline Roberto PalermoFriend
Messages: 9
Registered: March 2017
Junior Member
Thank you very much, I'll try!
Previous Topic:Kura on Raspberry Pi setup
Next Topic:Kura PWM?
Goto Forum:
  


Current Time: Mon Nov 19 07:23:52 GMT 2018

Powered by FUDForum. Page generated in 0.01806 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top