Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Lost Workspace(Help, I've lost an entire workspace)
Lost Workspace [message #1766260] Mon, 19 June 2017 15:01 Go to next message
Rien Boydens is currently offline Rien BoydensFriend
Messages: 2
Registered: June 2017
Junior Member
I've lost an entire workspace.
Eclipse was open in that workspace and suddenly it freaks out and I get an error that the workspace can't be synchronized with the filesystem.
When I check the filesystem I see that almost everything is gone.
The only things remaining are the folders of the files that were open and the .metadata folder with the .plugins folder and the .log file
Is there anyway I can recover all my files because I tried almost everything to recover it but I can't find it.

I've included the .log file if that might be of help.
  • Attachment: .log
    (Size: 20.80KB, Downloaded 141 times)
Re: Lost Workspace [message #1766280 is a reply to message #1766260] Mon, 19 June 2017 19:56 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31163
Registered: July 2009
Senior Member
You can import the projects into a new workspace using File -> Import -> General -> Existing Projects into Workspace.
Re: Lost Workspace [message #1766294 is a reply to message #1766280] Tue, 20 June 2017 05:05 Go to previous messageGo to next message
Rien Boydens is currently offline Rien BoydensFriend
Messages: 2
Registered: June 2017
Junior Member
The thing is that all my projects are also gone. Almost everything on my usb was gone. I tried to recover it using some recovery software but it didn't work.

But you don't have to help anymore, there was only one project I really would like to keep and I can easily recreate it. So I already gave up on trying to recover it and just deleted everything that was left, it wasn't of any use anymore.
Thanks anyway.
Re: Lost Workspace [message #1819560 is a reply to message #1766260] Fri, 17 January 2020 10:48 Go to previous messageGo to next message
Dave Hitchman is currently offline Dave HitchmanFriend
Messages: 9
Registered: August 2018
Junior Member
Happening now at least once a day to me.
It has been stable until this year, now its crap. First sign of trouble is that keys like delete stop working. Then you close eclipse and when you reopen it doesnt know the url for any of the open windows.

What has been done to eclipse or what was always wrong with it thats now showing up?

To be honest if this problem has no answer or persists any more I will throw eclipse off my machine and find an IDE that isnt a java driven fragile crock
Re: Lost Workspace [message #1819565 is a reply to message #1819560] Fri, 17 January 2020 11:28 Go to previous message
Dave Hitchman is currently offline Dave HitchmanFriend
Messages: 9
Registered: August 2018
Junior Member
Having screwed up my workspace for the 5th time I get back to the why when I have included the headers and the paths to the libraries are correct has it decided today that it can no longer link to the standard functions it linked to an hour ago. This has to be the most useless IDE I have ever come across
Previous Topic:Blank window in IDE: how to get rid of it
Next Topic:What controls the syntax analyser?
Goto Forum:
  


Current Time: Fri Jun 05 22:45:16 GMT 2020

Powered by FUDForum. Page generated in 0.05428 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top