Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » AUT Start Error(AUT fails to start with jubula rcp uninstalled error)
AUT Start Error [message #1765641] Tue, 13 June 2017 01:12 Go to next message
Bruce Edgerton is currently offline Bruce EdgertonFriend
Messages: 25
Registered: May 2017
Junior Member
I am trying to start my AUT from the Jubula standalone IDE but it fails with the exception below. I have followed all of the instructions for starting an AUT, ie. Connect to the AUT agent, add the jubula start command to the ini file, copy rcp to plugins. Any help would be appreciated.

Here is my config file:

eclipse.application=calypso.application
osgi.bundles.defaultStartLevel=4
eclipse.product=calypso.product
osgi.splashPath=platform:/base/plugins/calypso
osgi.bundles=org.eclipse.equinox.simpleconfigurator@1:start,org.eclipse.jubula.rc.rcp@start
org.eclipse.equinox.simpleconfigurator.configUrl=file:org.eclipse.equinox.simpleconfigurator/bundles.info

And here is the error log:

!ENTRY org.eclipse.osgi 4 0 2017-06-13 10:56:21.471
!MESSAGE Startup error
!STACK 1
java.lang.IllegalArgumentException: Bundle "update@plugins/org.eclipse.jubula.rc.rcp_5.0.0.201701111513.jar" has been uninstalled
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getStartLevel(AbstractBundle.java:1531)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.getBundleStartLevel(StartLevelManager.java:322)
at org.eclipse.core.runtime.adaptor.EclipseStarter.ensureBundlesActive(EclipseStarter.java:421)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:293)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
Re: AUT Start Error [message #1765919 is a reply to message #1765641] Wed, 14 June 2017 13:24 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 115
Registered: March 2012
Senior Member
On the first look the configurations seems to be good.
But i need more information to get a better guess of what might not work.

Which version of eclipse is the RCP application you are using?
Is there more information in the log Files in your Home directory ".jubula/logs"?

with regards
Marvin Mueller
Re: AUT Start Error [message #1766140 is a reply to message #1765919] Fri, 16 June 2017 11:57 Go to previous messageGo to next message
Milos Hroudny is currently offline Milos HroudnyFriend
Messages: 17
Registered: June 2017
Junior Member
My RCP application works fine and contains in config.ini:
...
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.1.0.v20131217-1203.jar@1\:start
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
...
In bundles.info of the AUT has to be added a line:
org.eclipse.jubula.rc.rcp,5.0.0.201705050842,plugins/org.eclipse.jubula.rc.rcp_5.0.0.201705050842.jar,4,true

and the file
org.eclipse.jubula.rc.rcp_5.0.0.201705050842.jar
stored in the AUT plugins

Best Regards
Milos Hroudny
Re: AUT Start Error [message #1766516 is a reply to message #1766140] Thu, 22 June 2017 13:58 Go to previous message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 115
Registered: March 2012
Senior Member

Which version of eclipse is the RCP application you are using?
Is there more information in the log Files in your Home directory ".jubula/logs"? (e.g. the client.log or the rc_rcp.log)

with regards
Marvin Mueller
Previous Topic:check for nested Property
Next Topic:Jubula & Eclipse BPMN2 Modeler
Goto Forum:
  


Current Time: Wed Sep 26 06:26:28 GMT 2018

Powered by FUDForum. Page generated in 0.02003 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top