Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Authentication/Transport Error(Login Window does not take my credentials)
Authentication/Transport Error [message #1752719] Thu, 26 January 2017 13:04 Go to next message
Max Schwund is currently offline Max SchwundFriend
Messages: 10
Registered: January 2017
Junior Member
Hey guys,

I have some trouble to clone my Repository. The Repository is running on Bitbucket if neseccary.

I tried to clone it via Egit with https. But when i type in my credentials and URI of the Repository and click next... Eclipse asks me again for my credentials... It asks me 3 Times for my credentials and then throws an exception. My Username and Password ist correct.

I guess Eclipse is not let me connect to the server.
Proxys Working fine (Marketplace is working).

I am also able to clone this repository besides Eclipse (Git bash)


EDIT: Neon.2, Windows 7 64 Bit...

Greetings Max

Error Message:

j
ava.lang.Exception: org.eclipse.jgit.api.errors.TransportException: https://mschwund@stash.Path.to/my/repo.git: not authorized
  at org.eclipse.oomph.setup.git.impl.GitCloneTaskImpl.perform(GitCloneTaskImpl.java:882)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3305)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3248)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4469)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4463)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4461)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3239)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3214)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3114)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:556)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:682)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

[Updated on: Thu, 26 January 2017 15:06]

Report message to a moderator

Re: Authentication/Transport Error [message #1752755 is a reply to message #1752719] Thu, 26 January 2017 21:25 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1178
Registered: July 2009
Senior Member
Which EGit version are you using ?
Does it work if you provide credentials on the first wizard page ?
Re: Authentication/Transport Error [message #1752770 is a reply to message #1752755] Fri, 27 January 2017 07:01 Go to previous messageGo to next message
Max Schwund is currently offline Max SchwundFriend
Messages: 10
Registered: January 2017
Junior Member
Eclipse Git Team Provider 4.4.1.201607150455-r org.eclipse.egit.feature.group Eclipse EGit

No... Eclipse still asks me for my credentials.
Re: Authentication/Transport Error [message #1752958 is a reply to message #1752770] Tue, 31 January 2017 10:27 Go to previous messageGo to next message
Max Schwund is currently offline Max SchwundFriend
Messages: 10
Registered: January 2017
Junior Member
Ok now the Problem is this:

org.eclipse.jgit.api.errors.TransportException: https://mschwund@XXX.XXX.XXX/scm/Test/testprof.git: cannot open git-upload-pack
	at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:221)
	at org.eclipse.jgit.api.LsRemoteCommand.call(LsRemoteCommand.java:159)
	at org.eclipse.egit.core.op.ListRemoteOperation.run(ListRemoteOperation.java:100)
	at org.eclipse.egit.ui.internal.clone.SourceBranchPage$8.run(SourceBranchPage.java:341)
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)
Caused by: org.eclipse.jgit.errors.TransportException: https://mschwund@XXX.XXX.XXX/scm/Test/testprof.git: cannot open git-upload-pack
	at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:510)
	at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:288)
	at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:198)
	... 4 more

[Updated on: Tue, 31 January 2017 12:35]

Report message to a moderator

Re: Authentication/Transport Error [message #1826349 is a reply to message #1752719] Thu, 23 April 2020 20:27 Go to previous messageGo to next message
Charles Herrick is currently offline Charles HerrickFriend
Messages: 17
Registered: July 2016
Location: Jeddo, TX
Junior Member
Did you ever get this to work. I have an issue very close to this. Egit :: clone repository takes my credentials and immediately throws the Transport Error (3 possible probs, url, sslVerify, etc). Git BASH clone works flawlessly. Any ideas on why Egit is being difficult?
Note: I do not have ssh keys set up.
Windows 10, Eclipse 4.4.2
Egit 4.9.2


--
Charles Herrick
[e:] charles.n.herrick@gmail.com
[m:] (512) 289-0926
Re: Authentication/Transport Error [message #1826373 is a reply to message #1826349] Fri, 24 April 2020 07:22 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1178
Registered: July 2009
Senior Member
You are using very ancient Eclipse and EGit versions. We are not fixing such old versions.
You should upgrade both to a recent release. Latest Eclipse release is 2020-03 and EGit 5.7.0 [1],
you can also try EGit nightly build [2] which is usually working fine and has a couple more fixes.

[1] https://download.eclipse.org/egit/updates
[2] https://download.eclipse.org/egit/updates-nightly
Re: Authentication/Transport Error [message #1826406 is a reply to message #1826373] Fri, 24 April 2020 13:15 Go to previous messageGo to next message
Charles Herrick is currently offline Charles HerrickFriend
Messages: 17
Registered: July 2016
Location: Jeddo, TX
Junior Member
Thanks very much.
I'm limited by the fact that I'm in IBM ODM Rule Designer, the Eclipse built for BRMS business rules. Current version is 8.10.x but my client is confined to 8.9.x, which is a fairly recent version of Rule Designer (I realize not of Eclipse).

Trying to pull in a later version of Egit - using both of your links, most recently the most recent nightly builds, the installation balks and wants to install 4.9.20171215...

Is this because the update site does not like my "old" version of Eclipse?
How does the update know not to use the more recent version of Egit, and how does it choose which version to install instead?


--
Charles Herrick
[e:] charles.n.herrick@gmail.com
[m:] (512) 289-0926
Re: Authentication/Transport Error [message #1826408 is a reply to message #1826406] Fri, 24 April 2020 13:26 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 374
Registered: August 2016
Senior Member
You also reported this problem at https://www.eclipse.org/forums/index.php/t/1103487/ . Would be good if we could discuss this in one place.

That said, the latest EGit that will install in an Eclipse 4.4. is EGit 5.0.3, available at the update site https://download.eclipse.org/egit/updates-5.0.3 . See https://wiki.eclipse.org/EGit/FAQ#What_versions_of_Eclipse_does_EGit_target.3F .
Re: Authentication/Transport Error [message #1826410 is a reply to message #1826408] Fri, 24 April 2020 13:44 Go to previous message
Charles Herrick is currently offline Charles HerrickFriend
Messages: 17
Registered: July 2016
Location: Jeddo, TX
Junior Member
Thanks for your great help. I agree, I should not have redundant threads. Please forgive.
Let's use the other thread please:
https://www.eclipse.org/forums/index.php/t/1103487/

I will go there now.


--
Charles Herrick
[e:] charles.n.herrick@gmail.com
[m:] (512) 289-0926
Previous Topic:eGIT is throwing NullPointerException
Next Topic:After upgrade to 2020-03, egit sees unstaged changes even after replace with HEAD
Goto Forum:
  


Current Time: Tue Jun 22 21:37:34 GMT 2021

Powered by FUDForum. Page generated in 0.02203 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top