Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Authentication/Transport Error(Login Window does not take my credentials)
Authentication/Transport Error [message #1752719] Thu, 26 January 2017 13:04 Go to next message
Max Schwund is currently offline Max SchwundFriend
Messages: 10
Registered: January 2017
Junior Member
Hey guys,

I have some trouble to clone my Repository. The Repository is running on Bitbucket if neseccary.

I tried to clone it via Egit with https. But when i type in my credentials and URI of the Repository and click next... Eclipse asks me again for my credentials... It asks me 3 Times for my credentials and then throws an exception. My Username and Password ist correct.

I guess Eclipse is not let me connect to the server.
Proxys Working fine (Marketplace is working).

I am also able to clone this repository besides Eclipse (Git bash)


EDIT: Neon.2, Windows 7 64 Bit...

Greetings Max

Error Message:

j
ava.lang.Exception: org.eclipse.jgit.api.errors.TransportException: https://mschwund@stash.Path.to/my/repo.git: not authorized
  at org.eclipse.oomph.setup.git.impl.GitCloneTaskImpl.perform(GitCloneTaskImpl.java:882)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3305)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3248)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4469)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4463)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4461)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3239)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3214)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3114)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:556)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:682)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

[Updated on: Thu, 26 January 2017 15:06]

Report message to a moderator

Re: Authentication/Transport Error [message #1752755 is a reply to message #1752719] Thu, 26 January 2017 21:25 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 922
Registered: July 2009
Senior Member
Which EGit version are you using ?
Does it work if you provide credentials on the first wizard page ?
Re: Authentication/Transport Error [message #1752770 is a reply to message #1752755] Fri, 27 January 2017 07:01 Go to previous messageGo to next message
Max Schwund is currently offline Max SchwundFriend
Messages: 10
Registered: January 2017
Junior Member
Eclipse Git Team Provider 4.4.1.201607150455-r org.eclipse.egit.feature.group Eclipse EGit

No... Eclipse still asks me for my credentials.
Re: Authentication/Transport Error [message #1752958 is a reply to message #1752770] Tue, 31 January 2017 10:27 Go to previous message
Max Schwund is currently offline Max SchwundFriend
Messages: 10
Registered: January 2017
Junior Member
Ok now the Problem is this:

org.eclipse.jgit.api.errors.TransportException: https://mschwund@XXX.XXX.XXX/scm/Test/testprof.git: cannot open git-upload-pack
	at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:221)
	at org.eclipse.jgit.api.LsRemoteCommand.call(LsRemoteCommand.java:159)
	at org.eclipse.egit.core.op.ListRemoteOperation.run(ListRemoteOperation.java:100)
	at org.eclipse.egit.ui.internal.clone.SourceBranchPage$8.run(SourceBranchPage.java:341)
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)
Caused by: org.eclipse.jgit.errors.TransportException: https://mschwund@XXX.XXX.XXX/scm/Test/testprof.git: cannot open git-upload-pack
	at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:510)
	at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:288)
	at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:198)
	... 4 more

[Updated on: Tue, 31 January 2017 12:35]

Report message to a moderator

Previous Topic:contents of ~/.gitignore not used
Next Topic:Advanced history filter
Goto Forum:
  


Current Time: Sat May 27 17:39:03 GMT 2017

Powered by FUDForum. Page generated in 0.05320 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software