Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Style customization not working
Style customization not working [message #1752271] Fri, 20 January 2017 13:32 Go to next message
Wilbert Alberts is currently offline Wilbert AlbertsFriend
Messages: 186
Registered: June 2010
Senior Member
Hi,

I created a vsp consisting of two layers. In the second layer I added a style customization that adds/enables an icon for an edge.

When I select the second layer, no icons are displayed for existing edges. However, when I close the diagram and reopen it, the icons suddenly appear. Similar, when I deselect the second layer, the icons remain and only disappear once the diagram is closed and reopened.

I must admit that I'm using Sirius 3.1.4 on Eclipse Mars so it might very well be possible that this is a bug that has already been fixed (if it is a bug at all).

So, do I need to file a bug report?

Greetings,
Wilbert.
Re: Style customization not working [message #1752274 is a reply to message #1752271] Fri, 20 January 2017 14:00 Go to previous messageGo to next message
Maxime Porhel is currently offline Maxime PorhelFriend
Messages: 463
Registered: July 2009
Location: Nantes, France
Senior Member
Hi Wilbert,

This looks like a bug (icon update fails when the style is changed but initialization is ok when you reopen the diagram).

Could you file a bug report ?

Regards;

Maxime
Re: Style customization not working [message #1805887 is a reply to message #1752274] Fri, 26 April 2019 15:19 Go to previous message
Tjalling Ran is currently offline Tjalling RanFriend
Messages: 4
Registered: February 2019
Junior Member
Hi Maxime and Wilbert,

This issue is still present in Sirius 6.1.0. I filed a bug report for it in February (here).
At the moment, the bug is marked as unconfirmed and hasn't been assigned to anyone.

Update: found Wilbert's original bug report (here), which is still open. Marked my bug report as duplicate.

Regards,
Tjalling

[Updated on: Fri, 26 April 2019 15:31]

Report message to a moderator

Previous Topic:Loading Resource file
Next Topic:Change context before navigation
Goto Forum:
  


Current Time: Tue Oct 22 22:11:19 GMT 2019

Powered by FUDForum. Page generated in 0.02106 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top