Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Using 1.6 jdk in Neon not supported?(Using 1.6 jdk in Neon not supported?)
icon9.gif  Using 1.6 jdk in Neon not supported? [message #1750951] Mon, 02 January 2017 16:52 Go to next message
Ryan Brown is currently offline Ryan BrownFriend
Messages: 4
Registered: January 2017
Junior Member
I just started on a project that targets the 1.6 jre. I have set-up the proper execution environments and ant build tragets. However, when I try to run my ant dist target I get the following error.

eclipse.buildId=4.6.1.M20160907-1200
java.version=1.8.0_111
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86_64

org.eclipse.ant.launching
Error
Mon Jan 02 09:39:47 MST 2017
JRE version less than 1.7 is not supported. 


Is this indicating that neon cannot actually build/run jre 1.6 applications? I feel like it is much more likely that I am missing some configuration option. This will build find from the command line for me.
Re: Using 1.6 jdk in Neon not supported? [message #1750988 is a reply to message #1750951] Tue, 03 January 2017 13:55 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
We'll need some more detail to help; the above looks like you are trying to launch Eclipse itself using a 1.6 JVM. Is that your intention?
All recent versions of Eclipse can be used to develop applications that target older JVMs, that's not a problem. Back up and describe in more detail what you are doing.
Re: Using 1.6 jdk in Neon not supported? [message #1751010 is a reply to message #1750988] Tue, 03 January 2017 16:19 Go to previous messageGo to next message
Ryan Brown is currently offline Ryan BrownFriend
Messages: 4
Registered: January 2017
Junior Member
Thanks for the reply. I am actually just trying to run an ant dist target when I get that error.

Re: Using 1.6 jdk in Neon not supported? [message #1751014 is a reply to message #1751010] Tue, 03 January 2017 16:30 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
The Ant run configuration is probably using the project's JRE by default. You can edit the run configuration and change the JRE that it uses to execute. See http://help.eclipse.org/neon/index.jsp?topic=%2Forg.eclipse.platform.doc.user%2FgettingStarted%2Fqs-84_run_ant.htm&cp=0_1_2_0_2
Re: Using 1.6 jdk in Neon not supported? [message #1751019 is a reply to message #1751014] Tue, 03 January 2017 17:05 Go to previous messageGo to next message
Ryan Brown is currently offline Ryan BrownFriend
Messages: 4
Registered: January 2017
Junior Member
This [attached] is what I see in the run configuration.

index.php/fa/28002/0/

[Updated on: Tue, 03 January 2017 17:08]

Report message to a moderator

Re: Using 1.6 jdk in Neon not supported? [message #1751029 is a reply to message #1751019] Tue, 03 January 2017 18:12 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Well thur's yur problem right thur!
Smile
It's been a long time since I worked with Ant, so I don't know why it's complaining about 1.6, but you can just change that configuration to use 1.7 or 1.8. That is just configuring which JVM is used to execute Ant (which is a Java program, after all) and should not impact your application.
Re: Using 1.6 jdk in Neon not supported? [message #1751032 is a reply to message #1751029] Tue, 03 January 2017 19:17 Go to previous message
Ryan Brown is currently offline Ryan BrownFriend
Messages: 4
Registered: January 2017
Junior Member
Well, that's embarrassing! I was thinking that was the project target. Embarrassed

Thanks for your help!
Previous Topic:Profile id _SELF_ is not registered
Next Topic:How to deploy web service files in Jetty
Goto Forum:
  


Current Time: Thu Jun 27 04:49:51 GMT 2019

Powered by FUDForum. Page generated in 0.03259 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top