Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Lock disappears in Resource->Project Explorer(Lock disappears in Resource->Project Explorer when branching with "Start working in a branch")
icon8.gif  Lock disappears in Resource->Project Explorer [message #1749704] Fri, 09 December 2016 20:53 Go to next message
Robin Panicker is currently offline Robin PanickerFriend
Messages: 1
Registered: December 2016
Junior Member
Hi

I am starting to use SVN in our projects. To start with SVC, Subversive seems very good client for us and we are doing Proof of concept with Subversive.

Currently I am facing a issue with Subversive. After locking a work product in Folder "A" from "Resource->Project Explorer" and then branching it to Folder "B" with "Start working in a branch" option. On doing that the lock made in Folder "A" disappears (also the icon change to different one), even doing "Scan Lock" shown my Work Product in "Folder A" its not locked. But if you look in "SVN Repository Explorer" I can still see the work product locked under my name in Folder one.

After this I broke the lock from "SVN Repository Explorer" then tried to get a lock in SVN "Resource->Project Explorer" but the work product is only getting "Local Lock". But when try to unlock it never gets unlocked.

Is there a reason for this or is it a bug? It will great help if we can get this solved.

Regards
Robin

Re: Lock disappears in Resource->Project Explorer [message #1750844 is a reply to message #1749704] Thu, 29 December 2016 20:07 Go to previous message
Alexander Gurov is currently offline Alexander GurovFriend
Messages: 148
Registered: July 2009
Senior Member
Hi!

It is not an issue, but how SVN works by design. Actually, what is it you're doing?
1) You've locked a file. Resource is locked now.
2) You're branching it now, while setting the option "Start working with branch". When branch is created there is a new file created which, although, have the same ancestry but is a completely different resource. So, obviously it is not locked. And then, the option "Start working with branch" means your working copy will be switched to point to this newly created resource.
3) Now you scan for locks and see none which is correct.

So, if you wish to lock it too - then you'll need to set another lock. On the resource in the branch this time.
Previous Topic:Connector discovery dialog showing too early
Next Topic:Subversive Error
Goto Forum:
  


Current Time: Thu Sep 21 01:43:37 GMT 2017

Powered by FUDForum. Page generated in 0.03553 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software