Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Select Node by TextPath for Tree got error for Mac
Select Node by TextPath for Tree got error for Mac [message #1748986] Wed, 30 November 2016 18:59 Go to next message
Khanh Vu is currently offline Khanh VuFriend
Messages: 24
Registered: June 2016
Junior Member
I have a test case within a test suite that ran successfully on Windows.

When I run the same test case on Mac it failed on SelectNodeByTextPathOnTree method.

The Error Description states: Timeout received before confirming the posted event.

index.php/fa/27744/0/

Does that mean Mac is not supported or do I need some Jubula Mac configuration steps?

Thanks,
Khanh
Re: Select Node by TextPath for Tree got error for Mac [message #1749020 is a reply to message #1748986] Thu, 01 December 2016 08:39 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
Hi Khanh,

we removed the official support for testing on Mac machines a few releases ago. We know that some (most) actions do work on Mac, but there may be problems, most specifically in SWT. If it's reproducible, you can enter a bug for it, but it will probably not be high on the prio list since we don't run tests on Mac anymore.

My advice would be to run most of your tests on Windows / Linus machines - is that possible?

Best regards,
Alex
Re: Select Node by TextPath for Tree got error for Mac [message #1749098 is a reply to message #1749020] Thu, 01 December 2016 19:15 Go to previous message
Khanh Vu is currently offline Khanh VuFriend
Messages: 24
Registered: June 2016
Junior Member
Hi Alex,

If my customers like Mac and will not change for me,
then will I need to do Custom Jubula Extension?

I just need a pointer in the right direction to plan for 2017

Thanks
Khanh
Previous Topic:Can not select Central Test Data for test case in Jubula8.3.1
Next Topic:Jubula failing to launch eclipse(ERROR: ** (installer:6483): WARNING **: Could not open X display)
Goto Forum:
  


Current Time: Mon Sep 24 13:26:41 GMT 2018

Powered by FUDForum. Page generated in 0.01676 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top