Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » JFace » TableViewer hiding columns in MAC(A thick line gets appeneded in MAC )
TableViewer hiding columns in MAC [message #1748426] Wed, 23 November 2016 05:42
Karteek Majety is currently offline Karteek MajetyFriend
Messages: 2
Registered: November 2016
Junior Member
I have a tableviewer for which a table contains 100 columns.
I would like to hide columns as per my requirement.
In one scenario,I would like to see only 1 column ,in an other scenario i would like to see 50 columns .etc.
There is data persisted on each column.
I also have multiple tables but i show only 1 table at a time based on the user selection of the table.

Issue:
To hide the unwanted columns to be shown I am using
column.setWidth(0) for a tablecolumn.
In case of Windows the tablecolumns are getting shown properly but in case of Macintosh OS ,there is a thick line which gets appended at the end after hiding the columns.
The length of this thick blurred line is propotional to the number of columns i hide ..i.e. by setting columns.setWidth(0).


PFA screen shot.

Is there a way where I can eliminate showing of the thick line in MAC?
Am I missing to call any method which is what is causing the issue?
It would be great if someone helps me with this issue.


Thanks



Previous Topic:Resize tree on collapsing and expanding
Next Topic:JFace TableViewer Number of Columns header
Goto Forum:
  


Current Time: Thu Nov 15 03:43:31 GMT 2018

Powered by FUDForum. Page generated in 0.02806 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top