Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » How to enforce checkout with 1.7 working copy format?
icon5.gif  How to enforce checkout with 1.7 working copy format? [message #1747429] Mon, 14 November 2016 15:41 Go to next message
Andrey Loskutov is currently offline Andrey LoskutovFriend
Messages: 80
Registered: July 2009
Member
We've on RHEL7 and this beast provides only Subversion 1.7.x. Subversion 1.8+ will be not available for RHEL due compatibility concerns.

Now we have a problem: we use latest 4.x Subversive plugin with SVNKit 1.8.12 provided by org.polarion.eclipse.team.svn.connector.svnkit18_6.0.1.I20160627-1700.jar connector.

By default this Subversive + SVNKit version pair checkouts the SVN repo with the 1.8 working copy version, so the old 1.7 SVN CLI fails to work with this. If we checkout with 1.7 SVN CLI, Subversion works fine but SVNKit has at least one bug with reverting files, similar with https://issues.tmatesoft.com/issue/SVNKIT-582. This bug seem to be fixed only in SVNKit 1.8.13, so it is not available via Subversive connectors *yet*.

Let assume Subversive connectors will be upgraded to latest SVNKit, so the clients with Eclipse will be happy working with the working copy created by 1.7 SVN CLI. Unfortunately this will not resolve the problem if the SVN repo was checked out with Eclipse - because SVNKit seem to *always* check out with SVN 1.8 working copy format.

Now the actual question: is there a way to *enforce* Subversion to always use 1.7 SVN working copy format on checkout? Is there any Subversive code saying SVNKit to use this or that working copy format on checkout at all? See for example https://issues.tmatesoft.com/issue/SVNKIT-495 for the API I mean. Something we can quickly patch?

P.S.
No, using JavaHL is not an option on our platform (it collides with old xulrunner library using different sqlite version).

P.P.S
Another option would be to use old connector, but it looks like Subversive 4.x requires connectors 6.x which contain SVNKit 1.8. Any possibility to use the old one may be?
Re: How to enforce checkout with 1.7 working copy format? [message #1750837 is a reply to message #1747429] Thu, 29 December 2016 19:32 Go to previous message
Alexander Gurov is currently offline Alexander GurovFriend
Messages: 148
Registered: July 2009
Senior Member
We're using JavaHL-based API when working with SVN Kit. So, in regards to this the functionality you're requesting is not a simple thing to do. What ways there are?
1) We can 'resurrect' SVN Kit 1.7.x based connector, though it is not an advised idea. It is a few times slower than SVN Kit 1.8.x after all.
2) We can extend JavaHL API in SVN Kit connector 1.8.x so that it allows to specify working copy format to be used on checkout.
3) We can completely rework SVN Kit integration in order to use its own API instead of JavaHL, which is not preferred since it will be that much more complex in maintaining.

You're welcome to post your suggestions on Subversive Bugzilla: https://bugs.eclipse.org/bugs/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&classification=Technology&list_id=15509137&order=bug_id&product=Subversive&query_format=advanced
Previous Topic:SVN: Email Sender For Team
Next Topic:Could not acquire the framework manipulator service
Goto Forum:
  


Current Time: Tue Sep 25 09:26:40 GMT 2018

Powered by FUDForum. Page generated in 0.04186 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top