Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » [neon] Login with http works, but not https
[neon] Login with http works, but not https [message #1747213] Thu, 10 November 2016 19:02 Go to next message
Steve Conley is currently offline Steve ConleyFriend
Messages: 11
Registered: November 2016
Junior Member
I am an experienced Eclipse user (10 years+) but I decided to look at Scout for a quick project.

I installed Scout 4.6.1.20161007-1200 to my Ubuntu 16.04.1 with little difficulty, and proceeded to follow the Helloworld example. That worked fine and then I followed the instructions to use https (nio).

This was a new setup and so I followed the Apache setup instructions also. I was trying to replicate a brand new environment.

The two problems I see are that I get "Login failed" message whether I use:

https://localhost:8443/org.eclipse.scout.apps.helloworld.ui.html/
or
http://localhost:8080/org.eclipse.scout.apps.helloworld.ui.html/

when I type the same user/passwords that work for the non-HTTP mode.
(Passwords being in the
helloworld.ui.html.app.dev/src/main/resources/config.properties)

I have scanned and read all the pertinent stuff I could find on the web and this forum and have not found anyone having this problem except one, where he said, oh, I changed to HTTP and it was ok.

Well, that is NOT ok for me as I need the encryption.

I know I must be missing something simple - and I did download the helloworld example and tried it also, with the exact same results.
and
I repeated all the steps over in the scout beginner's documentation to no avail.

Any ideas?

Re: [neon] Login with http works, but not https [message #1747215 is a reply to message #1747213] Thu, 10 November 2016 19:43 Go to previous messageGo to next message
Santo Mota is currently offline Santo MotaFriend
Messages: 62
Registered: July 2013
Member
did you create your personal certified? thats necesary to use HTTPS://

I was facing the same problem and I solved with a right creation of my personal certified.


Hope this help

https://www.eclipse.org/forums/index.php/t/1082065/

[Updated on: Thu, 10 November 2016 19:45]

Report message to a moderator

Re: [neon] Login with http works, but not https [message #1747216 is a reply to message #1747215] Thu, 10 November 2016 19:59 Go to previous messageGo to next message
Steve Conley is currently offline Steve ConleyFriend
Messages: 11
Registered: November 2016
Junior Member
Not sure what you mean "personal certified" ?

Personal Certificate ??

If so, I think so, I followed the directions in the guide and these were my commands:

create key:

$JAVA_HOME/bin/keytool.exe -genkey -keyalg RSA -dname CN=localhost -alias tomcat_localhost -keystore tomcat_localhost.jks -keypass changeit -storepass changeit

Export it:

sudo $JAVA_HOME/bin/keytool -exportcert -alias tomcat_localhost -storepass changeit -keystore tomcat_localhost.jks -file tomcat_localhost.der

Import it:

sudo $JAVA_HOME/bin/keytool -import -alias tomcat_localhost -trustcacerts -storepass changeit -keystore /usr/lib/jvm/java-8-oracle/jre/lib/security/cacerts -file tomcat_localhost.der

Then I restarted Tomcat.

Note that the Tomcat Managers work fine now in HTTPS mode and correctly accept their passwords.

It is just the Scout app that does not work.






Re: [neon] Login with http works, but not https [message #1747218 is a reply to message #1747216] Thu, 10 November 2016 20:44 Go to previous messageGo to next message
Steve Conley is currently offline Steve ConleyFriend
Messages: 11
Registered: November 2016
Junior Member
BTW, I actually have two installs of Java ... the one that Ubuntu did and the Oracle 8 one I did as requested by the setup.

the path to the certificate above is a link to:
/etc/ssl/certs/java/cacerts
as is the OpenJDK8 that was previously installed.

So both "java" should have the certificate, which is show if you list it.

Re: [neon] Login with http works, but not https [message #1747223 is a reply to message #1747218] Thu, 10 November 2016 23:58 Go to previous messageGo to next message
Santo Mota is currently offline Santo MotaFriend
Messages: 62
Registered: July 2013
Member
yeah I was pointing to Certificate.
I'm in windows using tomcat and the command I had been use is

keytool.exe -import -alias tomcat -trustcacerts -storepass changeit -keystore "C:\Program Files\Java\jdk1.8.0_91\jre\lib\security\cacerts" -file C:\apache-tomcat-8.0.38\signed\localhost.crt


as you can see the only different is .crt vs .der

Can you plz look inside the tomcat log to see more detail about the error.

On Windows = C:\apache-tomcat-8.0.38\logs

I didn't ask, are you using tomcat right? if yes, go and check which java's instalation are using tomcat and add the certificate
Re: [neon] Login with http works, but not https [message #1747295 is a reply to message #1747223] Fri, 11 November 2016 17:50 Go to previous messageGo to next message
Steve Conley is currently offline Steve ConleyFriend
Messages: 11
Registered: November 2016
Junior Member
I have applied it as I explained above to the certificate which is actually used by both java's. Although the java used by tomcat 8 is oracle 8 java (as I also explained).

If I give the command:
sudo $JAVA_HOME/bin/keytool -list -storepass changeit -keystore /etc/ssl/certs/java/cacerts

this entry is included in the list:
tomcat_localhost, Nov 9, 2016, trustedCertEntry,
Certificate fingerprint (SHA1): 52:36:88:AC:5C:58:88:F7:F8:D1:EC:D6:F7:BC:87:0C:7A:82:F9:CB

If I go to Firefox and the certificate manager, and look under "servers" there is a permanent entry under localhost
localhost localhost:8443 Permanent (expires) 02/07/2017.
with the same SHA1 Fingerprint.

So I am "pretty sure" my certificate is created and in the right place.

I have included these log excerpts when I attempt to log on.
But at the moment, they don't tell me anything ...

My localhost.access.log has these pertinent entries when I attempted the logon:
127.0.0.1 - - [11/Nov/2016:12:07:55 -0500] "GET /org.eclipse.scout.apps.helloworld.ui.html/ HTTP/1.1" 200 2884
127.0.0.1 - - [11/Nov/2016:12:07:55 -0500] "GET /org.eclipse.scout.apps.helloworld.ui.html/res/scout-login-a0015e54.min.css HTTP/1.1" 304 -
127.0.0.1 - - [11/Nov/2016:12:07:55 -0500] "GET /org.eclipse.scout.apps.helloworld.ui.html/res/login-ce7811fb.min.js HTTP/1.1" 304 -
127.0.0.1 - - [11/Nov/2016:12:07:55 -0500] "GET /org.eclipse.scout.apps.helloworld.ui.html/res/jquery-all-665948bc.min.js HTTP/1.1" 304 -
127.0.0.1 - - [11/Nov/2016:12:07:55 -0500] "GET /org.eclipse.scout.apps.helloworld.ui.html/res/scout-login-f6ccd197.min.js HTTP/1.1" 304 -
127.0.0.1 - - [11/Nov/2016:12:07:55 -0500] "GET /org.eclipse.scout.apps.helloworld.ui.html/res/logo.png HTTP/1.1" 304 -
127.0.0.1 - - [11/Nov/2016:12:08:03 -0500] "POST /org.eclipse.scout.apps.helloworld.server/process HTTP/1.1" 200 370
127.0.0.1 - - [11/Nov/2016:12:08:05 -0500] "POST /org.eclipse.scout.apps.helloworld.ui.html/auth HTTP/1.1" 403 1022
127.0.0.1 - - [11/Nov/2016:12:08:13 -0500] "POST /org.eclipse.scout.apps.helloworld.server/process HTTP/1.1" 200 370


the tomcat8 helloworld.html.ui log shows:

2016-11-11 08:22:40,596 INFO [http-nio-8443-exec-1] org.eclipse.scout.rt.shared.servicetunnel.http.MultiSessionCookieStoreInstaller - Successfully uninstalled java.net.CookieManager@4379b082 (Cookie store: org.eclipse.scout.rt.shared.servicetunnel.http.MultiSessionCookieStore@3856bef4) - MDC[]
2016-11-11 12:06:32,150 INFO [Thread-8] org.eclipse.scout.rt.platform.internal.PlatformImplementor - Headless mode: scout.headless=true, java.awt.headless=true, GraphicsEnvironment.isHeadless()=true - MDC[]
2016-11-11 12:06:32,229 INFO [Thread-8] org.eclipse.scout.rt.platform.inventory.ClassInventory - Finished preparation of jandex class inventory in 73.506160 ms - MDC[]
2016-11-11 12:06:32,596 INFO [Thread-8] org.eclipse.scout.rt.platform.logger.LoggerPlatformListener - registered logger support [org.eclipse.scout.rt.platform.logger.LogbackLoggerSupport] - MDC[]
2016-11-11 12:06:32,599 INFO [Thread-8] org.eclipse.scout.rt.shared.services.common.code.CodeTypeRegistrator - 0 code type classes registered. - MDC[]
2016-11-11 12:06:32,608 INFO [Thread-8] org.eclipse.scout.rt.shared.servicetunnel.RegisterTunnelToServerPlatformListener - Tunnel to server proxies registered. - MDC[]
2016-11-11 12:06:32,610 INFO [Thread-8] org.eclipse.scout.rt.shared.servicetunnel.http.MultiSessionCookieStoreInstaller - Successfully installed java.net.CookieManager@6937e240 (Cookie store: org.eclipse.scout.rt.shared.servicetunnel.http.MultiSessionCookieStore@6369954e) - MDC[]
2016-11-11 12:06:32,683 INFO [Thread-8] org.eclipse.scout.rt.ui.html.res.PrebuildFiles - Pre-building of web resources enabled - MDC[]
2016-11-11 12:06:32,684 INFO [Thread-8] org.eclipse.scout.rt.ui.html.res.PrebuildFiles - Pre-building resource '/index.html' - MDC[]
2016-11-11 12:06:32,684 INFO [Thread-8] org.eclipse.scout.rt.ui.html.UiThemeUtility - UI theme configured in config.properties: application - MDC[]
2016-11-11 12:06:32,714 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@680d3552[requestPath=res/application-all-macro.css, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/helloworld.ui.html-1.0.0-SNAPSHOT.jar!/WebContent/res/application-all-macro.css, fileType=CSS, nodeType=MACRO] theme=application m_minify=true - MDC[]
2016-11-11 12:06:44,530 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@3ba7660f[requestPath=res/jquery-all-macro.js, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/org.eclipse.scout.rt.ui.html-6.1.0.M3.jar!/WebContent/res/jquery-all-macro.js, fileType=JS, nodeType=MACRO] theme=application m_minify=true - MDC[]
2016-11-11 12:06:45,160 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@3b059b6f[requestPath=res/application-all-macro.js, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/helloworld.ui.html-1.0.0-SNAPSHOT.jar!/WebContent/res/application-all-macro.js, fileType=JS, nodeType=MACRO] theme=application m_minify=true - MDC[]
2016-11-11 12:06:55,479 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@2ecafb[requestPath=res/index.js, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/helloworld.ui.html-1.0.0-SNAPSHOT.jar!/WebContent/res/index.js, fileType=JS, nodeType=LIBRARY] theme=application m_minify=true - MDC[]
2016-11-11 12:06:55,481 INFO [Thread-8] org.eclipse.scout.rt.ui.html.res.PrebuildFiles - Pre-building resource '/login.html' - MDC[]
2016-11-11 12:06:55,483 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@527aae44[requestPath=res/scout-login-module.css, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/org.eclipse.scout.rt.ui.html-6.1.0.M3.jar!/scout-login-module.css, fileType=CSS, nodeType=SRC_MODULE] theme=application m_minify=true - MDC[]
2016-11-11 12:06:57,382 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@18d39db3[requestPath=res/scout-login-module.js, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/org.eclipse.scout.rt.ui.html-6.1.0.M3.jar!/scout-login-module.js, fileType=JS, nodeType=SRC_MODULE] theme=application m_minify=true - MDC[]
2016-11-11 12:06:57,673 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@3bc1b0a4[requestPath=res/login.js, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/helloworld.ui.html-1.0.0-SNAPSHOT.jar!/WebContent/res/login.js, fileType=JS, nodeType=LIBRARY] theme=application m_minify=true - MDC[]
2016-11-11 12:06:57,675 INFO [Thread-8] org.eclipse.scout.rt.ui.html.res.PrebuildFiles - Pre-building resource '/logout.html' - MDC[]
2016-11-11 12:06:57,676 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@2e3b835b[requestPath=res/logout.js, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/helloworld.ui.html-1.0.0-SNAPSHOT.jar!/WebContent/res/logout.js, fileType=JS, nodeType=LIBRARY] theme=application m_minify=true - MDC[]
2016-11-11 12:06:57,677 INFO [Thread-8] org.eclipse.scout.rt.ui.html.res.PrebuildFiles - Pre-building resource '/popup-window.html' - MDC[]
2016-11-11 12:06:57,678 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@42b8d585[requestPath=res/scout-module.css, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/org.eclipse.scout.rt.ui.html-6.1.0.M3.jar!/scout-module.css, fileType=CSS, nodeType=SRC_MODULE] theme=application m_minify=true - MDC[]
2016-11-11 12:07:03,833 INFO [Thread-8] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@3a33c31c[requestPath=res/popup-window.js, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/helloworld.ui.html-1.0.0-SNAPSHOT.jar!/WebContent/res/popup-window.js, fileType=JS, nodeType=LIBRARY] theme=application m_minify=true - MDC[]
2016-11-11 12:07:54,736 INFO [http-nio-8443-exec-14] org.eclipse.scout.rt.ui.html.script.ScriptFileBuilder - Building script ScriptSource@4ee74c4f[requestPath=res/scout-login-module.css, url=jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/org.eclipse.scout.rt.ui.html-6.1.0.M3.jar!/scout-login-module.css, fileType=CSS, nodeType=SRC_MODULE] theme=null m_minify=true - MDC[httpUri=/org.eclipse.scout.apps.helloworld.ui.html/login.html, cid=36c58fcc-b323-4afc-ac2e-c1ca6750fcb2]


the catalina log:

SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/var/lib/tomcat8/lib/slf4j-simple-1.7.21.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html/WEB-INF/lib/logback-classic-1.1.3.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [ch.qos.logback.classic.util.ContextSelectorStaticBinder]
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
Nov 11, 2016 12:07:03 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deployment of web application archive /var/lib/tomcat8/webapps/org.eclipse.scout.apps.helloworld.ui.html.war has finished in 33,144 ms

and the helloworld.server log:

2016-11-11 12:06:07,383 INFO [Thread-7] org.eclipse.scout.rt.platform.internal.PlatformImplementor - Headless mode: scout.headless=true, java.awt.headless=true, GraphicsEnvironment.isHeadless()=true - MDC[]
2016-11-11 12:06:07,437 INFO [Thread-7] org.eclipse.scout.rt.platform.inventory.ClassInventory - Finished preparation of jandex class inventory in 44.946565 ms - MDC[]
2016-11-11 12:06:07,648 INFO [Thread-7] org.eclipse.scout.rt.platform.logger.LoggerPlatformListener - registered logger support [org.eclipse.scout.rt.platform.logger.LogbackLoggerSupport] - MDC[]
2016-11-11 12:06:07,651 INFO [Thread-7] org.eclipse.scout.rt.shared.services.common.code.CodeTypeRegistrator - 0 code type classes registered. - MDC[]
2016-11-11 12:06:07,660 INFO [Thread-7] org.eclipse.scout.rt.mom.api.ClusterMom - +++ Using 'NullMomImplementor' for transport 'ClusterMom'. No messages are published and received. To enable this transport, configure a MOM implementor with property 'scout.mom.cluster.implementor'. - MDC[]


Re: [neon] Login with http works, but not https [SOLVED] [message #1747321 is a reply to message #1747213] Sat, 12 November 2016 02:25 Go to previous messageGo to next message
Steve Conley is currently offline Steve ConleyFriend
Messages: 11
Registered: November 2016
Junior Member
Ok, maybe this is a test ... to see if you can proceed to use Scout or not.

If so ... don't look at my answer ...

After tearing out most of my remaining hair ...

If find that the "encoded password" in
helloworld.ui.html.app.war/src/main/resources/config.properties are WRONG ...

I am not sure where they came from, but I had assumed since they were the same user names that someone has computed the hashed passwords and stuck them there ... but no ... or at least they are not right anymore.

Again, this is the Helloworld app created as specified in the user documentation.

If you want the HTTPS version to work ...

Go to file referenced above and correct as follows:
### Login Credentials
scout.auth.credentials=admin:SMzyfNc+AbR7CP50P4XuuhIzzTlOseC8Q64uvO/OaI4=.cO/2viQ7eVf+oP2EKKkbHBMPK6rA2Ptoqp2bVuzOfiVaL+NpnTgEvj0M1O4DyMoYkfa/IrBYduv/JwrxVbe9tg==;scott:BHiTRLuvTQ3rM6oWDZ1NHv0ucBmvs0Q48H3f2TzpSv4=.fp4ar1Fr+LEICwjaWWe3cAExpqW10FjqMjZ77/b5BQNhubVyxrkVzLihcp5TiUM/u9IVubU9GKay6qNlH3U/sw==


For reference:
CORRECT HASHED PASSWORD:
##admin:SMzyfNc+AbR7CP50P4XuuhIzzTlOseC8Q64uvO/OaI4=.cO/2viQ7eVf+oP2EKKkbHBMPK6rA2Ptoqp2bVuzOfiVaL+NpnTgEvj0M1O4DyMoYkfa/IrBYduv/JwrxVbe9tg==
OLD HASHED PASSWORD:
##admin:Q5hBRXwi25yU57UdwZESrw==.cvvCvJLQmtdQSu2VI8Di4f0j/bmf6q3YFOfb3esdRLiXnNnWIl3wHjBI8QSu8K1TfO1lvADmb9aOc1GEEfXztA==;

CORRECT HASHED PASSWORD:
##scott:BHiTRLuvTQ3rM6oWDZ1NHv0ucBmvs0Q48H3f2TzpSv4=.fp4ar1Fr+LEICwjaWWe3cAExpqW10FjqMjZ77/b5BQNhubVyxrkVzLihcp5TiUM/u9IVubU9GKay6qNlH3U/sw==
OLD HASHED PASSWORD:
##scott:xeCQwEtqP6sRfuvAYYUPHw==.6plBwhPiyYurpq8EysozTOrXe/FTw+pA3uyM0jnuPYz0zx16a4yDxVmhHik/YFiWGhTwMnhx4+bSk3rb5IOn+A==

Note they are not the same length even.

At least I can sleep better tonight ...

BTW, Santo had previously posted something about ConfigFileCredentialVerifier being the place they were computed, but I figured he was talking about different users he was defining.

Re: [neon] Login with http works, but not https [SOLVED] [message #1747443 is a reply to message #1747321] Mon, 14 November 2016 17:59 Go to previous messageGo to next message
Matthias Villiger is currently offline Matthias VilligerFriend
Messages: 116
Registered: September 2011
Senior Member
Hi Steve

Thank you for the analysis. You are right, there was a bug in the char[] -> byte[] conversion for the ConfigFileCrendentialVerifyer. It is fixed now with commit 4fa310f94ef6a2fe445d1996f37ec59b44c15c5e. So when you move to the next version the old (original) hashes should work again.

Thank you very much for pointing that out!

Regards
mat
Re: [neon] Login with http works, but not https [SOLVED] [message #1747444 is a reply to message #1747321] Mon, 14 November 2016 18:08 Go to previous messageGo to next message
Matthias Villiger is currently offline Matthias VilligerFriend
Messages: 116
Registered: September 2011
Senior Member
And please note that the current stable version of Scout is 6.0.100.RC4.2.
The builds with the "RC4" qualifier are usually the stable builds.

The version 6.1.x is the current development for Eclipse Oxygen coming in summer 2017. So maybe it is easier to use the stable version. There such issues should be less often Wink

regards
mat
Re: [neon] Login with http works, but not https [SOLVED] [message #1747523 is a reply to message #1747444] Tue, 15 November 2016 16:08 Go to previous messageGo to next message
Matthias Villiger is currently offline Matthias VilligerFriend
Messages: 116
Registered: September 2011
Senior Member
Here you can find the releases: https://wiki.eclipse.org/Scout/Updatesites

regards
mat
Re: [neon] Login with http works, but not https [SOLVED] [message #1747601 is a reply to message #1747523] Wed, 16 November 2016 12:14 Go to previous messageGo to next message
Steve Conley is currently offline Steve ConleyFriend
Messages: 11
Registered: November 2016
Junior Member
Thanks for looking at it. Glad to help.

Seeing you are one of the developers, I must thank you for what seems to be a nice product from my review so far.
It eliminates a lot of drudgery when putting together products that do not have to be "super" customized.

I may stick with the more bleeding version until the next release since I am early in the development of my project using it and somehow I ended up with this version:
eclipse-scout-neon-1a-linux-gtk-x86_64.tar.gz

I cannot figure out exactly where it fits in the /Scout/Updatesites.

It seems to be the version at this site, "Eclipse for Scout Developers" 64bit.
https://www.eclipse.org/downloads/eclipse-packages/

I went to look at my Eclipse "Available Software Sites" and was astounded to find 38 entries!
As this is a new install, I had not actually looked at that since all seemed to be working and I was not installing any other options.

For example, for Neon, there is eclipse.org/releases/neon, releases/neon,/201606221000, releases/neon/201609281000, releases/neon/201610111000.
And for Scout there is eclipse.org/scout/release/6.1/ and eclipse.org/scout/release/6.1/6.1.0
I have no idea how all those version entries got there unless there were already in the install.

Under installation details, the Scout entries are:
Eclipse for Scout Developers 4.6.1.20161007-1200 epp.package.scout Eclipse Packaging Project
Eclipse Scout SDK (Binary only) 6.1.0.M3 org.eclipse.scout.sdk-feature.feature.group Eclipse Scout Project

In the /Scout/Updatesites , that would "seem" to correspond to the 2nd preview line, which is labeled Oxygen M3 to the right.

So three questions if you would be so kind:
1. Is that "long" list of update sites with multiple version of each normal ? (In my 10 years+ Eclipse Java and "C" work, I have never seen that). And should I pare it down?
2. If that is where the version I got came from, why is the version being given out (at https://www.eclipse.org/downloads/eclipse-packages/) not the stable release? (that you may have no idea).
3. So far my issues have seemingly (except for this one) been mostly with the documentation which seems to be rather non-synched (understandably) with the "newer" release I have.
I would not mind helping out with finding the occasional issue while I am putting together my project - but don't want to be so bogged down I can't get my project done,
so would the "Preview" be a good place to be? Especially since I seem to be there already.

Re: [neon] Login with http works, but not https [SOLVED] [message #1747607 is a reply to message #1747601] Wed, 16 November 2016 12:32 Go to previous messageGo to next message
Jeremie Bresson is currently offline Jeremie BressonFriend
Messages: 1243
Registered: October 2011
Senior Member
Steve Conley wrote on Wed, 16 November 2016 13:14
1. Is that "long" list of update sites with multiple version of each normal ? (In my 10 years+ Eclipse Java and "C" work, I have never seen that). And should I pare it down?


I guess this is really standard business for each eclipse project participating in the release train.

* Under "download.eclipse.org/scout/releases" you find our releases.
* Under the release update sites (e.g neon). "eclipse.org/releases/neon" you find a copy that is published as part of the release train (eclipse calls this an "aggregation" update site)

This the same for each project (platform, pde, jdt, emf, ...)

Steve Conley wrote on Wed, 16 November 2016 13:14
2. If that is where the version I got came from, why is the version being given out (at https://www.eclipse.org/downloads/eclipse-packages/) not the stable release? (that you may have no idea).


https://www.eclipse.org/downloads/eclipse-packages/ is the neon release. The last stable version is there.
Here: https://www.eclipse.org/downloads/index-developer.php you find the Oxygen Milestones Release (final Oxygen version will be delivered in June 2017).

* With Neon: Scout is on the 6.0.x Branch.
* With Oxygen: our plan is to contribute the 7.0.0 Version. On the first Oxygen milestones the version is still 6.y.z (where y >= 1).

Steve Conley wrote on Wed, 16 November 2016 13:14
3. So far my issues have seemingly (except for this one) been mostly with the documentation which seems to be rather non-synched (understandably) with the "newer" release I have.
I would not mind helping out with finding the occasional issue while I am putting together my project - but don't want to be so bogged down I can't get my project done,
so would the "Preview" be a good place to be? Especially since I seem to be there already.


Ok this is true. If you have looked at the wiki, most of the content there is mostly outdated and we should add at least a warning notice.

The new content is for the moment published on GitHub pages:

* Neon: http://eclipsescout.github.io/6.0
* Oxygen: at the moment: http://eclipsescout.github.io/6.1 (will be 7.0 when we change the version number)

I hope this helps.
Re: [neon] Login with http works, but not https [SOLVED] [message #1747933 is a reply to message #1747607] Wed, 16 November 2016 22:20 Go to previous message
Steve Conley is currently offline Steve ConleyFriend
Messages: 11
Registered: November 2016
Junior Member
Thanks for detailed reply.

Given the above, I think I will fall back to Neon latest vs. Oxygen. Because I plan on releasing the product on Neon.
And it would seem "6.1->7.0" is not going to be supported on Neon at least at the beginning - and you probably don't want to here from me regarding those issues.

I do want to point out, if that was not clear,
https://www.eclipse.org/downloads/eclipse-packages/
directs you to:
Eclipse Neon.1a (4.6.1) Release
and under that is:
https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/neon/1a/eclipse-scout-neon-1a-linux-gtk-x86_64.tar.gz

So what happened "I think" is that when I initially tried to get things to work and they failed,
I used the eclipse update - and perhaps forgot to click the box that says only get what's appropriate for the environment.

So it seemed to get me the Oxygen stuff.

So I started from scratch again, and made sure to click the box.

This time, after getting through the "Plugin execution not covered by lifecycle configuration:" issue,
it has been smooth sailing.

I still show in installation details:
Eclipse for Scout Developers 4.6.1.20161007-1200 epp.package.scout Eclipse Packaging Project
Eclipse Scout SDK (Binary only) 6.0.100.RC4 org.eclipse.scout.sdk-feature.feature.group Eclipse Scout Project

but about half the entries that I had before.

I suppose the 20161007-1200 only applies to the "packaging" of eclipse and scout - and that the "fixes/changes" are in eclipse neon - NOT scout.

because it seems (maybe) to be covered by the SDK at 6.0.100.RC4.

Steve

Previous Topic:[NEON] Refresh Ui Component instantly
Next Topic:Hide page up/down arrows
Goto Forum:
  


Current Time: Fri Oct 20 01:21:41 GMT 2017

Powered by FUDForum. Page generated in 0.02205 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software